Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Trunking on Cisco SF300 Issue

Hello Friends,

 

Issue: I have 3 Cisco SF300 multilayer switches, I have configured one switch as a core switch and changed the mode to Router (from layer2 to Layer3) and configured Vlans and DHCP pools accordingly, but when i am trying to connect another SF300 to this switch by using VTP it's giving error then i tried searching a solution and found that it does not support VTP protocol, can someone please help me on that, how i can connect other SF300 to this core switch by using trunking.

 

My goal is to connect the Switch1 and Switch2 to the CoreSwitch by using trunking so that CoreSwitch can advertise all Vlan information to Switch1 and 2. and PC connected to Switch1 & 2 on different Vlans can communicate to each other.

 

Network Diagram:

CoreSwitch fast-Ethernet port 1 to 8 are connected to Huwai Router Port 1 to 8 using a dedicated physical enter phase to connect each Vlan to the internet. using Nat overload.   CoreSwitch's fastethernet Port 9 to 24 are disabled, gigabit port 1 to 4 are trunk port and allowed vlan are 11, 12,13,14,15,16,17 and 20.

 

Note: All 3 switches are in Layer3 mode.

CoreSwitch Gigabit ethernet Port1 connected to = Switch1 gigabit ethernet port 1 

CoreSwitch Gigabit ethernet Port2 connected to = Switch2 gigabit ethernet port 2

Switch1 Gigabit ethernet Port4 connected to = Switch2 gigabit ethernet port 4

 

Configuration:

 

CoreSwitch:

User Name:cisco
Password:XXXXXXX

Welcome to CoreSwitch.

Regards,
Sandy

CoreSwitch#show run
config-file-header
CoreSwitch
v1.3.7.18 / R750_NIK_1_35_647_358
CLI v1.0
set system mode router

file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
spanning-tree priority 0
vlan database
vlan 11-17,20
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
gvrp enable
ip dhcp excluded-address 192.168.11.1 192.168.11.2
ip dhcp excluded-address 192.168.12.1 192.168.12.2
ip dhcp excluded-address 192.168.13.1 192.168.13.2
ip dhcp excluded-address 192.168.14.1 192.168.14.2
ip dhcp excluded-address 192.168.15.1 192.168.15.2
ip dhcp excluded-address 192.168.16.1 192.168.16.2
ip dhcp excluded-address 192.168.17.1 192.168.17.2
ip dhcp pool network CashOfficedepo
address low 192.168.12.1 high 192.168.12.254 255.255.255.0
default-router 192.168.12.1
dns-server 192.168.20.3 192.168.20.4
exit
ip dhcp pool network Churn5StarPayrollWeb
address low 192.168.11.1 high 192.168.11.254 255.255.255.0
default-router 192.168.11.1
dns-server 192.168.20.3 192.168.20.4
exit
ip dhcp pool network Commission
address low 192.168.13.1 high 192.168.13.254 255.255.255.0
default-router 192.168.13.1
dns-server 192.168.20.3 192.168.20.4
exit
ip dhcp pool network Inventory
address low 192.168.15.1 high 192.168.15.254 255.255.255.0
default-router 192.168.15.1
dns-server 192.168.20.3 192.168.20.4
exit
ip dhcp pool network Managers
address low 192.168.17.1 high 192.168.17.254 255.255.255.0
default-router 192.168.17.1
dns-server 192.168.20.3 192.168.20.4
exit
ip dhcp pool network ReportingAccount
address low 192.168.14.1 high 192.168.14.254 255.255.255.0
default-router 192.168.14.1
dns-server 192.168.20.3 192.168.20.4
exit
ip dhcp pool network TechDept
address low 192.168.16.1 high 192.168.16.254 255.255.255.0
default-router 192.168.16.1
dns-server 192.168.20.3 192.168.20.4
exit
bonjour interface range vlan 1
hostname CoreSwitch
snmp-server location
snmp-server contact
clock timezone " " 0 minutes 0
ip name-server  202.XXX.XXX.XXX       
ip telnet server
!
interface vlan 1
 ip address 192.168.10.3 255.255.255.0
 no ip address dhcp
!
interface vlan 11
 name Churn5StarPayrollWeb
 ip address 192.168.11.1 255.255.255.0
!
interface vlan 12
 name CashOfficedepo
 ip address 192.168.12.1 255.255.255.0
!
interface vlan 13
 name Commission
 ip address 192.168.13.1 255.255.255.0
!
interface vlan 14
 name ReportingAccount
 ip address 192.168.14.1 255.255.255.0
!
interface vlan 15
 name Inventory
 ip address 192.168.15.1 255.255.255.0
!
interface vlan 16
 name TechDept
 ip address 192.168.16.1 255.255.255.0
!
interface vlan 17
 name Managers
 ip address 192.168.17.1 255.255.255.0
!
interface vlan 20
 name SERVERS
 ip address 192.168.20.1 255.255.255.0
!
interface fastethernet1
 switchport trunk allowed vlan add 11
!
interface fastethernet2
 switchport trunk allowed vlan add 12
!
interface fastethernet3
 switchport trunk allowed vlan add 13
!
interface fastethernet4
 switchport trunk allowed vlan add 14
!
interface fastethernet5
 switchport trunk allowed vlan add 15
!
interface fastethernet6
 switchport trunk allowed vlan add 16
!
interface fastethernet7
 switchport trunk allowed vlan add 17
!
interface fastethernet8
 switchport trunk allowed vlan add 20
!
interface fastethernet9
 shutdown
!
interface fastethernet10
 shutdown
!
interface fastethernet11
 shutdown
!
interface fastethernet12
 shutdown
!
interface fastethernet13
 shutdown
!
interface fastethernet14
 shutdown
!
interface fastethernet15
 shutdown
!
interface fastethernet16
 shutdown
!
interface fastethernet17
 shutdown
!
interface fastethernet18
 shutdown
!
interface fastethernet19
 shutdown
!
interface fastethernet20
 shutdown
!
interface fastethernet21
 shutdown
!
interface fastethernet22
 shutdown
!
interface fastethernet23
 shutdown
!
interface fastethernet24
 shutdown
!
interface gigabitethernet1
 gvrp enable
 switchport trunk allowed vlan add 11-17,20
!
interface gigabitethernet2
 switchport trunk allowed vlan add 11-17,20
!
interface gigabitethernet3
 switchport trunk allowed vlan add 11-17,20
!
interface gigabitethernet4
 switchport trunk allowed vlan add 11-17,20
!
exit
banner login ^C
Welcome to CoreSwitch.


Regards,
Sandy
^C
banner exec ^C
Welcome to CoreSwitch.


Regards,
Sandy
^C
ip default-gateway 192.168.11.2   (huwai router's fast ethernet port1 ip address)
ip default-gateway 192.168.12.2   (huwai router's fast ethernet port2 ip address)
ip default-gateway 192.168.13.2   (huwai router's fast ethernet port3 ip address)
ip default-gateway 192.168.14.2   (huwai router's fast ethernet port4 ip address)
ip default-gateway 192.168.15.2   (huwai router's fast ethernet port5 ip address)
ip default-gateway 192.168.16.2   (huwai router's fast ethernet port6 ip address)
ip default-gateway 192.168.17.2   (huwai router's fast ethernet port7 ip address)
ip default-gateway 192.168.20.2   (huwai router's fast ethernet port8 ip address)
CoreSwitch#

 

=====================

Switch1: no configuration yet (Tried configuring VTP but got no luck, it's not supported so i turned on the GVRP...running RSTP and spanning-tree priority is 4096)

=====================

Switch2:  no configuration yet.....

 

 

Thanks,

Sandy

Everyone's tags (1)
2 ACCEPTED SOLUTIONS

Accepted Solutions

You don't need VTP to create

You don't need VTP to create a trunk between 2 switches. Just set the interface as trunk and what VLANs you want allowed. Do this for both sides.

By the time you have GVRP

By the time you have GVRP configured you should have configured everything manually. It will only assign something if it is predefined. Save yourself the headache and configure it manually.

5 REPLIES

You don't need VTP to create

You don't need VTP to create a trunk between 2 switches. Just set the interface as trunk and what VLANs you want allowed. Do this for both sides.

New Member

CoreSwitch:show run command

CoreSwitch:

show run command output for gigabit interface1:

interface gigabitethernet1
 gvrp enable
 switchport trunk allowed vlan add 11-17,20
!

Switch1:

show run command output for gigabit interface1:

interface gigabitethernet1
 gvrp enable
!

But it is not allowing me to add VLans...as Vlan are created on CoreSwitch..find the below mentioned command line i tried on Switch1;

AccessLayer1#conf t
AccessLayer1(config)#interface GigabitEthernet 1
AccessLayer1(config-if)#switchport mode trunk
AccessLayer1(config-if)#switchport trunk allowed vlan
  add                  Specify which VLAN to add to the port.
  remove               Specify the VLAN to remove from port.
AccessLayer1(config-if)#switchport trunk allowed vlan add 11-17,20
VLAN 11 : VLAN was not created by user.
AccessLayer1(config-if)#

1: So should i create Vlans on Switch1 manually ? as Cisco SF300 do not support VTP and support GVRP,

2: in STP we do not need to create Vlans on a client switch but i do not know how to configure GVRP trunking...

 

Thanks,

Sandy

By the time you have GVRP

By the time you have GVRP configured you should have configured everything manually. It will only assign something if it is predefined. Save yourself the headache and configure it manually.

New Member

Please find the below

Please find the below mentioned show vlan output of both the Switches  :

CoreSwitch#show vlan
Created by: D-Default, S-Static, G-GVRP, R-Radius Assigned VLAN

Vlan       Name                   Ports               Created by
---- ----------------- --------------------------- ----------------
 1           1             fa1-24,gi1-4,Po1-8             D
 11  Churn5StarPayroll          fa1,gi1-4                 S
     Web
 12   CashOfficedepo            fa2,gi1-4                 S
 13     Commission              fa3,gi1-4                 S
 14  ReportingAccount           fa4,gi1-4                 S
 15      Inventory              fa5,gi1-4                 S
 16      TechDept               fa6,gi1-4                 S
 17      Managers               fa7,gi1-4                 S
 20       SERVERS               fa8,gi1-4                 S

 

AccessLayer1#show vlan

Vlan       Name                   Ports                Type     Authorization
---- ----------------- --------------------------- ------------ -------------
 1           1             fa1-24,gi1-4,Po1-8        Default      Required

AccessLayer1#

 

 

I just wondering that i have enabled GVRP on both side and made them trunk then why Switch1 is not showing me the Vlan i created on CoreSwitch :(

 

Thanks,

Sandy

New Member

yes i got the solution....i

yes i got the solution....i have to manually create Vlan on client switch as GVRP do not advertise the Vla to other switches like VTP does. this is the disadvantage of using GVRP over VTP. :(

 

Solution is: Turn on the trunking on both side and enable GVRP globally and then on the port which is connected to the other switch and then allow the vlans you have created on your core switch.

and you are good to go!!!

 

Thanks,

Sandy
 

382
Views
0
Helpful
5
Replies
CreatePlease login to create content