Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Trunking port

I have a Cisco 2960s stack. I trying to trunk a port with an Avaya POE switch. Port is trunked on the Cisco side correctly (I believe). When you configure tag all on the Avaya side, I lose all communication with that switch. Only 2 VLANs on both switches.                  

Everyone's tags (3)
7 REPLIES
Cisco Employee

Trunking port

Sean,

Is it possible that the Avaya tags all VLANs including the VLAN that is configured as native VLAN on the Cisco side? If that was the case then it is probable that untagged frames in the native VLAN sent from Cisco are dropped on the Avaya switch. Just for sake of completeness, a correct trunk port configuration on the Cisco switch should be done via switchport mode trunk command.

Would you mind trying to configuring a totally unused VLAN on your Cisco port as the native VLAN? You do not even need to create it, just use the switchport trunk native vlan X to define X as the native VLAN. Make sure it is not any of currently used VLANs.

Best regards,

Peter

Community Member

Trunking port

Peter-

I did try this and it did not correct the issue.

Sean

Community Member

Trunking port

Peter-

Here's a reply from another engineer I'm working with:

We’ve tried Tagall and untagPVID only…. Tagall will tag all packets with the VLAN ID whereas untagpvid will set vlan 1 as untagged and all other VLANs as tagged.

Dave did try configuring a non-used VLAN as the native VLAN on both the Cisco and Avaya switches, but that did not appear to have solved the issue either.

For the most part, every other install we have done, we’ve set the avaya tagging as TagAll and that has worked with the other cisco equipment.

The only difference really is that at three of my school we have 2960s stacks that the Avaya POE switch is trunked too (this is the first of those three locations that we are encountering this issue). All my other locations have 3750X switch stacks and everything is functioning as expected.

Sean

Cisco Employee

Trunking port

Hi Sean,

Hmmm... I believe that at this point, seeing the configuration of both switches would be helpful.

Best regards,

Peter

Community Member

Trunking port

Peter-

Would you like to see configs from both the Avaya and the Cisco switches? Do you want me to post them here?

Sean

Cisco Employee

Trunking port

Hi Sean,

Yes, if possible please post the configurations here. If you click on the "Use advanced editor" feature you will be able to attach files instead of posting them in text form. Please remove sensitive information such as addresses and passwords but do not otherwise remove lines from your configs.

Best regards,

Peter

Community Member

Trunking port

Hi sean,

Did you try configuring "switchport nonegotiate" along with switchport mode trunk to disable DTP.

Set this port as trunk port unconditionally.

Also check, is there any STP issue which is causing this issue.

Verify the output of show spanning-tree

Rajmohan R
340
Views
0
Helpful
7
Replies
CreatePlease to create content