Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

trying to disable telnet once and for all.

Switch#sh run

Building configuration...

Current configuration : 2455 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Switch

!

aaa new-model

aaa authentication login default local

aaa authorization exec default local

aaa authorization network default local

enable password xxx

!

username admin privilege 15 password 0 xxx

clock timezone mst -7

ip subnet-zero

!

ip domain-name co-locate

ip ssh time-out 120

ip ssh authentication-retries 3

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface FastEthernet0/25

!

interface FastEthernet0/26

!

interface FastEthernet0/27

!

interface FastEthernet0/28

!

interface FastEthernet0/29

switchport access vlan 520

!

interface FastEthernet0/30

switchport access vlan 520

!

interface FastEthernet0/31

switchport access vlan 520

speed 100

duplex full

!

interface FastEthernet0/32

switchport access vlan 520

!

interface FastEthernet0/33

!

interface FastEthernet0/34

!

interface FastEthernet0/35

!

interface FastEthernet0/36

!

interface FastEthernet0/37

!

interface FastEthernet0/38

!

interface FastEthernet0/39

!

interface FastEthernet0/40

!

interface FastEthernet0/41

!

interface FastEthernet0/42

!

interface FastEthernet0/43

!

interface FastEthernet0/44

!

interface FastEthernet0/45

!

interface FastEthernet0/46

!

interface FastEthernet0/47

switchport access vlan 12

!

interface FastEthernet0/48

switchport access vlan 12

speed 10

duplex half

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

no ip address

no ip route-cache

shutdown

!

interface Vlan520

ip address 172.17.193.11 255.255.255.0

no ip route-cache

!

ip default-gateway 172.17.193.1

ip http server

!

line con 0

line vty 5 15

!

!

end

Switch#

^^^^^^^^^^^^^^^^

I thought removing the telnet password from line vty 0 15 would do it but I am still able to telnet in. It ask me for username and pw...and then it goes straight to enable mode.

6 REPLIES

Re: trying to disable telnet once and for all.

xxx(config-line)#transport input ?

all All protocols

lapb-ta LAPB Terminal Adapter

mop DEC MOP Remote Console Protocol

none No protocols

pad X.3 PAD

rlogin Unix rlogin protocol

ssh TCP/IP SSH protocol

telnet TCP/IP Telnet protocol

udptn UDPTN async via UDP protocol

v120 Async over ISDN

you can use keyword "none".

or just enable only ssh, which I prefer.

Community Member

Re: trying to disable telnet once and for all.

Perfect..exactly what I needed. Thanks

Re: trying to disable telnet once and for all.

if it helps, rate the post

Thanks

Community Member

Re: trying to disable telnet once and for all.

I'm also trying to turn off telnet, how do you just turn on ssh?

Re: trying to disable telnet once and for all.

transport input ssh

Hall of Fame Super Gold

Re: trying to disable telnet once and for all.

David

To enable SSH and disable telnet configure this under all your vty lines:

transport input ssh

That will enable SSH and will not enable telnet. For SSH to work you will need to generate RSA keys.

HTH

Rick

297
Views
10
Helpful
6
Replies
CreatePlease to create content