Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Trying to UDP Forward for WOL Help

Hi All, we have a software application that we are trying to use for WOL. It says that its forwarding using port 7725. I thought I had all my ducks in row. I configured my access list, tagged the the SVI with the ip directed broadcast, and added ip forward-protocol udp 7725. However when I try my software app I can never get outside of the subnet that the server is connceted to. Both the server and one of my data networks share the same subnet however, I have a handful of other subnets that I need to forward this port. Here is a partial config of "DO-Switch" which has the server and some hosts in VLAN 1 then another switch's config that has serveral other VLANS that need WOL.

***DO-Switch***

interface Vlan1

ip address 10.1.0.1 255.255.240.0

ip directed-broadcast 101

no ip mroute-cache

!

interface Vlan252

description Wireless WAN B Layer3

ip address 192.168.252.2 255.255.255.0

ip directed-broadcast 101

ip pim sparse-dense-mode

!

router eigrp 100

redistribute static

network 10.0.0.0

network 172.16.0.0

network 192.168.249.0

network 192.168.251.0

network 192.168.252.0

network 192.168.253.0

network 192.168.254.0

no auto-summary

!

ip classless

ip forward-protocol udp 7725

ip route 0.0.0.0 0.0.0.0 192.168.254.1

no ip http server

!

!

access-list 101 permit udp host 10.1.0.6 any eq 7725

----------------------------------------------------------

***Core-Switch***

interface Vlan3

ip address 10.3.0.1 255.255.240.0

ip helper-address 10.2.0.4

ip helper-address 10.2.0.13

ip directed-broadcast 101

ip pim passive

!

interface Vlan4

ip address 10.4.0.1 255.255.240.0

ip helper-address 10.2.0.4

ip helper-address 10.2.0.13

ip directed-broadcast 101

ip pim passive

!

interface Vlan252

description Wireless WAN B Layer3

ip address 192.168.252.1 255.255.255.0

ip directed-broadcast 101

ip pim passive

!

router eigrp 100

no auto-summary

eigrp stub connected summary

network 10.0.0.0

network 192.168.251.0

network 192.168.252.0

network 192.168.254.0

!

ip classless

ip forward-protocol udp 7725

no ip http server

ip http secure-server

!

no logging trap

access-list 101 permit udp host 10.1.0.6 any eq 7725

Ip address 10.1.0.6 is the WOL server

thanks for the help,

Mike

6 REPLIES
Hall of Fame Super Silver

Re: Trying to UDP Forward for WOL Help

Hello Mike,

I think you should use

ip helper-address 10.x.y.255

the command you have used is declared to convert a directed broadcast to a broadcast but you need to propagate the broadast from the subnet where the server is to all the other client vlans

int vlan 1

ip helper-address directed-broadcast-subnet1

ip helper-address directed-broadcast-subnet2

...

ip helper-address directed-broadcast-subnetN

see

http://www.cisco.com/en/US/docs/ios/ipapp/command/reference/iap_i1.html#wp1052696

if the server sends out broadcast packets to make them reach the other subnets you need to use ip helper-address command for each client vlan under the SVI that processes the server traffic

Hope to help

Giuseppe

New Member

Re: Trying to UDP Forward for WOL Help

Thanks for the reply, where should I add the "ip helper-address 10.x.y.255 " command to every SVI with the exception of Vlan 1? Will this interfere with the other "ip helper-address" commands that I have already set up on the SVI for DHCP? If thats the case do I still need my Access-list and "directed broadcast" command?

thanks,

Mike

Hall of Fame Super Silver

Re: Trying to UDP Forward for WOL Help

Hello Mike,

the commands I have suggested need to be added only to the vlan where the server is connected to, that is vlan1 in your scenario.

My suggestion starts from the guess that the server is probably sending packets with a broadcast destination.

So its action is currently confined only on the vlan/subnet where the server is connected to.

So in my opinion you need to add the ip helper-address commands only to Vlan1

helper-address command instructs the router to convert a non routable broadcast to a routable unicast or directed broadcast that can reach other IP subnets.

Hope to help

Giuseppe

Blue

Re: Trying to UDP Forward for WOL Help

Mike:

Keep a few things in mind as you configure this:

1.) The ip forward-protocol command alone does nothing. You need the ip helper-address command, too. The helper address command lets the router interface know that it will be receiving a UDP broadcast from a directly connected client and that it should repackage it as either a directed broadcast to a specific destination subnet or a unicast to a specific machine.

By default, the helper address allows 8 different UDP-based applications to get forwarded, excluding WOL. That is why you need the ip forward-protocol command: to add that UDP-based application to the list of forwarded applications.

2.) The ip directed-broadcast command should be applied to the vlan interface that is expected to receive the directed broadcast from the sending/forwarding router. The directed broadcast is a tool sometimes used by hackers to launch a denial of service attack, so routers block directed broadcasts that are destined for directly connected hosts hanging off the interface.

So, you are dealing with broadcasts in 2 directions - the send side, which is why we use the helper address and the forward protocol commands, and the receive side, which is why we use the ip directed broadcast command.

HTH

Victor

New Member

Re: Trying to UDP Forward for WOL Help

Thanks both you. It's much more clearer now. Identifying the UDP port it was broadcasting was a bit of a pain but, once I had that any both of yours info got it knocked out.

thanks again,

Mike

Blue

Re: Trying to UDP Forward for WOL Help

Mike:

Congratulations. Glad we could help.

Thanks for the rating...

Victor

694
Views
15
Helpful
6
Replies
CreatePlease to create content