Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Two Data Vlans + Voice Vlan

Hello

I have two Vlan (Data 10 and voice 20) configured in my Catalyst switch.

Ip phones are conected to the Catalyst and workstations are connected to the Ip phones , every device receive the correct Ip address .

Now , I should add a new data Vlan (30) and I want to:

Ip phones gets Ip address from Vlan 20

Some Workstations gets Ip address from Vlan 10

Some workstations gets Ip address from Vlna 30

*All workstations shoud be connected to Ip phones.

Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Two Data Vlans + Voice Vlan

Rodrigo,

Okay, That was an old style configuration. You are mixing something in your configuration. (grin) The opration of the port is Trunk because of a "swi mo trunk" command. No need to have "switch port access vlan 20" there. Okay, go to the point,you just change the native vlan to what you want users to be in.

HTH,

Toshi

4 REPLIES

Re: Two Data Vlans + Voice Vlan

Rodrigo,

You just do the same way you did before.

- Add a new vlan on the switch you mentioned.

- Add a vlan interface for vlan 30. Including ip helper command on it (if needed).

- Create a new dhcp pool for vlan 30 on the device.

- Modify access vlan for users to be either on vlan 20 or 30.

F.e.

!

int g1/0/1

switchport access vlan 30

switchport mode access

switchport voice vlan 20

!

HTH,

Toshi

Re: Two Data Vlans + Voice Vlan

Thanks for the answer.

It sounds easy ,..

I didn't do the switch config .When I saw runn config for an specific port I could see :

switchport access vlan 20

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport mode trunk

switchport voice vlan 20

So I thought that the trunk port sent tagged packets for the Ip phone and untaged for workstations so I wondered if I shoulded change the native Vlan depending of what worksation is connected. Do you know what I mean?

Re: Two Data Vlans + Voice Vlan

Rodrigo,

Okay, That was an old style configuration. You are mixing something in your configuration. (grin) The opration of the port is Trunk because of a "swi mo trunk" command. No need to have "switch port access vlan 20" there. Okay, go to the point,you just change the native vlan to what you want users to be in.

HTH,

Toshi

Bronze

Re: Two Data Vlans + Voice Vlan

Hi.

One thing to note: Toshi's reply assumes that the IP Phones are Cisco IP Phones. Then it is correct that you only need this:

switchport mode access

switchport access vlan 30

switchport voice vlan 20

If the IP Phones are of another make, your config looks right and then you will have to make VLAN30 the native VLAN for those interfaces where you want to have VLAN30 as data vlan, as you mention.

HTH, Ingolf

109
Views
0
Helpful
4
Replies