Cisco Support Community
Community Member

Two DHCPs, one is slow to send the offer

Hello, I have a small issue about DHCP, I need two servers of DHCP.

1 - Provide by Switch Cisco  range

2 - Provide by Windows Server range

Everything works ok, but when I have a Computer using vlan 101 (at interface GigabitEthernet2/0/1) the DHCP is to slow, at debug mode I can read no dhcp pool for vlan 101,

then I see forward to, but this process is to slow, my computer need about 30 seconds (at wireshark I watch about 10 lines of resquest form the computer).

The configuration of the switch:

ip dhcp excluded-address


service dhcp


ip dhcp pool Wifi-Guest





interface Vlan100

description ### Wireless - SSID ###

ip address


interface Vlan101

description ### Wireless - SSID ###

ip address

ip helper-address


interface GigabitEthernet2/0/1

switchport mode access

switchport access vlan 101

spanning-tree portfast

spanning-tree bpduguard enable

My point is, how to disable DHCP server to vlan 101, I have try this:

ip dhcp excluded-address

but didn’t work... the speed is slow.

Also try to

interface Vlan101

no ip dhcp-server... but this command dont work obligate to "no ip dhcp server use subscriber-id"

Anyone have ideas to block or disable dhcp to vlan 101 on the switch dhcp server?.

Thanks in advance

Hall of Fame Super Blue

Re: Two DHCPs, one is slow to send the offer

interface vlan 101

no ip helper-address

CreatePlease to create content