Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

two hsrp on two interface two router

It is possible to have two HSRP on two interfaces on two routers ?

ROUTER 1
track 1 interface GigabitEthernet0/1 line-protocol
!
interface GigabitEthernet0/0
ip address 172.16.1.11 255.255.0.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
standby 10 ip 172.16.1.10
standby 10 priority 110
standby 10 preempt
standby 10 authentication crs-siss
standby 10 track 1 decrement 20
!
!
interface GigabitEthernet0/1
ip address 95.14.60.222 255.255.255.224
ip access-group 116 in
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
standby 20 ip 95.14.60.221
standby 20 priority 110
standby 20 preempt
standby 20 authentication crs-siss
standby 20 track 2 decrement 20

=============================================
ROUTER 2
track 1 interface GigabitEthernet0/1 line-protocol
!
interface GigabitEthernet0/0
ip address 172.16.1.12 255.255.0.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
standby 10 ip 172.16.1.10
standby 10 priority 110
standby 10 preempt
standby 10 authentication crs-siss
standby 10 track 1 decrement 20
!
!
interface GigabitEthernet0/1
ip address 95.14.60.223 255.255.255.224
ip access-group 116 in
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
standby 20 ip 95.14.60.221
standby 20 priority 110
standby 20 preempt
standby 20 authentication crs-siss
standby 20 track 2 decrement 20

It is correct ???

thank you

  • LAN Switching and Routing
2 REPLIES

two hsrp on two interface two router

Yes, you can do this. You're tracking 2 though and that tracking instance doesn't exist, so don't forget to create that. Your priorities are the same across the board. If you don't want to specify which router is going to be the active in the pair, then I wouldn't even change the priorities because they default to 100. Personally, I'd select which router I'd want as the active by making one priority 110 and the other at 105. When the failover happens for reasons of tracking, you'll decrement by 20 making the primary 90 and the other is now at 105 and your active. When the other comes back online, it will take over because its priority changes back to 110.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

two hsrp on two interface two router

hello john

on router 1 I have to put

ROUTER 1
track 1 interface GigabitEthernet0/1 line-protocol
track 2 interface GigabitEthernet0/0 line-protocol

!
interface GigabitEthernet0/0
..
..
standby 10 track 1 decrement 20
!
!
interface GigabitEthernet0/1
..
..
standby 20 track 2 decrement 20

=============================================

and on router 2 I have to put

ROUTER 2
track 1 interface GigabitEthernet0/1 line-protocol
track 2 interface GigabitEthernet0/0 line-protocol

!
interface GigabitEthernet0/0
..
..
standby 10 track 1 decrement 20
!
!
interface GigabitEthernet0/1
..
..
standby 20 track 2 decrement 20


correct ???

199
Views
0
Helpful
2
Replies
This widget could not be displayed.