Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Unable to access the internet with client machines

Hi everyone,

 

I am attempting to setup my lab to study for my CCNA and MCSA. I am incorporating this setup into my actual physical network.

I have almost everything figured out here is my setup:

ISP---Modem---Cisco 2800 Router---Catalyst 3560G Switch

connected to the switch is a Windows 2012 DHCP ADDS server and all of my client systems.

 

I have setup the NAT on the 2800

All my machines are getting the correct addressing from the DHCP server

everything is up up and looks copacetic.

 

The issue i am having now is that the silly thing wont talk to the internet, ive troubleshot and messed around with it but i just cant figure out where the disconnect is between the internet and my clients. So i am once again reaching out to the more experienced hands for help. Any ideas?

 

Thanks for the help,

 

Donnie

 

Here are my configs for both the router and switch:

Router

APPLECORE_ROUTER#show run
Building configuration...

Current configuration : 6495 bytes
!
! Last configuration change at 18:19:19 UTC Sat May 31 2014
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname APPLECORE_ROUTER
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
enable secret 4 JmQOf2aMz5LDl56NetDgeW0L/tIT2CPDJ2FFnaMQN76
!
no aaa new-model
!
memory-size iomem 20
dot11 syslog
ip source-route
!
!
!
!
!
ip cef
no ip domain lookup
ip domain name BchekInternetworking.local
!
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-644888447
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-644888447
 revocation-check none
 rsakeypair TP-self-signed-644888447
!
!
crypto pki certificate chain TP-self-signed-644888447
 certificate self-signed 01
  30820229 30820192 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 36343438 38383434 37301E17 0D313430 35333030 36353931
  365A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3634 34383838
  34343730 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
  C13CF29E 20201B11 7188158E 64A2F232 AA77ED7B A6B754C6 3552AA0C 873FB01F
  801FF6B2 33933A3A D3DBFC9B 79F790D0 7494EC10 BA16BB5B 69D4EF92 4771C732
  D526412B 92B40B92 CA3BD38C 33EA8822 7AA32558 184A6F1D C0C923DD D6D0B639
  63E8B7E3 EE258F0E 08090272 7FC2088D 74CE8508 8A8A4B9D 93D76643 EEB57371
  02030100 01A35330 51300F06 03551D13 0101FF04 05300301 01FF301F 0603551D
  23041830 168014DB EA1824EB E4743894 899F283C AED93004 CADC3D30 1D060355
  1D0E0416 0414DBEA 1824EBE4 74389489 9F283CAE D93004CA DC3D300D 06092A86
  4886F70D 01010505 00038181 006BA8E1 5FC2E5AA 3EEF9F1F 04C71ABD 5DD3BD74
  F555E4F2 4FAA03C7 9DDB5662 C2B8F294 CA73023F AD908E5B 9AE9FA74 8530229D
  03C527FD 8B11596F 8A8C9AF0 D05C54FD 67718268 02A22359 DD6E326D 6945925C
  E4BB2855 8D757BBB A09323B3 7684D3DC 23C094D9 237DFEA7 B96E73BE DF85BCC6
  A8E31A62 3C611839 489DF3F5 C4
        quit
!
!
license udi pid CISCO2801 sn FTX1110Z0UN
username donbie privilege 15 password 7 032D55180702204241060B5043
!
redundancy
!
interface FastEthernet0/0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.10
 encapsulation dot1Q 10
 ip address 10.227.10.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface FastEthernet0/1.20
 encapsulation dot1Q 20
 ip address 10.227.20.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface FastEthernet0/1.30
 encapsulation dot1Q 30
 ip address 10.227.30.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
ip forward-protocol nd
!
!
ip http server
ip http authentication local
ip http secure-server
ip nat source list HOME interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
ip access-list extended HOME
 permit ip 10.227.10.0 0.0.0.255 any
 permit ip 10.227.20.0 0.0.0.255 any
 permit ip 10.227.30.0 0.0.0.255 any
!
!
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 5 30
 password 7 022F0A480A0B0E2F43411B4C51
 login
line aux 0
 exec-timeout 5 30
 password 7 022F0A480A0B0E2F43411B4C51
 login
line vty 0 4
 exec-timeout 5 30
 privilege level 15
 password 7 153B051F05272A2A273C277747
 login local
 transport input telnet ssh
line vty 5 15
 exec-timeout 5 30
 password 7 0965401A1808161C0403167F7F
 login
 transport input all
!
scheduler allocate 20000 1000
end

 

Switch

APPLECORE_SWITCH#show run
Building configuration...

Current configuration : 6239 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname APPLECORE_SWITCH
!
enable secret 5 $1$48z5$xGKquSaTc84Wp7nALkSKs/
!
no aaa new-model
ip subnet-zero
ip routing
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/1
 description DHCP, ADDS Server
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 10
 switchport mode trunk
!
interface GigabitEthernet0/2
 description Untlangle Server
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/3
 description Cisco Wireless AP
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/4
 description Papabearmark2
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/5
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/6
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/7
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/8
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/9
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/10
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/11
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/12
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/13
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/14
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/15
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/16
 switchport access vlan 10
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/17
 switchport access vlan 20
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/18
 switchport access vlan 20
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/19
 switchport access vlan 20
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/20
 switchport access vlan 20
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/21
 switchport access vlan 20
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/22
 switchport access vlan 20
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/23
 switchport access vlan 20
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/24
 switchport access vlan 20
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/25
 switchport access vlan 20
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/26
 switchport access vlan 20
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/27
 switchport access vlan 20
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/28
 switchport access vlan 20
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/29
 switchport access vlan 20
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/30
 switchport access vlan 20
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/31
 switchport access vlan 20
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/32
 switchport access vlan 20
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/33
 switchport access vlan 30
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/34
 switchport access vlan 30
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/35
 switchport access vlan 30
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/36
 switchport access vlan 30
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/37
 switchport access vlan 30
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/38
 switchport access vlan 30
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/39
 switchport access vlan 30
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/40
 switchport access vlan 30
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/41
 switchport access vlan 30
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/42
 switchport access vlan 30
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/43
 switchport access vlan 30
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/44
 switchport access vlan 30
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/45
 switchport access vlan 30
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/46
 switchport access vlan 30
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/47
 switchport access vlan 30
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/48
 switchport access vlan 30
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/49
!
interface GigabitEthernet0/50
!
interface GigabitEthernet0/51
!
interface GigabitEthernet0/52
!
interface Vlan1
 ip address 10.227.220.1 255.255.255.0
!
interface Vlan10
 ip address 10.227.10.1 255.255.255.0
 ip helper-address 10.227.10.10
!
interface Vlan20
 ip address 10.227.20.1 255.255.255.0
 ip helper-address 10.227.10.10
!
interface Vlan30
 ip address 10.227.30.1 255.255.255.0
 ip helper-address 10.227.10.10
!
router rip
 network 10.0.0.0
!
ip classless
ip http server
!
!
control-plane
!
!
line con 0
line vty 0 4
 no login
line vty 5 15
 no login
!
!
end

2 ACCEPTED SOLUTIONS

Accepted Solutions
New Member

Both your switch and router

Both your switch and router have .1 IP addresses creating a conflict. Depending on what your doing you can change the switch VLAN IP addresses and everything will use your router as the gateway or you can change the router subinterface IPs and start routing between your switch and router.
New Member

1- there are duplicate ip

1- there are duplicate ip addresses in svi interfaces of the switch in vlan 10,20,30  with subinterfaces of router in vlan 10,20,30. basically the ip addresses are same. fix them ASAP

2- share the physical connections map between your router,switch & DHCP server

3- Remove " switchport trunk native vlan 10"  from interafce g0/1 of switch

 

 

 

 

11 REPLIES
VIP Super Bronze

If everything up to the

If everything up to the router is good and working, can you change:

ip nat source list HOME interface FastEthernet0/0 overload

to

ip nat inside source list HOME interface FastEthernet0/0 overload

and test again?

HTH

New Member

No go, although im sure it

No go, although im sure it was an issue that needed to be addressed. However i did some more ping tests (kinda embarrassing that i did not do this in the first place my bad).

I can ping from the router to 8.8.8.8 successfully

when i try to ping one of my client computers from the router it fails. I am now thinking that there is a connection issue between the router and the switch. I have a cable connecting the router (fa 0/1) to the switch (ge 0/1)

any thoughts on how i should proceed or what i should do?

Thanks

VIP Super Bronze

ok, that is good info.  The

ok, that is good info.  The config on the switch (gi0/1) and the router (fa0/1) looks good.

Couple of questions:

1-Since the switch is gig and the router is fast Ethernet, they are auto negotiating.  Is the link in up and up mode?

sh ip int bri gi0/1 and on the router sh ip int bri fa0/1

2-on the switch, vlan 10 in native, can add native to the sub-interface 10 on the router and make it native?

if not, remove native vlan from the switch side and test?

 no switchport trunk native vlan 10

HTH

 

 

New Member

1)Here is the output from the

1)Here is the output from the router and switch:

Switch

sh ip int bri gi0/1
Interface              IP-Address      OK? Method Status                Protocol
GigabitEthernet0/1     unassigned      YES unset  up                    up

Router

Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/1            unassigned      YES NVRAM  up                    up

also disabled the native vlan, unfortunately it did not help i still cant ping out of the switch.

However before this post i posted another thread and a individual by the screen name of aedamasceno assisted me with the initial configuration of my router and switch, maybe i missed something or he missed something

https://supportforums.cisco.com/discussion/12218571/help-setting-my-network

 

Thanks 

 

New Member

Dear as far I understood you

Dear as far I understood you clients are behind switch and you are able to ping 8.8.8.8 from your router but once you ping from client to router (through switch) it fails, it is layer 3 switch but I am unable to see in the config you provided "ip default-network/gateway (router interface ip)" furthermore you can put manual route in layer 3 switch like ip route 0.0.0.0 0.0.0.0 (Router Interface) I believe you have internal routing issue, kindly do this thing and let me know.

 

Thanks

Uzair

New Member

if possible kindly share the

if possible kindly share the trace result from PC and switch, plus did you enable RIP version 2 ? I cannot see any DHCP pool as well.

 

Regards,

Uzair

New Member

Both your switch and router

Both your switch and router have .1 IP addresses creating a conflict. Depending on what your doing you can change the switch VLAN IP addresses and everything will use your router as the gateway or you can change the router subinterface IPs and start routing between your switch and router.
New Member

Can you show me where you are

Can you show me where you are seeing this?

New Member

If you look at the fa0/1

If you look at the fa0/1 subinterfaces on the router and then look at the very bottom of your switch config. You'll see that the router subinterfaces have the same IPs as the VLAN interfaces on your switch.
New Member

1- there are duplicate ip

1- there are duplicate ip addresses in svi interfaces of the switch in vlan 10,20,30  with subinterfaces of router in vlan 10,20,30. basically the ip addresses are same. fix them ASAP

2- share the physical connections map between your router,switch & DHCP server

3- Remove " switchport trunk native vlan 10"  from interafce g0/1 of switch

 

 

 

 

New Member

That did it, the ip of the

That did it, the ip of the router and switch were conflicting changing that made the whole thing work.

Thanks so much for your help =D

Cheers,

Donnie

138
Views
5
Helpful
11
Replies
CreatePlease to create content