Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Unable to apply service policy to a sub interface (frame-relay)

Hello Expert,

I am tring to apply a service policy to a router that is on the frame-relay platform.

The serial interface use sub interface .

When I attempt to apply the service policy the following error message occurs

The qos policy configured with queuing parameters. A qos policy with queuing configuration is not allow on sub interface.

Can anyone assist with a solution.

Jomo

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Unable to apply service policy to a sub interface (frame-rel

Hello Jomo,

To remove the service policy from a Frame Relay (sub)interface, remove the added command frame-relay class. That should do the trick. In order to completely remove any queueing configuration, you should also remove the frame-relay traffic-shaping command from the main physical interface as well.

Best regards,

Peter

14 REPLIES
Cisco Employee

Re: Unable to apply service policy to a sub interface (frame-rel

Hello,

Can you please post here the configuration of your class maps, policy map and the configuration of the Frame Relay subinterface?

Best regards,

Peter

New Member

Re: Unable to apply service policy to a sub interface (frame-rel

Hello Peter,

>> Can you please post here the configuration of your class maps, policy map and the configuration of the Frame Relay subinterface?

Attach is the above request

Reagards

Jomo

Cisco Employee

Re: Unable to apply service policy to a sub interface (frame-rel

Hello Jomo,

Sorry for replying lately. I suggest reading this document:

http://www.cisco.com/en/US/partner/tech/tk543/tk545/technologies_tech_note09186a008009489a.shtml

According to that document, it is necessary to activate the support for the Frame Relay Traffic Shaping. We won't be using the actual shaping but the support for using CBWFQ falls under the FRTS functionality. Then, we can encapsulate the existing policy-map into a map-class construct and use that on the subinterface. Thus, your configuration can be modified as follows:

map-class frame-relay FR_QoS

service-policy output Qos_Internet

interface Serial0/0/0

frame-relay traffic-shaping

interface Serial0/0/0.1

frame-relay interface-dlci 16 IETF

  class FR_QoS

Give it a try and please let us know if it worked for you. Thanks!

Best regards,

Peter

New Member

Re: Unable to apply service policy to a sub interface (frame-rel

hello Peter,

I am having some problems do the last part of configuration (see below)

interface Serial0/0/0.1
frame-relay interface-dlci 16 IETF
  class FR_QoS

Note the first two configuration was done okay

map-class frame-relay FR_QoS
service-policy output Qos_Internet

interface Serial0/0/0
frame-relay traffic-shaping

Regards

Jomo

Cisco Employee

Re: Unable to apply service policy to a sub interface (frame-rel

Hello Jomo,

What problems exactly have you ecountered? So far, you have only indicated that something went wrong. Can you describe it in more detail? If the router produced an error message, please post it here as well.

Best regards,

Peter

New Member

Re: Unable to apply service policy to a sub interface (frame-rel

Hello Peter,

I am getting the same error as the first post

The qos policy configured with queuing parameters. A qos policy with queuing configuration is not allow on sub interface.

This is the config after I did the ajustment on the router

interface Serial0/0/0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
encapsulation frame-relay
ip route-cache flow
no fair-queue
frame-relay traffic-shaping
frame-relay lmi-type ansi
!
interface Serial0/0/0.1 point-to-point
description Linden Wan Interface
ip address xx.x.x.7 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip ospf mtu-ignore
frame-relay class FR_Qos------------------------------------------------------------ unsure about the line
frame-relay interface-dlci 16 IETF

Regards

Cisco Employee

Re: Unable to apply service policy to a sub interface (frame-rel

Jomo,

That frame-relay class command is okay, you may leave your configuration as it is now and you should now verify whether the QoS policy really works as expected.

Note that you have used a different capitalization - your output contains the string FR_Qos instead of FR_QoS while the name of the map-class was indeed FR_QoS. These names are generally case-sensitive. Can you verify that and correct it?

What worries me, however, is that the command was not accepted under the frame-relay interface-dlci mode. I have tested the syntactical correctness on 2691 IOS 12.4(15)T13 and it was accepted just fine. What is your router and your IOS version? Also, what kind of serial interface are you using?

Best regards,

Peter

New Member

Re: Unable to apply service policy to a sub interface (frame-rel

Hello Peter,

>>>  Note that you have used a different capitalization - your output contains the string FR_Qos instead of FR_QoS while the name of the map-  class   was indeed FR_QoS. These names are generally case-sensitive. Can you verify that and correct it?

I nullify the incorrect string and replace same with the correct (FR_QoS ).

interface Serial0/0/0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
encapsulation frame-relay
ip route-cache flow
no fair-queue
frame-relay traffic-shaping
frame-relay lmi-type ansi
!
interface Serial0/0/0.1 point-to-point
description Linden Wan Interface
ip address xx.x.x.7 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip ospf mtu-ignore
frame-relay class FR_QoS
frame-relay interface-dlci 16 IETF

>>> What is your router and your IOS version? Also, what kind of serial interface are you using?

This is the show version output of the router: show version
!----------------------------------------------------------------------------
Cisco IOS Software, 2800 Software (C2800NM-ADVSECURITYK9-M), Version 12.4(3i), RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Wed 28-Nov-07 21:10 by stshen

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

router07 uptime is 4 weeks, 2 days, 16 hours, 39 minutes
System returned to ROM by power-on
System image file is "flash:c2800nm-advsecurityk9-mz.124-3i.bin"


Cisco 2811 (revision 53.51) with 249856K/12288K bytes of memory.
Processor board ID FTX1219A0TE
2 FastEthernet interfaces
1 Serial(sync/async) interface
1 Virtual Private Network (VPN) Module
DRAM configuration is 64 bits wide with parity enabled.
239K bytes of non-volatile configuration memory.
62720K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

Regards

Cisco Employee

Re: Unable to apply service policy to a sub interface (frame-rel

Hello Jomo,

I will test this IOS on our 2811 in the lab. Nevertheless, please note that your IOS is very old and may contain numerous limitations and bugs.

The current version of your feature set is 12.4(25)c, image name c2800nm-advsecurityk9-mz.124-25c.bin. Alternatively, you could also consider using the 12.4T version which is one generation ahead of 12.4. The latest IOS version in the T train is the 12.4T(24)T3, image name c2800nm-advsecurityk9-mz.124-24.T3.bin

Both images should be appropriate for your hardware configuration.

Best regards,

Peter

New Member

Re: Unable to apply service policy to a sub interface (frame-rel

Hello Peter,

I tried the Qos I think it is working as per result (attachment).

I was tring to use cisco SDM to attach the service policy to subinterface and the error keep occuring

I am think that this kind of configuration may beyond SDM.

When i issue the sh policy-map int I am seeing all class-maps and the relevent queues and traffic flowing thru' the respect queues

which will suggest that all is working.

I attach the results for your you to vet.

Regards

New Member

Re: Unable to apply service policy to a sub interface (frame-rel

Hello Peter,

Quick question, if I need remove the service policy from  the serial interface how can I do so.

Unlike the Lan interface where the service policy is visible I am unable to distinguish the service-policy on the  serial side.

interface FastEthernet0/0
description Linden Lan Interface$ETH-LAN$
ip address xx.xx.xx.xx 255.255.254.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
duplex auto
speed auto
no mop enabled
service-policy input Qos_Internal

Regards

Cisco Employee

Re: Unable to apply service policy to a sub interface (frame-rel

Hello Jomo,

To remove the service policy from a Frame Relay (sub)interface, remove the added command frame-relay class. That should do the trick. In order to completely remove any queueing configuration, you should also remove the frame-relay traffic-shaping command from the main physical interface as well.

Best regards,

Peter

New Member

Re: Unable to apply service policy to a sub interface (frame-rel

Hello peter,

Thank you for  all the assistance , It was learning expirence for me.

And do keep up the good work

Bye

Regards

Jomo

Cisco Employee

Re: Unable to apply service policy to a sub interface (frame-rel

Hi Jomo,

You are heartily welcome. If I have the time I'll try to lab up why the class command was not accepted under your DLCI. I still owe you that one

Best regards,

Peter

1732
Views
0
Helpful
14
Replies
CreatePlease to create content