Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Unable to Configure Priority - Queue in Cisco 2950

Hi,

I'm connecting IP Phone to Cisco 2950, so during qos configuration in switch I found that I'm not able to configure priority-queue out in the interface and not able to do mls qos in the configure mode.

But I can configure trust COS in interface level.

Is it a common behaviour of C2950? Is there any other way to configure priority queue.

I'm running IOS version of 12.1(22)EA10a

Everyone's tags (1)
7 REPLIES
Super Bronze

Re: Unable to Configure Priority - Queue in Cisco 2950

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

What specific model of 2950?  The basic models have very limited QoS support.

New Member

Unable to Configure Priority - Queue in Cisco 2950

Model is C2950-I6Q4L2-M

Super Bronze

Re: Unable to Configure Priority - Queue in Cisco 2950

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

I that the model or the running IOS image?

What does show version show?

New Member

Unable to Configure Priority - Queue in Cisco 2950

Cisco Internetwork Operating System Software

IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA10a, RELEASE SOFTWARE (fc2)

Copyright (c) 1986-2007 by cisco Systems, Inc.

Compiled Tue 24-Jul-07 17:13 by antonino

Image text-base: 0x80010000, data-base: 0x80570000

ROM: Bootstrap program is C2950 boot loader

uptime is 4 weeks, 14 hours, 44 minutes

System returned to ROM by power-on

System restarted at 15:05:41 UTC Tue Oct 1 2013

System image file is "flash:/c2950-i6q4l2-mz.121-22.EA10a.bin"

cisco WS-C2950-24 (RC32300) processor (revision E0) with 20957K bytes of memory.

Processor board ID FOC0721Z2QH

Last reset from system-reset

Running Standard Image

24 FastEthernet/IEEE 802.3 interface(s)

Super Bronze

Re: Unable to Configure Priority - Queue in Cisco 2950

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

It appears you do have a basic 2950, i.e. a standard model, and as I noted in my first post, such models have very limited QoS features.

PS:

Where I work, we're in the middle of a Enterprise wide end-to-end QoS roll-out.  We have some of these 2950s, and for those, we had to resort to special QoS policy, on the upstream device's downlink port (if it's not a similar device).

New Member

Unable to Configure Priority - Queue in Cisco 2950

Can you help me out with those special QoS policy, as I need to configure priority for voice traffic.

Or Is there any other solution for this or to install a higher switch?

Super Bronze

Re: Unable to Configure Priority - Queue in Cisco 2950

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

Can I help?  Perhaps or perhaps not.  Much depends on what the next hop device is, and what your traffic looks like.

The 2950 will allow already marked packets to pass through it.  In our case, VoIP device marks packet and our upstream policy just validates traffic appears to be VoIP (to preclude abusing the marking).

e.g.:

ip access-list extended QOS-ACL-AGG-USER-EF
permit udp any range 16384 32767 any range 16384 32767 dscp ef

ip access-list extended QOS-ACL-AGG-USER-CS3
permit tcp any any eq 1720 dscp cs3
permit tcp any any range 2000 2002 dscp cs3

ip access-list extended QOS-ACL-ANY
permit ip any any

class-map match-all QOS-CLASS-ANY
match access-group name QOS-ACL-ANY

class-map QOS-CLASS-AGG-USER-EF
match access-group name QOS-ACL-AGG-USER-EF

class-map QOS-CLASS-AGG-USER-CS3
match access-group name QOS-ACL-AGG-USER-CS3

class-map QOS-CLASS-AGG-USER-IPPREC1
match ip precedence 1

policy-map QOS-POLICY-AGG-USER-IN
class QOS-CLASS-AGG-USER-EF
  set dscp ef
class QOS-CLASS-AGG-USER-CS3
  set dscp cs3
class QOS-CLASS-AGG-USER-IPPREC1
  set ip precedence 1
class QOS-CLASS-ANY
  set dscp default

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

267
Views
0
Helpful
7
Replies