Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

UNABLE TO connect or detect IP address from 2900 switch.

Need help to investigate the issue, we have a 2900 cisco cat switch and all ports are configured in vlan 3188 and this siwtch is uplink to 3750 switch which is running in transparent mode. Below is the configuration of both switches, please let me know further to investigate this problem. Attached is the config for 3750 switch.

2900#sh runn
Building configuration...

Current configuration : 12305 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
!
hostname hqcns1-602
!
boot-start-marker
boot-end-marker
no aaa new-model
clock timezone PST -8
clock summer-time PDT recurring
system mtu routing 1500
vtp mode off
authentication mac-move permit
ip subnet-zero
!

!
!
!
errdisable recovery cause bpduguard
errdisable recovery interval 400
!
spanning-tree mode rapid-pvst
spanning-tree portfast bpduguard default
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!

!
ip ssh logging events
ip ssh version 2
!
!
interface Port-channel1
switchport mode trunk
!
interface Port-channel2
switchport mode trunk
!
interface FastEthernet0/1
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/3
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/4
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/5
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/6
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/7
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/8
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/9
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/10
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/11
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/12
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/13
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/14
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/15
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/16
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/17
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/18
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/19
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/20
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/21
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/22
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/23
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/24
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/25
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/26
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/27
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/28
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/29
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/30
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/31
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/32
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/33
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/34
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/35
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/36
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/37
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/38
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/39
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/40
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/41
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/42
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/43
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/44
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/45
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/46
switchport access vlan 3190
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/47
switchport access vlan 3190
  switchport mode access
channel-group 2 mode active
spanning-tree portfast
!
interface FastEthernet0/48
switchport access vlan 3190
switchport mode access
channel-group 2 mode active
spanning-tree portfast
!
interface GigabitEthernet0/1
switchport mode trunk
channel-group 1 mode active
!
interface GigabitEthernet0/2
description ### UPLINK TO 3750 - Gi3/0/48 ###
switchport access vlan 3188
switchport mode access
spanning-tree portfast disable

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Bronze

Re: UNABLE TO connect or detect IP address from 2900 switch.

You need to manually configure an IP address on the 2900 switch.

You need to console into this switch and type the following:

interface Vlan3188
ip address 10.4.188.x 255.255.254.0

!

!
ip default gateway 10.4.188.1

Replace the 'x' with a non-conflict number in your network.

Regards,

Edison

2 REPLIES
Hall of Fame Super Bronze

Re: UNABLE TO connect or detect IP address from 2900 switch.

You need to manually configure an IP address on the 2900 switch.

You need to console into this switch and type the following:

interface Vlan3188
ip address 10.4.188.x 255.255.254.0

!

!
ip default gateway 10.4.188.1

Replace the 'x' with a non-conflict number in your network.

Regards,

Edison

Community Member

Re: UNABLE TO connect or detect IP address from 2900 switch.

Thanks Edison for your response.

The issue got resolved. The issue was with DHCP server. The subnet 10.4.188.0/23 wass not added.

3750 switch is acting like VTP transparent mode and its connected to 3/0/48 towards 0/2 on 2900 switch. I figured it out by connecting two laptops by assigning IP addresses manually on these two different switches. I am able to connected but it was not dynamically alloting the IP addresses from the port.

Well the issue got resolved now.

Hope we work on another issue.

664
Views
0
Helpful
2
Replies
CreatePlease to create content