Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Unable to create subinterface

I'm trying to route between 2 VLANs using a C1760 with a WIC-4ESW installed.

When I try to create a subinterface I get the following error:

Router(config)#interface fastEthernet 0/2.1

^

% Invalid input detected at '^' marker.

(It doesn't show in this forum but the ^ is under the 'f' of 'fastethernet')

I'm able to configure the fastethernet 0/2 interface but it just won't add a subinterface on that port. Is there a problem with the syntax?

Here's a show version:

Router#sho ver

Cisco Internetwork Operating System Software

IOS (tm) C1700 Software (C1700-K9O3SV8Y7-M), Version 12.3(2)XC, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

Synched to technology version 12.3(1.6)T

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2003 by cisco Systems, Inc.

Compiled Thu 25-Sep-03 04:18 by ealyon

Image text-base: 0x80008120, data-base: 0x819D753C

ROM: System Bootstrap, Version 12.2(7r)XM2, RELEASE SOFTWARE (fc1)

ROM: C1700 Software (C1700-K9O3SV8Y7-M), Version 12.3(2)XC, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

Router uptime is 9 weeks, 4 days, 16 hours, 48 minutes

System returned to ROM by power-on

System image file is "flash:c1700xc.bin"

cisco 1760 (MPC860P) processor (revision 0x500) with 114688K/16384K bytes of memory.

Processor board ID FOC07460LQF (3260012057), with hardware revision 0000

MPC860P processor: part number 5, mask 2

Bridging software.

X.25 software, Version 3.0.0.

1 Ethernet/IEEE 802.3 interface(s)

5 FastEthernet/IEEE 802.3 interface(s)

1 Virtual Private Network (VPN) Module(s)

32K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

4 REPLIES

Re: Unable to create subinterface

Paul,

Your configuration isn't the problem. You probably aren't using the right IOS image that supports router-on-a-stick. You need at least an IP Plus feature set IOS for this function.

HTH

Sundar

Purple

Re: Unable to create subinterface

Isn't this considered really a standalone switch to route you have to create SVI's and then apply the vlan to the interfaces , not sure you would even use subinterfaces with these cards . this may help

http://cisco.com/en/US/products/hw/routers/ps221/prod_configuration_basics09186a00801a055a.html#wp228179

New Member

Re: Unable to create subinterface

If this isn't the correct hardware could you suggest something I should purchase to use in its place?

Cisco Employee

Re: Unable to create subinterface

Paul,

I agree with Glen on this.You cannot create routed ports or sub-interfaces on the HWIC-4ESW Card. This is not supported on the card. This is a pure L2 switch, you cannot configure routed port features on it.The way it works is that you have to configure SVI's on this card for inter-vlan routing between the ports. Please see the Q&A below for the feature support:

http://cisco.com/en/US/products/hw/routers/ps221/prod_configuration_basics09186a00801a055a.html#wp229037

Please see the configuration guide ofr this card:

http://cisco.com/en/US/products/hw/routers/ps221/prod_configuration_basics09186a00801a055a.html#wp229037

HTH,

-amit Singh

2288
Views
0
Helpful
4
Replies