Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Unable to ping IP of IBGP nei Loopback

Hi All,

Here is my Lab Setup

2691 is BGP nei to R4 router and they are not directly connected.

2691 and R4 are in same AS  6500

2691 Config---

router ospf 1

network 3.3.3.3 0.0.0.0 area 0

Its advertising its loopback IP to OSPF domain.

router bgp 6500

no synchronization

bgp log-neighbor-changes

neighbor 6.6.6.6 remote-as 6500

neighbor 6.6.6.6 update-source Loopback3

2691Router# sh ip bgp
BGP table version is 6, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i50.1.1.0/24      6.6.6.6                  0    100      0 i
*>i200.1.1.0        6.6.6.6                  0    100      0 ?
*>i200.1.2.0        6.6.6.6                  0    100      0 ?
*>i200.1.3.0        6.6.6.6                  0    100      0 ?
*>i200.1.4.0        6.6.6.6                  0    100      0 ?


2691Router# sh ip bgp summ
BGP router identifier 3.3.3.3, local AS number 6500
BGP table version is 6, main routing table version 6
5 network entries using 585 bytes of memory
5 path entries using 260 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1217 total bytes of memory
BGP activity 25/20 prefixes, 25/20 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
6.6.6.6         4  6500    8770    8763        6    0    0 00:21:00        5

R4 Router

router ospf 11

log-adjacency-changes

network 6.6.6.6 0.0.0.0 area 0

router bgp 6500

no synchronization

bgp log-neighbor-changes

network 50.1.1.0 mask 255.255.255.0

  redistribute connected route-map FILTER

neighbor 3.3.3.3 remote-as 6500

neighbor 3.3.3.3 update-source Loopback6

access-list 50 permit 200.1.1.0

access-list 50 permit 200.1.3.0

access-list 50 permit 200.1.2.0

access-list 50 permit 200.1.4.0

!

route-map FILTER permit 10

match ip address 50

R4#  sh ip bgp summ
BGP router identifier 10.4.4.1, local AS number 6500
BGP table version is 26, main routing table version 26
5 network entries using 585 bytes of memory
5 path entries using 260 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1217 total bytes of memory
BGP activity 15/10 prefixes, 15/10 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
3.3.3.3         4  6500    8767    8778       26    0    0 00:25:23        0

We can see that 2691 and R4 are BGP neis and 2691 has 200.1.x.x routes in its route table.

My question is why from 2691 router i am unable to ping any route learned by BGP from R4????????????????????????????????????????

2691Router# ping 50.1.1.0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 50.1.1.0, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
2691Router#ping 200.1.2.0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.1.2.0, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Thanks

MAhesh

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Super Bronze

Unable to ping IP of IBGP nei Loopback

Mahesh,

Q. What does r RIB-Failure mean in the show ip bgp command output?



R1> show ip bgpBGP table version is 5, local router ID is 200.200.200.1Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,              r RIB-failureOrigin codes: i - IGP, e - EGP, ? - incomplete   Network          Next Ho...

A. When BGP tries to install the bestpath prefix into Routing Information Base (RIB) (for example, the IP Routing  table), RIB might reject the BGP route due to any of these reasons:

  • Route with better administrative distance already present in IGP. For  example, if a static route already exists in IP Routing table.

  • Memory failure.

  • The number of routes in VPN routing/forwarding (VRF) exceeds the route-limit configured under the VRF instance.

In such cases, the prefixes that are rejected for these reasons are identified by r RIB Failure in the show ip bgp command output and are not advertised to the peers. This feature was  first made available in Cisco IOS Software Release 12.2(08.05)T.

here is the link:

http://www.cisco.com/en/US/tech/tk365/technologies_q_and_a_item09186a00800949e8.shtml

So, since these routes don't show up in your BGP routing table, you can delete the "red conn" under the OSPF and create static routes pointing to null 0 interface and advertise them that way

Here is link to follow:

http://www.cisco.com/en/US/tech/tk364/technologies_tech_note09186a00801c9a6e.shtml

http://www.cciecandidate.com/?p=97

HTH

12 REPLIES
VIP Super Bronze

Unable to ping IP of IBGP nei Loopback

Hi Mahesh,

2691Router# ping 50.1.1.0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 50.1.1.0, timeout is 2 seconds:

In the scenario, you are pinging the 50.1.1.0    0 is not a host address.  A host address would be 50.1.1.1, 2, 3 etc..

HTH

New Member

Unable to ping IP of IBGP nei Loopback

Hi Reza,

Thanks for reply.

I ping the correct host IP now still same thing

2691Router#ping 50.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 50.1.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)


2691Router#ping 200.1.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.1.2.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

VIP Super Bronze

Unable to ping IP of IBGP nei Loopback

Mahesh,

On R4 try this:

ip route 50.1.1.0 255.255.255.0 null 0

under ospf

redis static

now, try pinging 50.1.1.1 and see what happens

HTH

New Member

Unable to ping IP of IBGP nei Loopback

Hi Reza,

I tried as below

R4(config)#ip route 50.1.1.0 255.255.255.0 null 0
R4(config)#
R4(config)#router ospf 11
R4(config-router)#re
R4(config-router)#redistribute static
% Only classful networks will be redistributed


R4#exit

[Connection to 6.6.6.6 closed by foreign host]
2691Router#sh ip bgp
BGP table version is 38, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i50.1.1.0/24      6.6.6.6                  0    100      0 i
*>i200.1.1.0        6.6.6.6                  0    100      0 ?
*>i200.1.2.0        6.6.6.6                  0    100      0 ?
*>i200.1.3.0        6.6.6.6                  0    100      0 ?
*>i200.1.4.0        6.6.6.6                  0    100      0 ?
2691Router# ping 50.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 50.1.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Still no luck

Thanks

VIP Super Bronze

Unable to ping IP of IBGP nei Loopback

Sorry Mahesh,

try this under ospf

redistribute static subnets

New Member

Unable to ping IP of IBGP nei Loopback

Hi Reza,

Did that still no luck

Thanks

MAhesh

VIP Super Bronze

Unable to ping IP of IBGP nei Loopback

Mahesh,

Can you post sh run from both routers?

Reza

New Member

Unable to ping IP of IBGP nei Loopback

Hi Reza,

Sh run from both routers is attached to original post

Thanks

VIP Super Bronze

Unable to ping IP of IBGP nei Loopback

Mahesh,

The config on the attached vs what you post above are different.  Below is the BGP config from r4 and it is different from what you posted in your first post

Also

on both routers under ospf can you add

red conn    

and delete

redistribute connected route-map FILTER

under BGP and test again?

router bgp 6500

no synchronization

bgp log-neighbor-changes

--More--          network 50.1.1.0 mask 255.255.255.0

redistribute connected route-map FILTER

neighbor 1.1.1.1 remote-as 5500

neighbor 1.1.1.1 ebgp-multihop 2

neighbor 1.1.1.1 update-source Loopback5

neighbor 3.3.3.3 remote-as 6500

neighbor 3.3.3.3 update-source Loopback6

neighbor 10.1.45.1 remote-as 5500

no auto-summary

New Member

Unable to ping IP of IBGP nei Loopback

Hi Reza,

I did as per you.

Now sh ip bgp on 2691 shows

2691Router# sh ip bgp
BGP table version is 16, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
r>i50.1.1.0/24      6.6.6.6                  0    100      0 i
r>i200.1.1.0        6.6.6.6                  0    100      0 ?
r>i200.1.2.0        6.6.6.6                  0    100      0 ?
r>i200.1.3.0        6.6.6.6                  0    100      0 ?
r>i200.1.4.0        6.6.6.6                  0    100      0 ?

Do u know why it shows r  now??????

Also sh ip route on 2691  shows no BGP routes but show as OSPF E2

O E2 200.1.4.0/24 [110/20] via 192.168.5.2, 00:02:32, FastEthernet0/1

     1.0.0.0/32 is subnetted, 1 subnets

O E2    1.1.1.1 [110/20] via 192.168.5.2, 00:46:04, FastEthernet0/1

     50.0.0.0/24 is subnetted, 1 subnets

O E2    50.1.1.0 [110/20] via 192.168.5.2, 00:02:32, FastEthernet0/1

Ping works now

2691Router#           ping 50.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 50.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
2691Router#           ping 200.1.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.1.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

So we have distributed connected subnets into OSPF and we still have BGP  neis but no BGP routes in sh ip route

of 2691.

Can you please explain above things

Thanks

VIP Super Bronze

Unable to ping IP of IBGP nei Loopback

Mahesh,

Q. What does r RIB-Failure mean in the show ip bgp command output?



R1> show ip bgpBGP table version is 5, local router ID is 200.200.200.1Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,              r RIB-failureOrigin codes: i - IGP, e - EGP, ? - incomplete   Network          Next Ho...

A. When BGP tries to install the bestpath prefix into Routing Information Base (RIB) (for example, the IP Routing  table), RIB might reject the BGP route due to any of these reasons:

  • Route with better administrative distance already present in IGP. For  example, if a static route already exists in IP Routing table.

  • Memory failure.

  • The number of routes in VPN routing/forwarding (VRF) exceeds the route-limit configured under the VRF instance.

In such cases, the prefixes that are rejected for these reasons are identified by r RIB Failure in the show ip bgp command output and are not advertised to the peers. This feature was  first made available in Cisco IOS Software Release 12.2(08.05)T.

here is the link:

http://www.cisco.com/en/US/tech/tk365/technologies_q_and_a_item09186a00800949e8.shtml

So, since these routes don't show up in your BGP routing table, you can delete the "red conn" under the OSPF and create static routes pointing to null 0 interface and advertise them that way

Here is link to follow:

http://www.cisco.com/en/US/tech/tk364/technologies_tech_note09186a00801c9a6e.shtml

http://www.cciecandidate.com/?p=97

HTH

New Member

Unable to ping IP of IBGP nei Loopback

Hi Reza,

Thanks for repy.

I will go through the links which you provided.

Mahesh

658
Views
0
Helpful
12
Replies