Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Unable to save startup-config

Hello,

Yesterday I just discovered that I'm unable to save the startup-config file to flash. I get an erroneus message that there's not enough space.

The device is a 2950G-24-EI type switch

The IOS is c2950-i6q4l2-mz.121-14.EA1a.bin

#copy run start

Destination filename [startup-config]?

startup-config file open failed ( Not enough space )

Switch#show startup-config

Switch# <----output blank, no results

Switch#show flash:

Directory of flash:/

2 -rwx 273 Jan 01 1970 00:01:33 env_vars

3 -rwx 796 Aug 13 1994 23:19:55 vlan.dat

4 -rwx 47 May 31 1993 05:13:18 private-config.text

7 -rwx 110 Mar 01 1993 00:02:13 info

8 -rwx 2958970 Mar 01 1993 00:03:47 c2950-i6q4l2-mz.121-14.EA1a.bin

9 drwx 2304 Mar 01 1993 00:04:58 html

84 -rwx 110 Mar 01 1993 00:05:08 info.ver

7741440 bytes total (2481152 bytes free) <---- Over 2MBs available

Switch#

My last startup-configuration save was about 3 months ago. Suddenly this error exists. The switchports are configured for another Vlan other then Management Vlan 1, so if I re-boot or lose power the switch is rendered useless.

Any assistance on troubleshooting this is greatly appreciated!

6 REPLIES

Re: Unable to save startup-config

It happens when you do not have free memory to run the commands.

What is the memory utilization shown by the switch?

I had a similar problem with a 3550 switch but had upgraded the IOS & the problem was rectified. You can't do that as you will lose your configs.

try disabling few services which will not affect production such as CDP,SNMP and try again.

HTH

Narayan

New Member

Re: Unable to save startup-config

I tried your advice and disabled as many services that I could. No change in status, it still won't save the config.

Here's initially what the memory usage reported:

Switch#show memory

Head Total(b) Used(b) Free(b) Lowest(b) Largest(b)

Processor 80BBEE80 4702592 4649856 52736 19944 1480

I/O A08EA840 2967072 2809936 157136 96672 4044

I turned off/disabled, service timestamps debug uptime, service timestamps log uptime, no cdp run (global), removed all aaa new-model configuration commands, rtr responder, logging trap alerts, ip rcmd rcp-enable.

Memory utization now looks like this:

Switch#show memory

Head Total(b) Used(b) Free(b) Lowest(b) Largest(b)

Processor 80BBEE80 4702592 4548972 153620 19944 38012

I/O A08EA840 2967072 2820420 146652 96672 4044

Also, I've noticed that when I do a show run I get this error message before the contents of the running-config is displayed:

Error on initialize VLAN database 1: VTP feature not yet initialized

Current configuration : 2920 bytes

VTP configuration looks good to me, it's in Client mode and the information displayed from "show vtp status" looks the same as from another switch in the same VTP domain. I switched over to Transparent mode with no luck!

Note II: I've also tried copying the configuration file from TFTP to startup-config and get the same message (No space available)

%Error opening nvram:/startup-config (Not enough space)

Switch#

Purple

Re: Unable to save startup-config

Never tried this . see if you can do a "dir nvram: and see if something is in there that shouldn't be that may be taking up space. Maybe someone saved something in there by mistake. you could be running into something like this.

CSCeb45692 Bug Details

Headline Free space in NVRAM is decreasing each time config is saved

Product IOS

Feature OTHERS Components Duplicate of

Severity 3 Severity help Status Verified Status help

First Found-in Version 12.1(13)EA1b All affected versions First Fixed-in Version 12.1(20)EA1 Version help

Release Notes

Basic Description :

Free NVRAM decreases every time the configuration is saved.

Conditions :

It is reproducable with the version c2950-i6q4l2-mz.121-13.EA1b on

WS-C2950T-24.

The symptoms occur only when the snmp engine is running - that is

only if there is some snmp configuration on the switch.

Symptoms :

When the config is saved using the "write mem" command, free space in NVRAM

decreases continuously (seen by issuing the "dir nvram:" command).

1024 bytes are lost every time the command is issued. If this is repeated

to the point where there is no more free NVRAM left, the following warning

is displayed by the switch

Switch#wr mem

Building configuration...

% Warning: Saving this config to nvram may corrupt any network management or

security files stored at the end of nvram. Continue? [no]:

Workaround:

When hitting this error statement, choose "yes"

The user-config will be saved, and there will be an internal cleanup.

Now if the "dir nvram:" command is issued, the original free NVRAM value

is displayed.

Resolution:

This bug has been fixed in 12.1(20)EA1 release.

New Member

Re: Unable to save startup-config

That's certainly pretty darn close to what's happening to me except I don't get the warning and option to save, rather I just get the error message. My IOS falls within the "range" of the bug and when it was first fixed.

Here's the results of dir nvram:

Switch#dir nvram:

Directory of nvram:/

%Error opening nvram:/ (Unknown error 89)

32768 bytes total (25147 bytes free)

Switch#

Gotta love the "Unknown error" message.

I've removed any references to snmp strings in my configuration:

Switch#sh snmp

%SNMP agent not enabled

Switch#sh snmp engineID

%SNMP agent not enabled

So far it's looking like an IOS upgrade may be my only option. It looks like there's 8MB of memory on the switch. I've deleted the html directory and contents, so now I have 4MB free, I can probably leave the old IOS on the switch. Which IOS version would be the most current that this switch will accept? Currently It's running the "Enhanced Image". Will it accept the "Enterprise Image"? I don't want to get burnt, been down that road before. :-(

Also, how about configuring the system:boot command to get it's config from a tftp server?

Rather then replying with a YES go this route, I'd still rather try and fix it. Stop some processes in memory perhaps? I viewed a similar switch, same type/model and configuration, and its memory processes weren't as utilized, so I think we're on the right track suspecting a memory process/utilization issue.

Thanks!

Re: Unable to save startup-config

Hi

Can u try service compress-config

Thanks

Mahmood

New Member

Re: Unable to save startup-config

mahmoodmkl, Thanks for replying! I had to go out on family emergency all last week. Now that I'm back I've lost Telnetting capabilities to that switch. It's still up and running until power is lost. I'll have to replace the switch with a spare and try upgrading the IOS. This issue is now dead. Thanks all for trying to help. We were close! :-)

3453
Views
0
Helpful
6
Replies
CreatePlease to create content