Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

understanding 6509 configuation

I have two 6509 switches and trying to understand the reason for the ports being configured the way they are.

There is Cisco VoIP being done throughout the network.

All of the ports are configured as shown below,(sample link port and trunk port)the only other config information is VLAN and routing config).

I understand that this is queueing being done, but do not understand the logic of why it is done the way it is.

For example, why are there multiple maps on each interface??

What are the multiple cos maps doing?

Why are there multiple numbers in each map?

Shown below:

ip cef load-sharing algorithm original

ip multicast-routing

no ip domain-lookup

ipv6 mfib hardware-switching replication-mode ingress

mls ip multicast flow-stat-timer 9

no mls flow ip

no mls flow ipv6

mls qos map cos-dscp 0 8 16 24 32 46 48 54

mls qos

no mls acl tcam share-global

mls cef error action freeze

interface FastEthernet4/41

switchport

switchport access vlan 50

switchport mode access

switchport voice vlan 250

no ip address

wrr-queue cos-map 1 1 1

wrr-queue cos-map 1 2 0

wrr-queue cos-map 2 1 2 3 4 6 7

wrr-queue cos-map 2 2 5

mls qos trust cos

spanning-tree portfast

interface GigabitEthernet6/1

switchport

switchport trunk encapsulation isl

switchport mode trunk

no ip address

wrr-queue bandwidth 30 70

wrr-queue queue-limit 40 30

wrr-queue random-detect min-threshold 1 40 80

wrr-queue random-detect min-threshold 2 70 80

wrr-queue random-detect max-threshold 1 80 100

wrr-queue random-detect max-threshold 2 80 100

wrr-queue cos-map 1 1 1

wrr-queue cos-map 1 2 0

wrr-queue cos-map 2 1 2 3 4

wrr-queue cos-map 2 2 6 7

mls qos trust dscp

there any information someone might be able to shed on why the config is done this way?

4 REPLIES
Cisco Employee

Re: understanding 6509 configuation

Hello,

Let me try explaining the configuration done on both the interfaces.

mls qos map cos-dscp 0 8 16 24 32 46 48 54

Using the above global config commands, a COS to DSCP mapping is done.

On the Fa4/41, command " wrr-queue cos-map" is used the map the traffic with a particular COS value to the egress queue of the interface. Each interface as 4 default queues to forward the traffic. I see that only 2 queues have been defined on the interface.The command " wrr-queue cos-map 2 2 5 " on the interface maps the traffic with the COS value of 2 and 5 to queue number 2 of the interface FA 4/41.

If, I were you, I would have used the voice traffic to be placed in a dedicated queue rather than using some other COS traffic along with the COS type 5 traffic. I would have done something link " wrr-queue cos-map 4 5 " to map my traffic with COS vlaue 5 to a dedicated queue number 4 on the interface.

On interface Gig 6/1, traffic mapping,schaduling and congestion avoidance is configured.

Command "wrr-queue cos-map" classifies and MAP the proper COS vlaue traffic to the respective interface queues." wrr-queue bandwidth 30 70 " defines the interface schedular's process of sending 30 frames using queue 1 and 70 frames using queue 2.Only 2 queues have been defined on the interface and as explained above you can use upto 4 queues per interface.

The command " wrr-queue random-detect " enable WRED on all the interface queues for congestion avoidance.to used the WRED droping algorithm each interface queue is defined with Max and Min threshlod values.the same has been defined on both the Queue 1 and Queue 2.

Please refer the link below for more understanding of the QOS config:

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat6000/122sx/swcg/qos.htm

HTH,Please rate if it does.

-amit singh

New Member

Re: understanding 6509 configuation

Thanks for the reply,

I don't understand where you get only two queues have been applied when four are showing up in the config.

And why did you single out the

wrr-queue cos-map 2 2 5

when the others are showing up first in the config?

Cisco Employee

Re: understanding 6509 configuation

Hello,

There are only 2 queues defined on the interface not the 4 queues. If you see the commands below

wrr-queue cos-map 1 1 1

wrr-queue cos-map 1 2 0

wrr-queue cos-map 2 1 2 3 4 6 7

wrr-queue cos-map 2 2 5

The first number tells you the queue which is being used to send the traffic with the respective COS vlaues. In the first command traffic with COS value of 1 will be sent to queue 1 and in the second command traffic with COS value 2 and 0 will be sent to queue 1 only. The same goes for third and the fourth command as well.There are only 2 queues defined on the interfaces.

I singled out " wrr-queue cos-map 2 2 5 " command just to take and example and explain it to you. If you see that traffic with COS vlaue 2 and 5 has been marked to use the queue 2.In the same queue voice traffic with COS 5 will queued along with the traffic with COS vlaue 2 which can make a singnificant impact on my voice traffic.I will always use a dedicated separate queue for voice traffic.

-amit singh

New Member

Re: understanding 6509 configuation

Dear Singh,

May I know the Cat 6509 qos setting with 7.X version. Only having Auto qos on 8.X

thanks advise,

KH

288
Views
10
Helpful
4
Replies