Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

understanding port channeling..

Folks,

I have a picture attached to understand some concepts on port channel:

I have a Switch-A connected to Switch-B as shown. On port a I have created a port channel between port Gi0/1 and G0/2.

However, on Switch-B port Gi0/1 and Gi0/2 are left as is it, no port channel is created.

Should this not be a problem? I still see that connectivity is present ans hosts on VLAN 10 are able to communicate to each other.

What issue would this cause in the real world?

Regards,

Nikport-channel LAB.jpg

Everyone's tags (1)
9 REPLIES
VIP Super Bronze

understanding port channeling..

Hi,

You need to configure etherchannel on both switches, if not it can cause loop in your network

HTH

New Member

understanding port channeling..

agreed..but what doubts me is I tried this in the LAB and had few machines connected, I did not observe any loops. Maybe because I just do not have enough machines connected to create the traffic.

But, why should this work in the first place?

Regards,

Nik

Silver

understanding port channeling..

Inspect the

show spanning-tree

show etherchannel summary

output to see the port states and which ports are used for traffic.

New Member

understanding port channeling..

Switch-A:

Mutha#sh spanning-tree

VLAN0001

  Spanning tree enabled protocol ieee

  Root ID    Priority    32769

             Address     0001.C78C.8DDB

             This bridge is the root

             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)

             Address     0001.C78C.8DDB

             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Po10             Desg FWD 3         128.27   Shr

VLAN0010

  Spanning tree enabled protocol ieee

  Root ID    Priority    32778

             Address     0001.C78C.8DDB

             This bridge is the root

             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)

             Address     0001.C78C.8DDB

             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/1            Desg FWD 19        128.1    P2p

Po10             Desg FWD 3         128.27   Shr

Mutha#

Mutha#sh etherchann summ

Flags:  D - down        P - in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 1

Number of aggregators:           1

Group  Port-channel  Protocol    Ports

------+-------------+-----------+----------------------------------------------

10     Po10(SU)           PAgP   Gig0/1(P) Gig0/2(P)

Mutha#

___________________________________________________________________________________________________

Switch-B:

ICC#sh spanning-tree

VLAN0001

  Spanning tree enabled protocol ieee

  Root ID    Priority    32769

             Address     0001.C78C.8DDB

             Cost        4

             Port        26(GigabitEthernet0/2)

             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)

             Address     0030.F2D0.5D61

             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Gi0/2            Root FWD 4         128.26   P2p

Gi0/1            Desg FWD 4         128.25   P2p

VLAN0010

  Spanning tree enabled protocol ieee

  Root ID    Priority    32778

             Address     0001.C78C.8DDB

             Cost        4

             Port        26(GigabitEthernet0/2)

             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)

             Address     0030.F2D0.5D61

             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Gi0/2            Root FWD 4         128.26   P2p

Gi0/1            Desg FWD 4         128.25   P2p

Fa0/1            Desg FWD 19        128.1    P2p

ICC#

ICC#sh ether summary

Flags:  D - down        P - in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 0

Number of aggregators:           0

Group  Port-channel  Protocol    Ports

------+-------------+-----------+----------------------------------------------

ICC#

Thnx,

Nik

Super Bronze

Re: understanding port channeling..

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

You're sure your configuration hasn't formed a port-channel dynamically?

PS:

If you have a real L2 loop, it generally causes major issues in the real world.

New Member

understanding port channeling..

I am sure Joseph,

I have manually configure the trunk.

New Member

Re: understanding port channeling..

can you share the config and sho spanning-tree output ?

only then you can see if the same has faced a blocked port due to STP.

New Member

understanding port channeling..

Hi Paresh,

I pasted the show spanning tree above:

here is the sh run on the ports:

Switch-A

interface Port-channel 10

description ** to ICC **

switchport trunk encapsulation dot1q

switchport mode trunk

__________________________________________________

Switch-B

interface GigabitEthernet0/1

description ** to Mutha **

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/2

description ** to Mutha **

switchport trunk encapsulation dot1q

switchport mode trunk

!

Silver

Re: understanding port channeling..

Hi Nik,

What types of switches do you use? If they don't support EtherChannel Inconsistency Detection then the etherchannel will be formed from the one side (using mode on), thus creating a L2 loop. Sure it is a serious issue in real world - creating a L2 loop can and will have impact on throughput and CPU's of switches and hosts as broadcast storms will arise. In addition, L2 loops create mac address table incosistency.

Best regards,

Jan

503
Views
0
Helpful
9
Replies