Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Upgrade IOS issue

Hello All,

I was upgrading one of our Companies Cisco 2801 routers today and I ran into an intresting issue. The image I was loading was:

c2801-adventerprisek9-mz.124-5c.bin, and its requirements were 128MB of RAM and 64 MB Flash. I verified this with a show ver, which returned this:

Cisco 2801 (revision 7.0) with 118784K/12288K bytes of memory.

Processor board ID FTX13088R33

2 FastEthernet interfaces

1 Serial interface

1 Virtual Private Network (VPN) Module

WIC T1-DSU

DRAM configuration is 64 bits wide with parity disabled.

191K bytes of NVRAM.

62720K bytes of ATA CompactFlash (Read/Write)

However when I boot I recieve these odd messages:

%SYS-3-IMAGE_TOO_BIG: 'flash:c2801-adventerprisek9-mz.124-5c.bin' is too large for available memory (21820700 bytes).

%SYS-6-READ_BOOTFILE_FAIL: flash:c2801-adventerprisek9-mz.124-5c.bin File read failed -- Not enough space.

%SYS-6-BOOT_MESSAGES: Messages above this line are from the boot loader.

boot of "c2801-adventerprisek9-mz.124-5c.bin" using boot helper "flash:c2801-adventerprisek9-mz.124-5c.bin" failed

error returned: File read failed -- Not enough space

loadprog: error - on file open

boot: cannot load "c2801-adventerprisek9-mz.124-5c.bin"

Then it looks like the router decompresses the image one more time and boots normally. Have you guys even seen anything like this?

Thanks!

  • LAN Switching and Routing
2 REPLIES
Hall of Fame Super Gold

Upgrade IOS issue

Can you try a different IOS?  The one you're using or upgrading to is pretty ancient.

New Member

Upgrade IOS issue

I tried quite a few different IOS images. The one that ended up working with out giving that issue was

c2801-entbasek9-mz.124-5e.bin I think. It was the same revision number just enterprise base instead of advanced enterprise. The reason I have it on such old IOS is because it only have 128MB RAM and 64MB flash. I also need the IP SLA features. Thanks for the help though! If you have any other suggested IOS images that match those feature sets let me know.

203
Views
0
Helpful
2
Replies
This widget could not be displayed.