Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Upgrade IOS on VSS pair

I have 2 6513-E switches with Supervisor 2T modules.

They are in a VSS-SSO pair, and I need to upgrade the IOS from 15.1.1(SY) to the latest.

The documentation I am seeing does not take into account the E chassis or the Supervisor 2T, so I am a bit confused on how this is done (there is no slavedisk, etc.)

Anyone have an upgrade procedure for this setup?

2 ACCEPTED SOLUTIONS

Accepted Solutions
Silver

Re: Upgrade IOS on VSS pair

Hi Colin,

The upgrade should be the same as any other upgrade on a VSS setup, the fact that you have SUP2T and  E chassis should not change the procedure.

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/15.0SY/configuration/guide/virtual_switching_systems.html#wp1341260

Table 4-1     VSS Hardware Requirements

Hardware

Count

Requirements

Chassis

  2

All chassis supported in Cisco IOS Release 15.0SY support VSS mode.

Note The two chassis need not be identical.

Supervisor Engines

  2

Either two VS-SUP2T-10G or two VS-SUP2T-10G-XL supervisor engines.

The two supervisor engines must match exactly.

Switching Modules

  2+

VSS mode support as shown in the Release Notes.

VSS mode does not support 61xx switching modules. In VSS mode, unsupported switching modules remain powered off.

Hope this helps.

VIP Super Bronze

Upgrade IOS on VSS pair

You got it.  That is the easiest way to do upgrade a VSS pair specially if you effort to have 1/5 hour of down time.  Copy the image to both bootdisk and salvebootdisk, set your boot variable, save the config and reboot.

You will be back in business is less than 15 minutes. Of course, you want a longer outage window just in case.

HTH

6 REPLIES
Silver

Re: Upgrade IOS on VSS pair

Hi Colin,

The upgrade should be the same as any other upgrade on a VSS setup, the fact that you have SUP2T and  E chassis should not change the procedure.

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/15.0SY/configuration/guide/virtual_switching_systems.html#wp1341260

Table 4-1     VSS Hardware Requirements

Hardware

Count

Requirements

Chassis

  2

All chassis supported in Cisco IOS Release 15.0SY support VSS mode.

Note The two chassis need not be identical.

Supervisor Engines

  2

Either two VS-SUP2T-10G or two VS-SUP2T-10G-XL supervisor engines.

The two supervisor engines must match exactly.

Switching Modules

  2+

VSS mode support as shown in the Release Notes.

VSS mode does not support 61xx switching modules. In VSS mode, unsupported switching modules remain powered off.

Hope this helps.

VIP Super Bronze

Upgrade IOS on VSS pair

Hi,

The primary VSS device is bootdisk and for the stand-by it is slavebootdisk.

What the output of dir flash?

HTH

Community Member

Upgrade IOS on VSS pair

Ah OK

So I can copy the new image into both the bootdisk: and slavebootdisk:, modify the boot system statement, and the reload the chassis?

It will be done after-hours, so I can have some downtime.

VIP Super Bronze

Upgrade IOS on VSS pair

You got it.  That is the easiest way to do upgrade a VSS pair specially if you effort to have 1/5 hour of down time.  Copy the image to both bootdisk and salvebootdisk, set your boot variable, save the config and reboot.

You will be back in business is less than 15 minutes. Of course, you want a longer outage window just in case.

HTH

Community Member

Upgrade IOS on VSS pair

Perfect. thanks for the help guys.

VIP Super Bronze

Upgrade IOS on VSS pair

Glad to help.  Thanks for the rating

425
Views
0
Helpful
6
Replies
CreatePlease to create content