Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Upgraded to a Cisco 861 need some assistance with the setup

Good Day,

We have upgraded our gateway router from a Cisco Linksys RVL200 to a Cisco 861, this is a big jump from a GUI driven system to IOS CLi and i'm having issue finding my feet. I tried the Cisco CP system but it didn't work so I'm going to configure it with IOS commands. I wish to replicate the current configuration on the 200 with the following setup, can someone help with the following problems:

  1. I have created a DHCP pool but i am unable to configure the FastEthernet ports to hand out address automatically, the pool is called USERS with range 192.168.1.30 -> 192.168.1.253.
  2. How do I work out the client-identifier for a DHCP client, I don't want to plug this into the network and manual reconnect all the PC's just to get the ID then make a static route.
Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Upgraded to a Cisco 861 need some assistance with the setup

Hi Alastair,

The client identifier is formed by concatenating  the media type and the MAC address. For example, the Microsoft client  identifier for Ethernet address b708.1388.f166 is 01b7.0813.88f1.66,  where 01 represents the Ethernet media type.

So you can build static mappings without connecting devices, if you know their MAC addresses. The following guide could be helpful to do that:

http://www.cisco.com/en/US/docs/ios/ipaddr/configuration/guide/iad_dhcp_svr_cfg.html#wp1117976

Kind Regards,
Ivan

**Please grade this post if you find it useful.

Kind Regards, Ivan Shirshin **Please grade this post if you find it useful.
8 REPLIES
Gold

Re: Upgraded to a Cisco 861 need some assistance with the setup

Hi,

if you have only ONE LAN then this is your config:

ip dhcp pool USERS

network x.x.x.x / prefix

dns-server x.x.x.x

default-router x.x.x.x

if you have inter-vlan routing, L3 devices like layer 3 switches and other routers in the way, u have to set ip helper-address on their interfaces.

this Link could be a help:

http://www.cisco.com/en/US/docs/ios/12_2/ip/configuration/guide/1cfdhcp.html#wp1001001

plz Rate if it helped.

Soroush.

Hope it Helps!

Soroush.
Cisco Employee

Upgraded to a Cisco 861 need some assistance with the setup

Hi Alastair,

You have to configure the following kind of configuration:

ip dhcp pool pool10

   network 10.10.10.0 255.255.255.0

   default-router 10.10.10.1

!

interface GigabitEthernet0/1.10  //this is for connected vlan 10

encapsulation dot1Q 10

ip address 10.10.10.1 255.255.255.0

!

Note that if you have multiple pools, router chooses the one which "default router" IP corresponds the IP address of interface the DHCP client is connected to.

E.g. GigEth0/1.20 would get an IP from pool20 instead of pool10.

ip dhcp pool pool20

   network 10.10.20.0 255.255.255.0

   default-router 10.10.20.1

interface GigabitEthernet0/1.20

encapsulation dot1Q 20

ip address 10.10.20.1 255.255.255.0

!

Kind Regards,
Ivan

**Please grade this post if you find it useful.

Kind Regards, Ivan Shirshin **Please grade this post if you find it useful.
New Member

Upgraded to a Cisco 861 need some assistance with the setup

thank you guys fr your replies, do you have any information on the generation of client-identifiers

Cisco Employee

Upgraded to a Cisco 861 need some assistance with the setup

Hi Alastair,

You can determine the client identifier by using the debug ip dhcp server packet command. In the following example, the client is identified by the value 0b07.1134.a029.

Router# debug ip dhcp server packet 

DHCPD:DHCPDISCOVER received from client 0b07.1134.a029 through relay 10.1.0.253.

DHCPD:assigned IP address 10.1.0.3 to client 0b07.1134.a029.

PS: Please do rate the posts that were useful.

Kind Regards,
Ivan

Kind Regards, Ivan Shirshin **Please grade this post if you find it useful.
New Member

Upgraded to a Cisco 861 need some assistance with the setup

Ivan, would I need to plugin all the clients then run that command to find the c-id or could I workout the c-id in advanced.

Cisco Employee

Upgraded to a Cisco 861 need some assistance with the setup

Hi,

Yes, you would need to connect clients for client-id to generate those DHCP packets to server. After all, it is client who is providing its client ID to server, not the way around - so without client there is no ID. Also, in some cases the dhcp packet from client may not even have Client ID value.

But typically ClientIDs are most likely to be the client MAC addresses, so if you know those  - you can use them without connecting the clients.

By the way, if the clients were successfully provided address by DHCP, you can check the ClientID in "show ip dhcp server bindings" command too (that works after the binding was made).

Kind Regards,
Ivan

**Please grade this post if you find it useful.

Kind Regards, Ivan Shirshin **Please grade this post if you find it useful.
New Member

Upgraded to a Cisco 861 need some assistance with the setup

Thanks Ivan, my questions are lead by the need to create static hosts on DHCP and i have a list of MAC addresses but if i want to create the static routes i would need a client-id aswell

Cisco Employee

Upgraded to a Cisco 861 need some assistance with the setup

Hi Alastair,

The client identifier is formed by concatenating  the media type and the MAC address. For example, the Microsoft client  identifier for Ethernet address b708.1388.f166 is 01b7.0813.88f1.66,  where 01 represents the Ethernet media type.

So you can build static mappings without connecting devices, if you know their MAC addresses. The following guide could be helpful to do that:

http://www.cisco.com/en/US/docs/ios/ipaddr/configuration/guide/iad_dhcp_svr_cfg.html#wp1117976

Kind Regards,
Ivan

**Please grade this post if you find it useful.

Kind Regards, Ivan Shirshin **Please grade this post if you find it useful.
605
Views
14
Helpful
8
Replies
CreatePlease login to create content