Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
New Member

Upgrading flash mem card in 1720 router

I'm trying to upgrade a 1720 router Flash carad. I bought a

16MB card for it. If i place the card in and try to boot, it boots to ROMMON1. Tried the confreg proceudre and all, but still couldnt boot. I booted the router with the old flashcard and it's fine. I popped in the new card after it was booted from old card, and did erase flash: and it went through the erase procedure. If i run "show flash: all" with the new card in  it says the new card only has 4 MB of free space. How should I go about this? I am unable to format with Class C filesystem, the format command is not available. Is there a process I need to go through to get the router to correctly recognize the new card? Thanks! - Scott


Re: Upgrading flash mem card in 1720 router

With the new flash in the router you will need to do this command

squeeze flash:

That should free up the space.


New Member

Re: Upgrading flash mem card in 1720 router

Thanks for the reply Mike. I should have thought of trying that before, but unfortunately, it didnt work anyway. Apparently its not a valid command in this IOS version c1700-y-m v12.0(4)T. I just get "invalid input detected" when trying to squeeze flash:  ...

New Member

Re: Upgrading flash mem card in 1720 router

Figured it out with help from the flash card vendor. Ill post results in case anyone else has this problem;

The IOS version was 12.0 (4) T and was too old to be able to see 16MB of flash card. To get around it, I had to load a newer IOS directly into DRAM (skipping the flash card). Once booted do a erase flash: and then copy the newer IOS to the flash card via TFTP and reload. Here is the command set:

From Rommon:


TFTP_FILE= c1700-y7-mz.124-25d.bin      

tftpdnld –r                        (the –r tells the router to decompress directly into the DRAM, it will not be saved to the flash)

once the router boots up, issue commands erase flash: or format flash:  one of those will work.

TFTP the image you eventually want to run on this router.


**edited to correct typo**

CreatePlease to create content