Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Upgrading IOS on 4500x Switches

Hello,

I need the crypto version of IOS for a VSS pair of 4500x-32 port switches.

I tried what I thought was the usual upgrade process.

tftp image to bootflash: and slavebootflash: and config to boot system flash blah.bin

wr mem

reloaded both switches.

on Bootup the cli simply says using 1st file on flash.

I followed the process which wanted to change the config-register to 0x2102 for some reason? and a redundancy peer reload, this simply put my swithes into rommon mode.

Whatever process I try the switches will not load the same version k9 crypto file, its simply ignored. Are we back to the old days of having to order the image on the bootflash?

Please help if anyone knows how to upgrade these switches, they are not production yet in pre-stagng so uptime is not important yet.

My current version is -

System image file is "bootflash:/cat4500e-universal.SPA.03.04.00.SG.151-2.SG.bin"

I want to load

cat4500e-universalk9.SPA.03.04.02.SG.151-2.SG2.bin

Which exists on the bootflash and slavebootflash

Thanks

Chris

Everyone's tags (4)
16 REPLIES
Hall of Fame Super Silver

Upgrading IOS on 4500x Switches

Can you post the output of the show command to display the boot variables and the output of show flash? Perhaps there is some syntax issue?

Also can you post all of the console output during an attempt to boot? Perhaps there is some issue in the boot process or with validity of the file in flash?

HTH

Rick

New Member

Upgrading IOS on 4500x Switches

Hello,

I am confused as to what the config-register should be, I can't find it documented.

I configured the boot string

Boot system flash:cat4500-universal.spa.03.04.00.sg.151-2.sg.bin

I reboot the switch and it goes into rommon mode.

It says invalid filename.... It must begin with a device name.

Please help.

It boots ok from Rommon if I manually type it.

Chris

New Member

I think the correct syntax is

I think the correct syntax is "boot system flash bootflash:xxx" and not "boot system flash:xxx"

so in your case it would be:

4500x(config)#boot system flash bootflash:cat4500-universal.spa.03.04.00.sg.151-2.sg.bin2.SG5.bin

other options are:

4500x(config)#no boot system ?
  flash  Boot from flash memory
  ftp    Boot from a server via ftp
  mop    Boot from a Decnet MOP server
  rcp    Boot from a server via rcp
  tftp   Boot from a tftp server
  <cr>

 

4500x)config)#boot system flash ?
  WORD  System image filename
  <cr>

 

 

 

 

Hall of Fame Super Silver

Yes - just as I posted

Yes - just as I posted earlier in this thread - 2 years ago. :)

Purple
New Member

Upgrading IOS on 4500x Switches

Cheers, a long document for a simple process, I just want to upgrade the damm things lol

Cisco Employee

Upgrading IOS on 4500x Switches

Hi Chris,

Were you able to get this resolved? let me know if you still need assistance, I can help.

Luke

New Member

Re:Upgrading IOS on 4500x Switches

Not resolved yet but I have a TAC case open.


Sent from Cisco Technical Support Android App

Upgrading IOS on 4500x Switches

Hello guys,

Just upgraded my cisco 4500x.

In fact the proccess is simple, you just have to upload the new IOS and then delete the old one from bootflash.

Then add the correct bootflash line in your configuration.

C.

New Member

Upgrading IOS on 4500x Switches

I am having the same issue. What was the correct bootflash line? Was it boot system flash:imagename ? It will not let me specify bootflash:  

BTW ISSU will not work when going from non K9 version to K9. It will fail.

Purple

Upgrading IOS on 4500x Switches


Where is the current image located?  That's what you would use  if it's not in bootflash:  .  Cisco likes to change names and confuse people like bootflash, bootdisk,  etc...

Hall of Fame Super Silver

Upgrading IOS on 4500x Switches

boot system flash bootflash:cat4500e-universalk9.SPA.03.04.00.SG.151-2.SG.bin

That's what I used successfully on a production 4500X VSS cluster. I upgraded the units separately during staging prior to building them into a VSS.

Configuration register is 0x2102. That tells the switch rommon to boot the image specified in the startup configuration file.

New Member

Upgrading IOS on 4500x Switches

Hello, resolved.

You cant cant upgrade via the ISSU process when changing from no crypto to crypto image. SSH requires crypto. What you have to do is upgrade in the old style, reboot, the two boxes moan, you break VSS. Then upgrade the second box manually then bring the VSS up again.

New Member

Upgrading IOS on 4500x Switches

VSS-ROUTER(config)#boot system flash bootflash:cat4500e-universalk9.SPA.03.04.02.SG.151-2.SG2.bin
VSS-ROUTER(config)#do wr
Building configuration...
Compressed configuration from 22592 bytes to 9330 bytes[OK]
VSS-ROUTER(config)#do sh bootv
BOOT variable = bootflash:cat4500e-universalk9.SPA.03.04.02.SG.151-2.SG2.bin,1;
CONFIG_FILE variable does not exist
BOOTLDR variable does not exist
Configuration register is 0x2102

Standby BOOT variable = bootflash:cat4500e-universalk9.SPA.03.04.02.SG.151-2.SG2.bin,1;
Standby CONFIG_FILE variable does not exist
Standby BOOTLDR variable does not exist
Standby Configuration register is 0x2102
VSS-ROUTER#redundancy reload peer
Reload peer [confirm]
VSS-ROUTER#
Preparing to reload peer

New Member

Upgrading IOS on 4500x Switches

Hey c-Davis,

Just saw this post- I follow the below method to upgrade 4500 with dual sups-

copy the image to bootflash& slavebootflash

!update the boot statement

conf t

boot system flash bootflash:

(needs to set the conf reg to 0x2102 if its set to other value)

end

wr mem

!!reload the entire box

redundancy reload shelf

this will reload the entire box and it will come up with the new image.

Cheers!

George

New Member

Has anyone tried using the

Has anyone tried using the "changeversion" functionality on ISSU; one command step?

37448
Views
6
Helpful
16
Replies
CreatePlease login to create content