Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Upgrading WS-C3750G-24TS-E1U to 15.0.1-SE2 ED

Hello,

I have the following switch:

#show version
Cisco IOS Software, C3750 Software (C3750-IPSERVICES-M), Version 12.2(52)SE, RELEASE SOFTWARE (fc3)
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Image text-base: 0x01000000, data-base: 0x02C00000

ROM: Bootstrap program is C3750 boot loader
BOOTLDR: C3750 Boot Loader (C3750-HBOOT-M) Version 12.2(44)SE5, RELEASE SOFTWARE (fc1)

System image file is "flash:c3750-ipservices-mz.122-52.SE/c3750-ipservices-mz.122-52.SE.bin"

cisco WS-C3750G-24TS-1U (PowerPC405) processor (revision D0) with 131072K bytes of memory.

512K bytes of flash-simulated non-volatile configuration memory. Model revision number           : D0 Motherboard revision number     : A0 Model number                    : WS-C3750G-24TS-E1U Top Assembly Revision Number    : A0 Version ID                      : V03
Switch Ports Model              SW Version            SW Image ------ ----- -----              ----------            ---------- *    1 28    WS-C3750G-24TS-1U  12.2(52)SE            C3750-IPSERVICES-M Configuration register is 0xF

I have downloaded c3750-ipservicesk9-mz.150-1.SE2.bin and I want to upgrade iOS to this image.

I have a few questions related to this:

1. Is my switch model compatible with this iOS version?

2. Do you recommend the upgrade? Does it bring some notable features?

3. Can I upgrade for free or do I need to buy some license?

4. I also want to upgrade/add the crypto image, can I add crypto for free or some license is required?

5. I have remote access to my switch via the console cable which plugged into machine1. But machine1 is connected to network via the same switch. I am accessing machine1 via SSH, and then the switch via console cable (minicom on CentOS). Is there an upgrade procedure for this kind of situation that also has some fall back (like reboot in X minutes and load the previous image) if the upgrade goes wrong?

Thank you

Everyone's tags (4)
6 REPLIES
VIP Super Bronze

Re: Upgrading WS-C3750G-24TS-E1U to 15.0.1-SE2 ED

1. Is my switch model compatible with this iOS version?

Yes, if this IOS is already loaded in your switch and it is working then you are good to go

2. Do you recommend the upgrade? Does it bring some notable features?

If you don't any feature that is not in 12.2(52) then you don't need to upgrade.  Also your version is not old anyway.

3. Can I upgrade for free or do I need to buy some license?

If you have a  SmartNet contract with Cisco and the switch is under warranty, then you upgrade for free

4. I also want to upgrade/add the crypto image, can I add crypto for free or some license is required?

The same as #3.  Also, check with your sales rep

Don't really understand question #5

HTH

Hall of Fame Super Gold

Re: Upgrading WS-C3750G-24TS-E1U to 15.0.1-SE2 ED

1. Is my switch model compatible with this iOS version?

Yes and no.  Depends on the size of your flash memory.  If your flash memory is 16 mb then you CANNOT go to 15.0(1)SE version.  The highest IOS verson a 16 mb 3750 can go is 12.2(55)SE (and later, like the SE1, SE2, SE3, SE4 and SE5).

2. Do you recommend the upgrade? Does it bring some notable features?

Depends on you.  But I do strongly recommend that you read the Release Notes and understand some of the issues faced by some of the 15.0(1)SE users.

3. Can I upgrade for free or do I need to buy some license?

Your current IOS is IP Services.  As long as you stay WITHIN the same feature set, i.  e.  IP Services, then you don't need a special license.

4. I also want to upgrade/add the crypto image, can I add crypto for free or some license is required?

Same answer as #3.

5. I have remote access to my switch via the console cable which plugged into machine1. But machine1 is connected to network via the same switch. I am accessing machine1 via SSH, and then the switch via console cable (minicom on CentOS). Is there an upgrade procedure for this kind of situation that also has some fall back (like reboot in X minutes and load the previous image) if the upgrade goes wrong?

Depends on the flash size of your appliance.  If you have only 16 mb then you need to copy the TWO (2) BIN files only.  If you have 32 mb flash then you can have two full version of the IOS of your choice in your appliance.

Community Member

Upgrading WS-C3750G-24TS-E1U to 15.0.1-SE2 ED

I bought the switch as second hand and I don't have any agreement with Cisco.

Am I eligible for an upgrade without paying got the new version?

Is this how I find out how much flash memory I have?

#dir flash1:/
Directory of flash:/

    2  -rwx        2072   Mar 1 1993 04:57:33 +00:00  multiple-fs
    4  -rwx        1879   Mar 1 1993 04:57:33 +00:00  config.text
    5  -rwx           5   Mar 1 1993 04:57:33 +00:00  private-config.text
    7  drwx         192  Oct 14 2009 09:20:10 +00:00  c3750-ipservices-mz.122-52.SE

32514048 bytes total (18136576 bytes free)

And how about this "remote upgrading" while being connected to a server (and using minicom to connect to switch console) that is connected via the switch?

Hall of Fame Super Gold

Upgrading WS-C3750G-24TS-E1U to 15.0.1-SE2 ED

You need a valid Service Contract to be able to download the IOS from Cisco.

Your switch is the 32mb flash model so you can load 15.0(1)SE (and later) IOS.

Upgrading the IOS has many ways.  The recommended is to use the command:

archive download-sw tftp:///filename.tar

Community Member

Upgrading WS-C3750G-24TS-E1U to 15.0.1-SE2 ED

I was able to download c3750-ipservicesk9-mz.150-1.SE2.bin from cisco.com after registering:

http://www.cisco.com/cisco/software/release.html?mdfid=279486442&flowid=2516&softwareid=280805680&release=15.0.1-SE2&relind=AVAILABLE&rellifecycle=ED&reltype=latest

So I have the image file. Can I just go ahead and install it or it will check some license on router and I might break it?

Hall of Fame Super Gold

Upgrading WS-C3750G-24TS-E1U to 15.0.1-SE2 ED

Can I just go ahead and install it or it will check some license on router and I might break it?

Go ahead and upload the IOS to the switch using the instructions provided in the Release Notes.

It's good that you are using IOS version 15.0(1)SE2.

6377
Views
0
Helpful
6
Replies
CreatePlease to create content