Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

using vrfs with eigrp

Hi Everyone

 

I need to get two vrfs configured on some 3750 switches. I started off by configuring one vrf on three switches, A connected to B and B connected to C. The config was very simple like below but it didnt work:

 

switch a example:

!

ip vrf admin

rd 100:1

route-target import 100:1

route target export 100:1

 

interface gigabitethernet 1/0/24

ip vrf forwarding admin

ip address 1.1.1.1 255.255.255.252

!

router eigrp 100

network 1.1.1.0 0.0.0.3

 

The rest of the config for switches B and C were configured the same. I could ping the next hop but I couldnt ping from switch A to C.

 

Now I found another guide on the internet and it had additional configuration that I needed to add to eigrp. So I configured:

 

router eigrp 100

address-family ipv4 vrf admin

network 1.1.1.0 0.0.03

 

Now i tried to add the command:

autonomous-system 100

However my switch wont accept this command even though the switch gives me a warning that i need to configure an autonomous system number.

 

My question is,am i on the right path here? and also why isnt my switch taking this command? the switch ios is 15 and its a universalk9.

 

Thanks for your help

 

 

 

 

3 REPLIES
VIP Super Bronze

Hi,You may need IP services

Hi,

You may need IP services license.

What is your license level?

sh license or sh ver

 

HTH

 

New Member

Hi I have a permanent ip

Hi

 

I have a permanent ip services licence on there

 

regards

 

 

New Member

Hi, Can you try configuring

Hi,

 

Can you try configuring the autonomous system on the same line as eigrp as address-family ipv4

 

Example,

router eigrp 100

address-family ipv4 vrf admin autonomous-system 1

 

51
Views
0
Helpful
3
Replies