Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Very high CPU usage 4900M switch

Hello,

I have a 4900M that is running with constant CPU usage of ~85%. I have 5 other of these switches with the same configuration and placing in the topology that do not have the problem.

sh proc cpu

CPU utilization for five seconds: 82%/0%; one minute: 85%; five minutes: 86%

47 233407012 643237989 362 4.23% 4.27% 4.31% 0 Cat4k Mgmt HiPri

48 1660690936 724232776 2293 76.81% 80.13% 80.72% 0 Cat4k Mgmt LoPri

sh plat heal

%CPU %CPU RunTimeMax Priority Average %CPU Total

K5L3Unicast Adj Tabl 2.00 47.80 15 11 100 500 48 49 37 44108:318

K5 L2 Hardware Addre 2.00 49.79 10 9 100 500 61 55 43 58187:346

Does anybody have any idea from the above data what the problem could be?

As I mentioned above the config is almost identical to that of the other switches that do not have the problem, and all other data looks similar (including sh interfaces switching) although there does seem to be a lot of spanning tree output on all interfaces.

Please let me know if you require furtehr information/output.

Thanks in advance.

4 REPLIES
Hall of Fame Super Silver

Re: Very high CPU usage 4900M switch

Hello Christopher,

I've found a document about 4500 high cpu

http://www.cisco.com/en/US/partner/products/hw/switches/ps663/products_tech_note09186a00804cef15.shtml

or

http://www.cisco.com/en/US/products/hw/switches/ps663/products_tech_note09186a00804cef15.shtml

However, if there is an high rate of STP messages there can be too many STP topology changes and you need to investigate this as noted in

http://www.cisco.com/en/US/partner/products/hw/switches/ps663/products_tech_note09186a0080094956.shtml

or

http://www.cisco.com/en/US/products/hw/switches/ps663/products_tech_note09186a0080094956.shtml

look for flapping links, what STP mode are you using?

Hope to help

Giuseppe

New Member

Re: Very high CPU usage 4900M switch

Thanks for the quick reply. I've been through the 4500 document, it doesnt really help too much, just instructs to use the usual 'sh proc cpu', 'sh platform health' and 'sh interfaces switching'. There are no STP topology changes just what seems an usually large amount of packets output for the switch uptime.

GigabitEthernet2/1

Throttle count 0

Drops RP 0 SP 0

SPD Flushes Fast 0 SSE 0

SPD Aggress Fast 0

SPD Priority Inputs 0 Drops 0

Protocol Path Pkts In Chars In Pkts Out Chars Out

Other Process 0 0 151844 9110640

Cache misses 0

Fast 0 0 0 0

Auton/SSE 0 0 0 0

PAgP Process 0 0 164099 19363682

Cache misses 0

Fast 0 0 0 0

Auton/SSE 0 0 0 0

Spanning Tree Process 0 0 57274993 3654508948

Cache misses 0

Fast 0 0 0 0

Auton/SSE 0 0 0 0

VTP Process 0 0 14913 1521126

Cache misses 0

Fast 0 0 0 0

Auton/SSE 0 0 0 0

I have noticed there is a lot of flapping interfaces that are assigned to port channels, it flaps between one or the other link. They are connected to teamed network adapters on ESX boxes.

16w2d: %C4K_EBM-4-HOSTFLAPPING: Host 00:50:56:A4:68:F2 in vlan 110 is flapping between port Gi2/1 and port Gi2/2

16w2d: %C4K_EBM-4-HOSTFLAPPING: Host 00:0C:29:DE:86:63 in vlan 110 is flapping between port Gi2/1 and port Gi2/2

interface GigabitEthernet2/1

switchport mode trunk

channel-group 4 mode desirable

!

interface GigabitEthernet2/2

switchport mode trunk

channel-group 4 mode desirable

!

interface Port-channel4

description "ESX trunk"

switchport

switchport mode trunk

!

Im not particularly familar with port channels used in this way to teamed network adapters. It does seem strange to me that the port channel interface has been created in the same way you usually would for a L3 etherchannel, but has no ip assignment, and both the physical and logical interfaces are set to trunk.

Any further assitance would be appreciated.

Thanks again

Hall of Fame Super Silver

Re: Very high CPU usage 4900M switch

Hello Christopher,

I see a possible problem here:

with mode desirable you are asking the switch to try to use proprietary PAGP to negotiate a bundle.

Towards servers we use LACP that can be enabled with

mode active on switch side.

I suggest you to check with server people.

To change to an LACP bundle I would suggest you to use a different channel number.

This should explain why you see host mac flapping: actually the bundle is not active from the point of view of the switch.

Hope to help

Giuseppe

New Member

Re: Very high CPU usage 4900M switch

Sounds very likely that this is the cause of the problem.

I did a bit of further reading and it seems Cisco recommend setting the channel-group mode to 'on' so that the bundle is forced and does not use any protocol.

I will implement the changes over the weekend.

Thank you very much for the help.

1311
Views
9
Helpful
4
Replies
CreatePlease to create content