Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

VLAN and EIGRP

Hello experts.

Scenario: I have a new 2851 ISR router connected to a 3750 switch. Both are configured for EIGRP in the same AS. The 2851 connects via GigE to the 3750. The connection is up just fine.

The 2851 has a VLAN (VLAN126, 192.168.26.254) configured for the switch ports that I want to use. Currently, I have not attached any devices to these ports. I have the statement NETWORK 192.168.26.0 in my EIGRP config.

The 2851 has received all routing updates from the AS just fine. The 3750 (and all devices behind it) do not show a route for the 26.0 network. Is it because I have no devices attached, or is there something I have missed in the config?

Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: VLAN and EIGRP

Friend,

THE VLAN needs to be up in order for EIGRP to pass the update.

Since you have connected any device, the vlan must be down nad hence the subnet is not getting advertised to the 3750.

The network should get advertised once you connect any device on that vlan

HTH, rate if it does

Narayan

1 REPLY

Re: VLAN and EIGRP

Friend,

THE VLAN needs to be up in order for EIGRP to pass the update.

Since you have connected any device, the vlan must be down nad hence the subnet is not getting advertised to the 3750.

The network should get advertised once you connect any device on that vlan

HTH, rate if it does

Narayan

118
Views
0
Helpful
1
Replies
CreatePlease to create content