Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VLAN and STP related issue

I have a 5505(L3) that multiple 2948G-L2 switches connect to. Several of the 2948G will have VLAN100 on them. If I plug in more than 1 2948G with VLAN100 active I lose access to all VLAN100 devices. It appears that a loop blocking maybe causing it to shut down ports on the 5505. Each one of the 2948G switches plugs directly into the 5505 and not to each other. The 5505 and the 2948G are both configured with VLAN ALL allowed on the interconnecting ports.

Are there any options other than to connect all the 2948G switches together?

Thanks

8 REPLIES
Purple

Re: VLAN and STP related issue

No what you are trying to do should work fine , you are either misconfigured or have a cabling problem causing a loop somewhere .You might want to post the both the layer 2 and 3 configs of the 5500 and maybe a single 2948 that is having a problem . No reason a 2948 can't be hung off a 5505 . Make sure to make the 5500 the spanning tree root of all vlans if its doing all the routing . Are you trunking to all the 2948's or you just using access ports set into vlan 100 .

New Member

Re: VLAN and STP related issue

The 2948s are using access mode on the server side and trunks on the link to the 5505. The 5505 is running trunks as well.

This config works great with 1 switch with vlan 100, once I have 2 switches with vlan 100 connected to the 5505 it can no longer route to the vlan.

The 2948 switches connect to 2 5505 switches for redundancy with hsrp running.

Does that help?

Purple

Re: VLAN and STP related issue

Well not really you should be able to hang as many switches off the 5500 that you want . Are the switches in transparent mode ??? On your trunks make sure the native vlans match on each side , without seeing configs we are kind of shooting in the dark .

New Member

Re: VLAN and STP related issue

Attached is a layout of the network, is this possible between the 2948G and 5505 switches?

That is what I am trying to do. If I labelled a link as a vlan, it is trunking. Otherwise it is a standard vlan.

New Member

Re: VLAN and STP related issue

Attached are the configs for the 2948G switches.. I will post the 5505 configs in another post.

New Member

Re: VLAN and STP related issue

Here are the 5505 configs for the RSM and SUP.

I hope that helps.

New Member

Re: VLAN and STP related issue

I have pulled the 5505 switches out and connected directly to my 6500s and the issue is not there. Must have been a config issue in CatOS.

Purple

Re: VLAN and STP related issue

You said you plugged them into the 6500's , who is doing the routing for vlan 100 ? Is vlan 100 routed by the 5505 or the 6500's ? If it is to be terminate on the 5505's then make sure spanning tree is running for that vlan on the 5500's with the root switch being the hsrp active side 5500 and the secondary root would be the other side . Spanning tree should take care of any loops . To me it sounds like spanning tree is not running or setup correctly and when you plug them in you are causing a loop. If you set it up like I indicated on the 2948's and spanning tree is setup correctly then you will see one of the uplinks on the 2948's in a spanning tree blocked state . I am confused when you say you plug it into the 6500 as I don't really know where you are routing vlan 100 . With all the redundancy and crosslinks getting spanning tree setup correctly is crucial.

154
Views
0
Helpful
8
Replies