Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VLAN Communication and IP-Helper- Address troubles

Hello all,

I feel like I'm a disgrace to my CCNA and the LONG years of studying. I'm having a problem with my VLAN communication. What i'm trying to do is setup a VoIP lab at home. I currently have a cisco 2621XM with my voice ports. My sub-interface for voice configured and the IP helper-address command configured. I've already have my DHCP scopes on my Domain Controller.

I've configured my 2950 VLAN's and IP's. the Data VLAN is on the default VLAN number and my voice is on VLAN 20. My subnet for data is 10.0.1.0 and Voice 10.1.1.x. My encapsulation on my trunked port is ISL and I understand the 2950 switch default (once trunked to the router) 802.1q is already set.

I'm stuck and getting flustrated. Can someone please guide me in the right path?

Also I know my switch is not a layer three switch, but can someone tell me why my Voice VLAN shuts down or my Data VLAN shuts down on my 2950 when I try and enable either one?

9 REPLIES
Hall of Fame Super Blue

Re: VLAN Communication and IP-Helper- Address troubles

There are a number of issues with your config.

1) On your switch you have vlan 1 and vlan 2 L3 interfaces using IP addresses from your subnets. But you have configured these as vlan 10 and 20 on switch ports and you have configured isl encapsulation for vlan 20 on your router.

These need to match. You say the data vlan is on the default vlan - is this vlan 10 or vlan 1 because it's not clear from your configs ie. the switchports are either in vlan 10 or 20 and not vlan 1.

So lets assume you are using vlan 10 for data and vlan 20 for voice.

2) The 2950 only supports 802.1q encapsulation so you can't use ISL encapsulation on the router.

3) You can only have one L3 vlan interface up and running on the 2950 at any one time. Assuming you are managing it from vlan 10 then you need to shutdown the vlan 1 and vlan 2 interfaces on the 2950 and use a L3 vlan 10 interface.

So try this updated config -

router

======

int fa0/1

encapsulation dot1q 10 native

int fa0/1.20

encapsulation dot1q 20

2950

int fa0/24

no switchport access vlan 20

switchport mode trunk

switchport trunk native vlan 10

int vlan 1

no ip address

shutdown

no int vlan 2

int vlan 10

ip address 10.0.1.17 255.255.255.128

Note the above config changes put the management of the switch into vlan 10 which is your data vlan. This is generally not recommended in production but will be fine for your lab.

Jon

New Member

Re: VLAN Communication and IP-Helper- Address troubles

So once I do this, this should fix the issue I'm having? So would the DHCP traffic flow towards the VLAN for voice?

Hall of Fame Super Blue

Re: VLAN Communication and IP-Helper- Address troubles

Kenneth

"So once I do this, this should fix the issue I'm having?"

No, i just thought i'd write a load of config for no real reason :-)

Seriously, you need to modify your config because it just doesn't make any sense at the moment. Once you've updated the config retest and see what results you get. Then post back here.

Jon

New Member

Re: VLAN Communication and IP-Helper- Address troubles

HAHA ok. Nice reply.

New Member

Re: VLAN Communication and IP-Helper- Address troubles

I can't run encapsulation dot1q on the on the fa 0/1. So Ii was able to get dot1q on a sub interface for my data, so that did not work. I put data traffic back on the interface fa 0/1..My voice fa 0/1.20 is pingable. So what now?

Hall of Fame Super Blue

Re: VLAN Communication and IP-Helper- Address troubles

Kenneth

Make these changes then -

router

======

int fa0/1.10

encapsulation dot1q 10

int fa0/1.20

encapsulation dot1q 20

do not have an IP address on the actual fa0/1 interface - just use 2 subinterfaces. Also we will leave the native vlan as 1 so no need for the native keyword.

On the switch

=============

int fa0/24

no switchport trunk native vlan 10

Apart from the above you must make sure that vlans 10 and 20 exist on the switch. So on the 2950 do a "sh vlan brief" and you should see vlan 10 and 20.

After you have made the changes can you then post the switch and router config again together with the output of a "sh int trunk" on the 2950.

Jon

New Member

Re: VLAN Communication and IP-Helper- Address troubles

I will try this. On can you PM me your contact information? It always seems like you know how to help me out LOL. I've only been a CCNA for 6 months. It sucks because I don't do Cisco on a daily basis.

New Member

Re: VLAN Communication and IP-Helper- Address troubles

I attached the configs from both switches, and router. I still couldn't traffic to the LAN with the sub-interface. I moved back to the LAN and took my connection from my 2950 back to my 2912XL switch..

New Member

Re: VLAN Communication and IP-Helper- Address troubles

Before I changed everything back. I copied the config from my primary, secondary switches, and I also copied the config from my router before I changed that as well. None of the changes worked.

323
Views
0
Helpful
9
Replies