Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Vlan config between Catalyst 2950 switch and Cisco 2600 router ..

HI,

I am trying to configure VLANs in 2950 switch and connect the trunk ports 16,17 to the router .

Now the problem is When I enable any One VLAN interface the other one goes down automatically .

for example :

#vlan 1

#no shut

It automatically gives VLAN 2 is administratively down .

If i again enable VLAN 2 it says ..

VLAN 1 administratively down...

I also tried enabling spanning-tree portfast but no use ??

where is the problem?Pls see the config

Thanks ..

sh ver

Cisco Internetwork Operating System Software

IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA8a, RELEASE SOFTWARE (fc1)

ROM: Bootstrap progis C2950 boot loader

System image file is "flash:/c2950-i6q4l2-mz.121-22.EA8a.bin"

cisco-2950#sh run

Building configuration...

version 12.1

!interface FastEthernet0/1

switchport access vlan 2

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/2

switchport access vlan 4

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/3

switchport access vlan 6

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/4

switchport access vlan 8

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/5

switchport access vlan 10

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/6

switchport access vlan 12

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/7

switchport access vlan 14

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/8

switchport access vlan 16

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/9

switchport access vlan 18

switchport mode access

spanning-tree portfast

interface FastEthernet0/12

switchport access vlan 24

interface FastEthernet0/16

switchport trunk allowed vlan 2,4,6,8,10,12,14

switchport mode trunk

interface FastEthernet0/17

switchport trunk allowed vlan 16,18,20,22,24,100

switchport mode trunk

interface FastEthernet0/20

switchport access vlan 100

switchport mode acce

interface FastEthernet0/21

switchport access vlan 100

switchport mode access

interface FastEthernet0/22

switchport access vlan 100

switchport mode access

spanning-tree portfast

interface FastEthernet0/23

switchport access vlan 100

switchport mode access

spanning-tree portfast

interface FastEthernet0/24

switchport access vlan 100

switchport mode access

spanning-tree portfast

interface Vlan1

ip address 10.1.0.254 255.255.255.0

no ip route-cache

shutdown

interface Vlan2

ip address 10.2.0.6 255.255.255.248

no ip route-cache

shutdown

interface Vlan3

no ip address

no ip route-cache

interface Vlan4

ip address 10.4.0.6 255.255.255.248

no ip route-cach

interface Vlan6

ip address 10.6.0.6 255.255.255.248

no ip route-cache

shutdown

interface Vlan8

ip address 10.8.0.6 255.255.255.248

no ip route-cache

shutdown

interface Vlan10

ip address 10.10.0.6 255.255.255.248

no ip route-cache

shutdown

interface Vlan12

ip address 10.12.0.6 255.255.255.248

no ip route-cache

shutdown

interface Vlan14

ip address 10.14.0.6 255.255.255.248

no ip route-cache

shutdown

interface Vlan16

ip address 10.16.0.6 255.255.255.248

no ip route-cache

shutdown

interface Vlan18

ip address 10.18.0.6 255.255.255.248

no ip route-cache

shutdown

interface Vlan20

ip address 10.20.0.6 255.255.255.248

no ip route-cache

shutdown

interface Vlan22

ip address 10.22.0.6 255.255.255.248

no ip route-cache

shutdown

interface Vlan24

ip address 10.24.0.6 255.255.255.248

no ip route-cache

shutdown

interface Vlan100

no ip address

no ip route-cache

shutdow

cisco-2950#

5 REPLIES
Cisco Employee

Re: Vlan config between Catalyst 2950 switch and Cisco 2600 rout

Hi Friend,

2950 is a pure payer 2 switch and only one layer 3 logical interface can be up at a time for admin/management purpose.

You can only create vlans at layer 2 on 2950 switches and all will be in active state if there is a trunk carrying those vlans.

Just create the vlans on 2950 and check the status in "sh vlan"

You can create the subinterfaces on your router for the number of vlans which you want to have intervlan routing and can define encapsulation dot1q command with vlan number under those subinterfaces.

Have a look at this link for more information

http://www.cisco.com/warp/public/473/50.shtml#801.1Q

HTH

Ankur

*Pls rate all helpfull post

Re: Vlan config between Catalyst 2950 switch and Cisco 2600 rout

Hi Murthy

You can have L2 Vlans enabled on your Cisco 2950 switch which is basically a Layer 2 switch provided you haven't exceeded the maximum permissible limit.

From the config which you have posted its very much clear that you are trying to create SVI (VLAN interfaces assigned with IP address).In Layer 2 switches such as Cisco 2950 you can have only one SVI up and running and when you try to enable the other SVI the existing will go down(admin down).This is the default nature and a limitation of a Layer 2 Switch.

You can have different Layer 2 vlans created under VLAN database and assign them under the respective interface using switchport access vlan and allow them on a trunk which is connected to the router.

On the router if you have IP Plus ios feature or a new ios code which can allow you to create and assign sub interfaces with encapsulation as 802.1q you can terminate the SVI.

regds

Community Member

Re: Vlan config between Catalyst 2950 switch and Cisco 2600 rout

Hi Prem & Ankur,

Thanks for the reply !!

did u mean to say that i should not specify the IP Address in the Switch End in the VLan interface !!

Pls correct me if iam wrong ?

Thanks & Regards

Cisco Employee

Re: Vlan config between Catalyst 2950 switch and Cisco 2600 rout

Hi Friend,

Yes you should only specify one vlan interface with an ip address just for management purpose.

On 2950 switch which is a layer 2 switch you should only create only one vlan interface with an ip address for management purpose and if you try to create second vlan interface and assign an ip address it will accept it but if you say "no shut" it will become active and previous configured interface will go down.

So only one vlan interface with an ip address is allowed to be active at a time for management purpose.

If its a layer 3 switch like 3550,3560 and above you can create multiple vlan interface with an ip address and all can be active at a time and can have routing between them.

HTH

Ankur

*Pls rate all helpfull posr

Community Member

Re: Vlan config between Catalyst 2950 switch and Cisco 2600 rout

Hi ,I have modified my present config and created one VLAN interface with 10.1.0.253 .

Now the problem is i am not able to ping any of other Vlans ....

OSPF is configured at the router end .

pls see switch&router configs .

ROUTER-2600 CONFIG:

interface FastEthernet0/0

description *** Connected to VLAN2,4,6,8,10,12,14****

no ip address

duplex auto

speed auto

interface FastEthernet0/0.1

encapsulation dot1Q 4

ip address 10.4.0.5 255.255.255.248

interface FastEthernet0/0.2

encapsulation dot1Q 6

ip address 10.6.0.5 255.255.255.248

interface FastEthernet0/0.3

encapsulation dot1Q 8

ip address 10.8.0.5 255.255.255.248

interface FastEthernet0/0.4

encapsulation dot1Q 10

ip address 10.10.0.5 255.255.255.248

interface FastEthernet0/0.5

encapsulation dot1Q 12

ip address 10.12.0.6 255.255.255.248

interface FastEthernet0/0.6

encapsulation dot1Q 14

ip address 10.14.0.5 255.255.255.248

interface FastEthernet0/0.7

encapsulation dot1Q 2

ip address 10.2.0.5 255.255.255.248

interface FastEthernet0/1

ip address 10.1.0.253 255.255.255.0

duplex auto

speed auto

interface FastEthernet0/1.1

encapsulation dot1Q 18

ip address 10.18.0.5 255.255.255.248

interface FastEthernet0/1.2

encapsulation dot1Q 16

ip address 10.16.0.5 255.255.255.248

interface FastEthernet0/1.3

encapsulation dot1Q 20

ip address 10.20.0.5 255.255.255.248

interface FastEthernet0/1.4

encapsulation dot1Q 22

ip address 10.22.0.5 255.255.255.248

interface FastEthernet0/1.5

encapsulation dot1Q 24

ip address 10.24.0.5 255.255.255.248

router ospf 1

log-adjacency-changes

network 10.1.0.0 0.0.255.255 area 1

network 10.2.0.0 0.0.255.255 area 2

network 10.4.0.0 0.0.255.255 area 2

network 10.6.0.0 0.0.255.255 area 2

network 10.8.0.0 0.0.255.255 area 2

network 10.10.0.0 0.0.255.255 area 2

network 10.12.0.0 0.0.255.255 area 2

network 10.14.0.0 0.0.255.255 area 2

network 10.16.0.0 0.0.255.255 area 1

network 10.18.0.0 0.0.255.255 area 1

network 10.20.0.0 0.0.255.255 area 1

network 10.22.0.0 0.0.255.255 area 1

network 10.24.0.0 0.0.255.255 area 1

*****************************************

SWITCH CONFIG :

VLAN:

interface Vlan1

ip address 10.1.0.254 255.255.255.0

no ip route-cache

TRUNK Port 16 & 17 :

interface FastEthernet0/16

switchport trunk allowed vlan 2,4,6,8,10,12,14

switchport mode trunk

interface FastEthernet0/17

switchport trunk allowed vlan 1,16,18,20,22,24

switchport mode trunk

3101
Views
0
Helpful
5
Replies
CreatePlease to create content