Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

vlan configuration problem

while configuring 2924xl as port based fixe d configuration, the packets are not forwarding to the port 1 where i need to forward the packet to port 1.

I have created all 24 vlan's and created one as trunk port and added all vlans to it.

Can any one help me on this.

13 REPLIES

Re: vlan configuration problem

Hi Swamy

Are you trying to connect the trunk to an external device like Router or a L3 switch ?

Also can you revert on whats the exact problem you are facing up over there ...

if possible do post out the config here..

regds

Re: vlan configuration problem

Hi

u r problem is not clear.can u alloborate it.

Thanks

Mahmood

New Member

Re: vlan configuration problem

avswamy, Can you post your config? Did you config your vlan via vlan database? Are all of the other ports in separate vlans? Is port 1 your trunk port? Are you looking at the port's traffic statistics to determine that the frames are not getting to port 1?

New Member

Re: vlan configuration problem

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,101-106,1002-1005

switchport mode trunk

no cdp enable

!

interface FastEthernet0/2

switchport access vlan 102

!

interface FastEthernet0/3

switchport access vlan 103

!

interface FastEthernet0/4

switchport access vlan 104

!

interface FastEthernet0/5

switchport access vlan 105

!

interface FastEthernet0/6

switchport access vlan 106

!

---------------------------------

here is the config and i am trying to communicate with server from the lan, the 1st port i want to communicate with server, at the same time i don't open the communications between systems(other ports).

Re: vlan configuration problem

Hi Swamy

Which is the other end connecting to the Fastethernet 0/1 of your switch ?

Is it connecting to your server or to any other N/W devices ?

regds

New Member

Re: vlan configuration problem

Did you configure the vlan via vlan database or in global config? Next, I would recommend that your turn on spanning-tree portfast on all of your ports-because all of them are connected to hosts-to reduce connectivity delay. On port 1 fa0/1 I would do a 'sho int fa0/1 swithport' to determine if the port is operating in the correct mode (access via trunk). I would look at my traffic counters to see if frames are actually begin received (output) on that port..Lastly I would look at the trunk configuration on the server. You may consider turning off DTP negoitations as well.

New Member

Re: vlan configuration problem

There are two solutions to this scenario:

1. The clean solution is to have an upstream router connected to Fa0/1 to perform Inter-VLAN routing. You would then define a separate VLAN for your server and connect the server on a port configured for this VLAN.

2. If I understand correctly, your server is directly connected to Fa0/1. In this case, you need to configure a multi-access port instead of a trunk port. Note that the use of multi-access ports and trunk ports on the same switch is exclusionary (one or the other only, not both). You would then need a NIC card and a driver for this NIC card on your server that supports VLAN configuration.

New Member

Re: vlan configuration problem

can you send us the config details...

-senthil

New Member

Re: vlan configuration problem

this is the first managed switch and the 1st port is connected to a server and all the remaining ports are connected to work stations.

Re: vlan configuration problem

Hi

Where u r doing u r intervlan routing.I think u connected the server to the trunk port.If u want to communicate between u r clients n server u need to go through a layer 3 device.

i dnot see any intervaln routing information.

Thanks

Mahmood

New Member

Re: vlan configuration problem

If with out layer3 switch, the layer2 configuration will not work means cisco then trouble some to me, and I have to check the other companies like cabletron for the same.

Where I have configure N number of switches on cabletron, which can be configured with out any layer 3switch for communicating with server from clients in the local lan.

New Member

Re: vlan configuration problem

This has nothing to do with cisco. That is basic networking. There has to be a router in this picture.

New Member

Re: vlan configuration problem

In this scenario it appears as though he is trying to run 802.1Q the server, allowing all users access to the server but no access to one another.

160
Views
0
Helpful
13
Replies