Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Vlan created on 6509 Catalyst Switch: End Node Have No Internet Access

Hello All, happy Tuesday.

I have Created a New VLAN on a WS-6509-E Switch - IOS Version 12.2(33) SXH3a.

Through the Gobal Configuration Mode

(a) Created VLAN 30 - Shows as an Active Vlan -   Switch# show vlan - command

Switch (config)# interface vlan 30

Switch (config)# ip address 10.1.2.1 255.255.255.0

Switch (config)# no shut

(b) Switch (config)# interface Gi3/36

(b) Switch (config)# switchport mode access

(c) Switch (config)# switchport access vlan 30

(d) Switch (config)# no shut

Please let me know if anyone have any suggestions for - The Node assigned to the relevant Switchport ( Gi 3/36 ) - Not able to get on the internet through that Vlan.

Thanks.

9 REPLIES

Vlan created on 6509 Catalyst Switch: End Node Have No Internet

A few things to check:

Can you ping interface vlan 30 from the host?

Does the host have the correct gateway (10.1.2.1)?

Does the firewall/router (or the device that does natting) know to nat the 10.1.2.0/24 subnet?

Can you ping any hosts in other vlans that are attached to this switch?

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Vlan created on 6509 Catalyst Switch: End Node Have No Internet

Hello John,

Thank you for your responses on this matter, please note the answers for the questions you presented

Can you ping interface vlan 30 from the host? YES

Does the host have the correct gateway (10.1.2.1)? YES

Does the firewall/router (or the device that does natting) know to nat the 10.1.2.0/24 subnet? How do i check for this.

Can you ping any hosts in other vlans that are attached to this switch? NO

Thanks...

Vlan created on 6509 Catalyst Switch: End Node Have No Internet

Can you post the following?

sh vlan id 30

sh run int vlan 30

sh ip route

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Vlan created on 6509 Catalyst Switch: End Node Have No Internet

Hi John, thanks for your review and please find the info below :

SHOW VLAN ID 30 -

VLAN Name                             Status    Ports
SHOW RUN INT VLAN 30 _---- -------------------------------- --------- -------------------------------
30   wireless                         active    Gi3/1, Gi3/36

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
30   enet  100030     1500  -      -      -        -    -        0      0   

Remote SPAN VLAN
----------------
Disabled


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

SHOW RUN INT VLAN 30 -

Vlan30 is up, line protocol is up

  Internet address is 10.1.2.1/24

  Broadcast address is 255.255.255.255

  Address determined by setup command

  MTU is 1500 bytes

  Helper address is not set

  Directed broadcast forwarding is disabled

  Outgoing access list is not set

  Inbound  access list is not set

  Proxy ARP is enabled

  Local Proxy ARP is disabled

  Security level is default

  Split horizon is enabled

  ICMP redirects are always sent

  ICMP unreachables are always sent

  ICMP mask replies are never sent

  IP fast switching is enabled

  IP Flow switching is disabled

  IP CEF switching is enabled

  IP CEF switching turbo vector

  IP Null turbo vector

  IP multicast fast switching is enabled

  IP multicast distributed fast switching is disabled

  IP route-cache flags are Fast, CEF

  Router Discovery is disabled

  IP output packet accounting is disabled

  IP access violation accounting is disabled

  TCP/IP header compression is disabled

  RTP/IP header compression is disabled

  Probe proxy name replies are disabled

  Policy routing is disabled

  Network address translation is disabled

  BGP Policy Mapping is disabled

  Output features: IP Post Routing Processing, HW Shortcut Installation

  Post encapsulation features: MTU Processing, IP Protocol Output Counter, IP Sendself Check, HW Shortcut Installation

  Sampled Netflow is disabled

  IP Routed Flow creation is disabled in netflow table

  IP Bridged Flow creation is disabled in netflow table

  WCCP Redirect outbound is disabled

  WCCP Redirect inbound is disabled

  WCCP Redirect exclude is disabled

  IP multicast multilayer switching is disabled

SHOW IP ROUTE  -

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.50.100.1 to network 0.0.0.0

     172.20.0.0/24 is subnetted, 1 subnets

C       172.20.160.0 is directly connected, Vlan10

     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C       10.1.2.0/24 is directly connected, Vlan30

C       10.50.100.0/23 is directly connected, Vlan1

S*   0.0.0.0/0 [1/0] via 10.50.100.1

Vlan created on 6509 Catalyst Switch: End Node Have No Internet

Are you saying that from the host on vlan 30, you cannot ping vlan 1 or vlan 10's SVI?

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Vlan created on 6509 Catalyst Switch: End Node Have No Internet

Hi John, no i want the VLAN separate just like it's now ( the other Vlan's have no access to Vlan 30 and versa verse).

I want to use the Vlan 30 nodes to use 10.1.2.0 Natted address to speak to each other and to get internet access through this setup. Thus far I am only testing one Switchport Gi3/36 assigned to Vlan 30, however i have no access to the internet through the the Switchport.

The test Node can ping it's gateway 10.1.2.1 and the natted address of the Cisco Switch on 10.50.100.x

The test node NIC is configured with a Static IP - 10.1.2.3 / 255.255.255.0 / GW 10.1.2.1

All i need to accomplish is for nodes connected to the relevant Switchports which is assigned to Vlan 30, to get out to the internet.

Thanks,

Vlan created on 6509 Catalyst Switch: End Node Have No Internet

I think I understand now. What device is doing NAT?

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

Vlan created on 6509 Catalyst Switch: End Node Have No Internet

The WS 6509 - E Switch

Vlan created on 6509 Catalyst Switch: End Node Have No Internet

Post your nat configs and all interfaces. What does your routing to the internet?

I don't see an nat statement on your svi. You should have an "ip nat inside" on the svi if you're wanting to translate those addresses to the vlan that has the "ip nat outside" command.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
334
Views
0
Helpful
9
Replies
CreatePlease to create content