Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VLAN creation in WS-C2948G-L3 ?

Hi,

I just bought a Cisco layer 3 switch (model Number: WS-C2948G-L3) from ebay and my intend is to create VLAN's in this. But strangely enough, I don't see any commands to create vlans. but I see the command sh vlans.

I think this switch is loaded with Cat OS and so I tried to create vlan's using set command, but seems the switch doesn't take this command.

Router#set?
set  setup

But,

Router#set ?
% Unrecognized command

Find the below output of show version and show bootflash commands:

Router#sh bootflash:

Boot flash directory:
File  Length   Name/status
  1   3183128  cat2948g-in-mz.120-7.W5.15d.bin
[3183192 bytes used, 13594024 available, 16777216 total]
16384K bytes of processor board Boot flash (Read/Write)

Router#sh ver

Cisco Internetwork Operating System Software
IOS (tm) L3 Switch/Router Software (CAT2948G-IN-M), Version 12.0(7)W5(15d)  RELE
ASE SOFTWARE
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Mon 05-Jun-00 16:16 by integ
Image text-base: 0x60010928, data-base: 0x605B8000

ROM: System Bootstrap, Version 12.0(7)W5(15a) RELEASE SOFTWARE

Router uptime is 17 hours, 38 minutes
System restarted by power-on
System image file is "bootflash:cat2948g-in-mz.120-7.W5.15d.bin"

cisco Cat2948G (R5000) processor with 49152K/16384K bytes of memory.
R5000 processor, Implementation 35, Revision 2.1
Last reset from power-on
48 FastEthernet/IEEE 802.3 interface(s)
2 Gigabit Ethernet/IEEE 802.3z interface(s)
121K bytes of non-volatile configuration memory.
16384K bytes of processor board Boot flash (Read/Write)

Configuration register is 0x2142 (will be 0x2102 at next reload)

I know this switch is out of sale and cico doesn't support this switch also. Do I need to have a different firmware installed, to get VLAN's created?

Any help greatly appreciated.

Thanks in advance,

Ribin

2 ACCEPTED SOLUTIONS

Accepted Solutions
New Member

Re: VLAN creation in WS-C2948G-L3 ?

try this

2948G-L3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
2948G-L3(config)#bridge irb
!create vlan 10
2948G-L3(config)#bridge 10 protocol ieee
2948G-L3(config)#bridge 10 route ip
2948G-L3(config)#interface bvi 10 
2948G-L3(config-if)#ip address 10.1.1.1 255.255.255.0
2948G-L3(config-if)#exit
!assign vlan 10 to fast 1
2948G-L3(config)#interface fast 1 2948G-L3(config-if)#no shutdown 2948G-L3(config-if)#bridge-group 10
detail see

http://www.cisco.com/en/US/products/hw/switches/ps672/products_tech_note09186a0080093f8f.shtml#ex1

Re: VLAN creation in WS-C2948G-L3 ?

Hi Ribin

I think here you need to configure a BVI Interfaces with the IP you want.

Example Interface:

Router(config)# interface fastethernet 2.1

Router(config-subif)# encap isl 50

Router(config-subif)# bridge-group 1

bridge-goup 1 is interfave BVI 1 in BVI 1 you specified the IP.

Example BVI:

Router(config)# bridge irb

Router(config)# interface bvi bridge-group

Router(config-if)# ip address ip-address ip-address-subnet-mask

Router(config-if)# exit

Router(config)# bridge bridge-group route protocol

Detail informations here:

http://www.cisco.com/en/US/docs/switches/lan/catalyst2948gand4908g/12.0_18_w5_22a/configuration/guide/bridging.html

Hope that is the key for you.

- Sebastian

16 REPLIES
Purple

Re: VLAN creation in WS-C2948G-L3 ?

   That is a native IOS box so try creating them the way you would on a normal IOS box .  I haven't worked on one of the L3 versions only the L2 versions which were catos and used set based commands .   Great way to search for this stuff is to just go to the main cisco.com webpage and do a search for what you want to do .

http://www.cisco.com/en/US/products/hw/switches/ps606/products_configuration_guide_chapter09186a008007d102.html#xtocid263693

conf t

vlan 20

name -  xxx.xxx.xxx.xxx/mask

int vlan 20

ip address xxx.xxx.xxx.xxx mask

New Member

Re: VLAN creation in WS-C2948G-L3 ?

Hi,

I am not able to enter any of the vlan commands. I tried some of the commands in http://www.ciscopress.com/articles/article.asp?p=29803.

I tried as you mentionedalso.

Router#conf t

Router(config)#vlan?

%Unrecognized command.

How can I proceed from here?

- Ribin

New Member

Re: VLAN creation in WS-C2948G-L3 ?

try this

2948G-L3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
2948G-L3(config)#bridge irb
!create vlan 10
2948G-L3(config)#bridge 10 protocol ieee
2948G-L3(config)#bridge 10 route ip
2948G-L3(config)#interface bvi 10 
2948G-L3(config-if)#ip address 10.1.1.1 255.255.255.0
2948G-L3(config-if)#exit
!assign vlan 10 to fast 1
2948G-L3(config)#interface fast 1 2948G-L3(config-if)#no shutdown 2948G-L3(config-if)#bridge-group 10
detail see

http://www.cisco.com/en/US/products/hw/switches/ps672/products_tech_note09186a0080093f8f.shtml#ex1

New Member

Re: VLAN creation in WS-C2948G-L3 ?

I can enter these commands in the switch. But how can I create vlan's?

- Ribin

New Member

Re: VLAN creation in WS-C2948G-L3 ?

bridge 10 is vlan 10.

show vlans

New Member

Re: VLAN creation in WS-C2948G-L3 ?

Below is my config:

sh run
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
ip subnet-zero
bridge irb
!
!
!
interface FastEthernet1
no ip address
no ip directed-broadcast
bridge-group 10
!
interface FastEthernet2

no ip directed-broadcast
shutdown
!
interface FastEthernet3
no ip address
no ip directed-broadcast
shutdown

interface BVI10
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
no ip route-cache cef
!
ip classless
!
bridge 10 protocol ieee
bridge 10 route ip
line con 0
transport input none
line aux 0
line vty 0 4
!
end

Nothing shown in sh vlan:

Router#sh vlan

No Virtual LANs configured.

Router#

- Ribin

New Member

Re: VLAN creation in WS-C2948G-L3 ?

Do you have device connect to fast port 1?

If I remember right ( 12 years ago), bridge can not up/up until that port actived.

New Member

Re: VLAN creation in WS-C2948G-L3 ?

I connected a laptop to fastethernet 1. But still no luck it seems...

Router#sh ip int bri                   
Interface                  IP-Address      OK? Method Status                Prot
ocol
FX1000:1                   unassigned      YES unset  up                    up

FastEthernet1              unassigned      YES unset  up                    up

FastEthernet2              unassigned      YES unset  administratively down down

FastEthernet3              unassigned      YES unset  administratively down down

FastEthernet4              unassigned      YES unset  administratively down down

FastEthernet5              unassigned      YES unset  administratively down down

FastEthernet6              unassigned      YES unset  administratively down down

FastEthernet7              unassigned      YES unset  administratively down down

FastEthernet8              unassigned      YES unset  administratively down down

FastEthernet9              unassigned      YES unset  administratively down down

FastEthernet10             unassigned      YES unset  administratively down down


Router#sh vlan

No Virtual LANs configured.

Router#

- Ribin

New Member

Re: VLAN creation in WS-C2948G-L3 ?

Any other option I should try out?

I think the issue with the firmware I am having. Please correct me if I am wrong. Could someone let me know the actual firmware version which will work in this switch for vlans?

- Ribin

New Member

Re: VLAN creation in WS-C2948G-L3 ?

No more help/suggestions?

- Ribin

Re: VLAN creation in WS-C2948G-L3 ?

Hello,

Like I see in some old documentations you can't use the "known" IOS vlan commands.

I prefer the 802.1q configuration and I would say try it, hope that helps

please look here:

http://www.cisco.com/en/US/docs/switches/lan/catalyst2948gand4908g/12.0_18_w5_22a/configuration/guide/vlan_cnfg.html

best regards,

Sebastian

New Member

Re: VLAN creation in WS-C2948G-L3 ?

Hi Sebastian,

In the mentioned doc, I was going through "Configuring ISL VLAN Encapsulation" and Figure 5-2     An ISL VLAN Bridging Configuration.

It talks about vlan 50 and vlan 100.Where do I give IP address for vlan's?

- Ribin

Re: VLAN creation in WS-C2948G-L3 ?

Hi Ribin

I think here you need to configure a BVI Interfaces with the IP you want.

Example Interface:

Router(config)# interface fastethernet 2.1

Router(config-subif)# encap isl 50

Router(config-subif)# bridge-group 1

bridge-goup 1 is interfave BVI 1 in BVI 1 you specified the IP.

Example BVI:

Router(config)# bridge irb

Router(config)# interface bvi bridge-group

Router(config-if)# ip address ip-address ip-address-subnet-mask

Router(config-if)# exit

Router(config)# bridge bridge-group route protocol

Detail informations here:

http://www.cisco.com/en/US/docs/switches/lan/catalyst2948gand4908g/12.0_18_w5_22a/configuration/guide/bridging.html

Hope that is the key for you.

- Sebastian

New Member

Re: VLAN creation in WS-C2948G-L3 ?

Great..It worked.......Thanks Sebastian

- Ribin

New Member

Re: VLAN creation in WS-C2948G-L3 ?

Hi,

I used below commands for creating vlan's

2948G-L3#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
2948G-L3(config)#bridge irb
!create vlan 10

2948G-L3(config)#bridge 10 protocol ieee

2948G-L3(config)#bridge 10 route ip

2948G-L3(config)#interface bvi 10
2948G-L3(config-if)#ip address 10.1.1.1 255.255.255.0
2948G-L3(config-if)#exit
!assign vlan 10 to fast 1
2948G-L3(config)#interface fast 1
2948G-L3(config-if)#no shutdown
2948G-L3(config-if)#bridge-group 10

Now I need to create a trunk port in this switch. Any help?

- Ribin

Re: VLAN creation in WS-C2948G-L3 ?

Sure Ribin,

Check this out:

http://www.cisco.com/en/US/docs/switches/lan/catalyst2948gand4908g/12.0_18_w5_22a/configuration/guide/vlan_cnfg.html#wpxref95738

Here you will find some examples, better as I can told you here..

hope that is ok..

if you have further questions, just let me know..

- Sebastain

2695
Views
0
Helpful
16
Replies
CreatePlease login to create content