Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

vlan doesn't work

Hi there. I have what is hopefully a very easy/newbie question. I work for a nonprofit that received a WS-C2960S-24TS-L as a donation. We want to create a VLAN on a single port that is connected to a 5-port switch to segment the computers used by our participants from our office computers.

I believe I followed the steps correctly to telnet to the device, create the VLAN and then assign a port to the VLAN. However when I plug the switch (or even just a single computer) into the jack connected to that port the computer is unable to resolve an IP address (Windows 7 reports that it won't connect tho my location network or the Internet). I have tried creating the VLAN on a different port, tried different cables but the same results. The VLAN port on the Cisco lights up green when I connect to it, but the computer/s on the receiving end don't get a conection. Am I missing a command I should issue once the VLAN is created and the port is assigned? It seems like it should be a straight-forward process but it just doesn't seem to work.

Thanks in advance for any suggestions.

3 REPLIES
Purple

   To add a new vlan just do

   To add a new vlan just do this.   How is the the 2960 hooked to the rest of your network and where is your dhcp server located? 

 

conf t

vlan X

exit

interface g0/X

switchport

switchport mode access

switchport access vlan X

 

New Member

As said, you need to

As said, you need to elaborate more on your topology.

The reason it's not working is as you have just simply placed it within a VLAN, this means it is isolated and therefore cannot communicate with anything else!

Martin

New Member

creating vlan provide you

creating vlan provide you layer-2 connectivity thats why your port on switch turns green, but in order to connect with network you also need layer-3 connectivity by assigning an ip address.

example:

vlan 10

exit

 

interface vlan 10

ip address 10.1.1.1 255.255.255.0

no shut

 

interface g0/1

switchport mode access

switchport access vlan 10

no shut

 

 

139
Views
0
Helpful
3
Replies
CreatePlease to create content