Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

vlan id not seen by ESX host

Hi there,

I was wondering if anyone has come across an issue whereby one vlan id i.e 10 is not seen by ESX host vnic's but the vnic in this vlan 10 can ping the default gateway on the vlan 10. The vnic's see the ip range but missing the vlan id of 10. A second vlan on this same switch can be seen correct by vnic's

Here is config of switch port facing the vnic.

interface GigabitEthernet0/16

switchport trunk allowed vlan 10,20

switchport mode trunk

spanning-tree portfast

I was wondering also that native vlan 20 defined on further upstream switch would this cause this issue. I don't thinks so.

Regards,

Michael.

Everyone's tags (4)
2 REPLIES
Silver

vlan id not seen by ESX host

Try configuring native vlan 20 on the trunk. also do not forget trunk encapsulation!!!!

---

Posted by WebUser Neeraj Jagga from Cisco Support Community App

New Member

vlan id not seen by ESX host

I tried that but lost connectivity on vlan 20

SW1 - Blade sw

interface FastEthernet0/10

description ** uplink to enc2 sw4

switchport mode trunk

spanning-tree portfast

end

Port        Mode         Encapsulation  Status        Native vlan

Fa0/10      on           802.1q         trunking      1

Blade switch - SW 1

interface GigabitEthernet0/17
switchport trunk allowed vlan 32,33,35,42,43,45,51-64,70-73,81,200
switchport mode trunk

Port        Mode         Encapsulation  Status        Native vlan

Gi0/17      on               802.1q         trunking      1

Switchport on vnic

interface GigabitEthernet0/16
switchport trunk allowed vlan 81,200
switchport mode trunk
spanning-tree portfast

Port        Mode         Encapsulation  Status        Native vlan

Gi0/16      on               802.1q         trunking      1

675
Views
0
Helpful
2
Replies
CreatePlease to create content