Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Vlan ID's and Trunking

Hello,

I need your help to understand Vlan ID’s and trunking.

We have three or four networks in place with some twenty subnets /Vlans from Vlan1 10.1.1.x, Vlan2 192.168.0.x, and so on to Vlan 129. We have two new businesses with the same subnets like Vlan 1 on the three or four networks listed above with different subnets assigned – like Vlan 1 is 192.168.1.x, Vlan 2 192.168.0.x and so on through Vlan 10 for the new businesses.

I was able to create new trunk ports on all equipment then attach the older networks with the new and the trunks come online and we see the neighbors when typing show CDP neighbors detail, then we add new Vlans for the new business switches on the same subnet like Vlan 201 10.1.1.x to mimic the first three or four networks and placing them on the same subnet. We have a problem when trying to ping the new equipment Vlans on the same subnet not able to connect or ping them, we wiped the new equipment adding Vlans like the first three or four networks with Vlan1 10.1.1.x, Vlan2 192.168.0.x and so on through Vlan 129, and doing this all networks work and we can ping all networks from each switch with some additional routing statements.

I need to know why we can’t have different Vlan numbers talk with other Vlan numbers on the same subnet, why the Vlan numbers need to match on all equipment with Vlan 1 on switch one needs to be on switch 2 – 9 and the only way they will talk together.

Have I missed something – can we have Vlan 1 with 10.1.1.x on switch 1, on switch 2 have Vlan 101 with 10.1.1.x on the same subnet and talk with switch 1. We have so many Vlans they do not match with the new networks or subnets, do you know of a way to allow Vlan ID numbers to differ from one piece of equipment to another and be on the same subnet.

Thank you all.

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Vlan ID's and Trunking

How big is the network,  how many switches?

The idea of extended vlans is pretty out of date in todays layer 3 switch world with line speed routing.

Vlan 1 on switch a won't talk to vlan 2 on switch B without routing,  either routing a stick or Switched virtual intverafces ( int vlan 1).  The reason why is the very nature of vlans.  It seperates broadcast domains so there aren't so many collisions. 

Ify ou trunk between switches the traffic is tagged with a dot1q header that says what vlan it is apart of.  Unless your vlans match on each switch by the very nature they wont talk.

So you either have to set the ports to a routed interface, setup static routes/dynamic routing protocol like eigrp rip or ospf, and ensure the subnets don't overlap.

The other option is keep them at layer 2 and give it a switchport access vlan #, and give the switch a route out of the network using the SVI of that vlan.

Example:

int vlan 1

ip address 10.1.1.1 255.255.255.0

int f0/0

switchport mode access

switchport access vlan 1

ip route 0.0.0.0 0.0.0.0 10.1.1.4 (assuming this address is on the other switches int vlan 1 SVI)

The above statement will alllow routing to happen from switch a to b while on different subnets, but you will need to ensure ther is no overlapping IP's with subnet masks.

Much easier way is to get allt he vlan numbers to match and make them trunks.  Also ensure there is no overlapping ip's.  That way the SVI's of all the switches can talk along with all the hosts if they are all in the same subnet, network.

I dont know how your network is setup,  but piont is  vlans 1 has to match vlan 1 on each switch when seperated by a trunk.  the traffic coming out of a trunk port from vlan 1 is literally tagged with vlan 1.  Now if its native vlan it wont be tagged, but if the subnet doesnt match (10.1.1.1 vs 192.168.1.1 for example even though they are in the same subnet they won't talk  without a router.  Basically like ships in the night, they are there but they dont see each other.

4 REPLIES
Purple

Vlan ID's and Trunking

  It would work if you didn't need to trunk the links.  If you are trunking the switch needs to add a vlanid to the header so it knows what vlan the traffic belongs to so it must have the same vlans assigned on the other end so that when the switch strips the vlanid off when it comes in it know what to to with the traffic .  If you don't need to trunk you can have it vlan 2 on one end of the link and vlan 5 on the other end as long as they are in the same subnet.

New Member

Re: Vlan ID's and Trunking

Hello,

How about this - we create a new Vlan called 241 that we create on all network switches with a new subnet like 192.168.5.x with switch 1 192.168.5.2/24, switch 2 192.168.5.3/24, and switch 3 192.168.5.4/24. then we trunk all switches and on the trunk port we add switchport trunk native vlan 241 - will this allow the connection betwen all switches, and use one Vlan ID to handle the trunking.

Will this work to connect all the networks together?

Thank you

Message was edited by: Stephen Sisson

New Member

Vlan ID's and Trunking

How big is the network,  how many switches?

The idea of extended vlans is pretty out of date in todays layer 3 switch world with line speed routing.

Vlan 1 on switch a won't talk to vlan 2 on switch B without routing,  either routing a stick or Switched virtual intverafces ( int vlan 1).  The reason why is the very nature of vlans.  It seperates broadcast domains so there aren't so many collisions. 

Ify ou trunk between switches the traffic is tagged with a dot1q header that says what vlan it is apart of.  Unless your vlans match on each switch by the very nature they wont talk.

So you either have to set the ports to a routed interface, setup static routes/dynamic routing protocol like eigrp rip or ospf, and ensure the subnets don't overlap.

The other option is keep them at layer 2 and give it a switchport access vlan #, and give the switch a route out of the network using the SVI of that vlan.

Example:

int vlan 1

ip address 10.1.1.1 255.255.255.0

int f0/0

switchport mode access

switchport access vlan 1

ip route 0.0.0.0 0.0.0.0 10.1.1.4 (assuming this address is on the other switches int vlan 1 SVI)

The above statement will alllow routing to happen from switch a to b while on different subnets, but you will need to ensure ther is no overlapping IP's with subnet masks.

Much easier way is to get allt he vlan numbers to match and make them trunks.  Also ensure there is no overlapping ip's.  That way the SVI's of all the switches can talk along with all the hosts if they are all in the same subnet, network.

I dont know how your network is setup,  but piont is  vlans 1 has to match vlan 1 on each switch when seperated by a trunk.  the traffic coming out of a trunk port from vlan 1 is literally tagged with vlan 1.  Now if its native vlan it wont be tagged, but if the subnet doesnt match (10.1.1.1 vs 192.168.1.1 for example even though they are in the same subnet they won't talk  without a router.  Basically like ships in the night, they are there but they dont see each other.

New Member

Vlan ID's and Trunking

Very large network ,

thank you

1358
Views
0
Helpful
4
Replies
CreatePlease to create content