Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

vlan on 2960s catalyst

hallo Community,i need your help

i have a Catalyst 2960S since 2 days iam a new user, i like to configure the switch!

my first problem is: i have 2 vlan vlan1/24 and vlan200/24 i'd like to cofig port1 to be tagged on the 2 vlans i know from hp port must be tagged

how can i config port 1 to be tagged on vlan1 and vlan200? and port 2 to be untagged in vlan1 and untagged in vlan200?

can some body help?

thank you very much

best regards Tony

12 REPLIES
Hall of Fame Super Gold

vlan on 2960s catalyst

Tagged VLAN:

conf t

interface G 1/0/

switchport mode trunk

switchport trunk  allowed

end

wr

UN-Tagged VLAN:

conf t

interface G 1/0/

switch access vlan

end

wr

New Member

vlan on 2960s catalyst

thank you for the answer,

but i still have the problem in vlan200!!

vlan1 is my default vlan

in vlan200 there is a dhcp server,

i connect the switch to the LAN through port 1, how can i configure port one so that the switch can communicate on the 2 vlans?

on port 2 i have connected my apple and i didnot become an ip adress from the dhcp server

how shall i config port 2?

thank u

best regards Tony

Re: vlan on 2960s catalyst

Hi Tony,

Please config like below..

#interface -->interface number to which you connect the switch
#switch port mode trunk
#switchport trunk  allowed vlan 200 --> so on you can if you want any other vlan like vlan 1


#interface -->interface number to which you connect your laptop
#switchport access vlan 2

Please rate the helpfull posts.
Regards,
Naidu.

Purple

vlan on 2960s catalyst

Hi,

and port 2 to be untagged in vlan1 and untagged in vlan200?

An access port can only be a member of 1 VLAN either VLAN 1 ( default) or VLAN 200 with the switchport access vlan 200

interface command.

If you want some client connected to a port in 1 VLAN to get an IP address via DHCP from a server in another VLAN then

you must configure ip helper-address command under the interface VLAN  which the client is a member of.

example: client connected to a port in VLAN 1

-interface vlan 1

ip address x.x.x.x y.y.y.y.y

ip helper-address x.x.x.x  where x.x.x.x is the ip address of DHCP server.

Regards.

Alain

Don't forget to rate helpful posts.

vlan on 2960s catalyst

Hi Tony,

Yes, you need the ip helper command inorder to forward the dhcp broadcast request from the respective vlan to dhcp server. So it must be like below example...

in vlan200
ip address 10.10.10.1
ip helper-address "dhcp server ip"


Please rate the helpfull posts.
Regards,
Naidu.

New Member

vlan on 2960s catalyst

in vlan200 (10.10.200.0/24)

i have a dhcp server

ip adress 10.10.200.1

and thats my problem how can i config port 2 in vlan200 so that my lap becomes an ip= 10.10.200.3

the cisco switch(port1) is connected to a hp switch(port3) so i think i have to config cisco port1 to be tagged on vlan1 and vlan200 then i can config cisco port2 to be untagged in vlan200 because when i untagged port2 on vlan200 i will directly become an ip from the dhcp server or what do u think? (see my attachment),

Purple

vlan on 2960s catalyst

Hi,

in this case you have nothing special to do as your client is in same vlan as the server.

so just do this on the Cisco switch:

on port 1:

switchport mode trunk

on port 2:

switchport mode access

switchport access vlan 200

Just make sure the native vlan is the same on the HP and Cisco for the trunk link between the 2 devices.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

vlan on 2960s catalyst

Hey thank you for the tipps,

on port 1 the trunk works, but on port 2 i am still have no connection to the dhcp server.

ASA 5510 is doing the routing

best regards

Tony

Purple

vlan on 2960s catalyst

Hi,

where is the ASA in your topology, I didn't see it.

Repost a full topology and full configs.

Regards.

Alain

Don't forget to rate helpful posts.
New Member

vlan on 2960s catalyst

i would like to config the cisco to work like the hp switches because by and by i want to change to cisco.

so i still have the question:

how i tagged the 2960 in vlan1 aund vlan2

and

how i untagged the pc in vlan1 and the mac in vlan2

ps i have made the upgrad of the IOS.

best regards

Tony

New Member

vlan on 2960s catalyst

hey,

have u seen the topology?

Hall of Fame Super Gold

Re: vlan on 2960s catalyst

And who's doing your routing?

Oh well, you have a 2960.  Upgrade the IOS to 12.2(55)SE1 or later and you  have limited static routing functionality.

897
Views
9
Helpful
12
Replies
CreatePlease to create content