Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Vlan on Cisco SG300-28 switch no internet access

I'm new to cisco but been configuring those Cisco 800s etc. The situation is I have a Cisco 1941 router that throws the internet to the cisco SG300 switch Layer3 with 2 VLANs. VLAN1 got internet while VLAN10 don't have. Here's the config I did from GUI.

-------

vlan database

vlan 10

exit

voice vlan oui-table add 0001e3 Siemens_AG_phone________

voice vlan oui-table add 00036b Cisco_phone_____________

voice vlan oui-table add 00096e Avaya___________________

voice vlan oui-table add 000fe2 H3C_Aolynk______________

voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone

voice vlan oui-table add 00d01e Pingtel_phone___________

voice vlan oui-table add 00e075 Polycom/Veritel_phone___

voice vlan oui-table add 00e0bb 3Com_phone______________

bonjour interface range vlan 1

hostname switchbe1e1f

no passwords complexity enable

username cisco password encrypted 7af78c911d5b48bea1dc2449d9d89513abeb4be5 privilege 15

ip telnet server

!

interface vlan 1

ip address 192.168.80.1 255.255.255.0

no ip address dhcp

!

interface vlan 10

ip address 192.168.10.1 255.255.255.0

!

interface gigabitethernet1

switchport mode access

switchport access vlan 10

switchport general pvid 10

!

interface gigabitethernet2

switchport trunk native vlan 10

!

interface gigabitethernet3

switchport trunk native vlan 10

!

interface gigabitethernet4

switchport trunk native vlan 10

!

interface gigabitethernet5

switchport trunk native vlan 10

!

interface gigabitethernet6

switchport trunk native vlan 10

!

interface gigabitethernet24

switchport mode access

!

ip route 0.0.0.0 0.0.0.0 192.168.80.2

------

Thanks in advance.

Everyone's tags (1)
2 REPLIES
Purple

Vlan on Cisco SG300-28 switch no internet access

Hi,

Could you post following on the 1941 router:

show run | s nat

show access-list

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Vlan on Cisco SG300-28 switch no internet access

It's ok man I think I figured it out, it's not the switch configuration problem... it's something lacking on my router.

Solution: I added another ip route on the router for the VLAN10

192.168.10.0 255.255.255.0 192.168.80.1

Thank you for asking about the cisco 1941 it made me check it.

429
Views
0
Helpful
2
Replies