Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VLAN problem in CISCO 2811 Router

I am facing serious problem with my 2811 router.

I have install a one 4ESW (HWIC)card.

All of these ports are under VALN 1.

Then I have just configured 4 VLANS in here.

Like :

FastEthernet0/0/0 as VLAN 1 (IP ADDRESS : 192.168.80.1/29)

FastEthernet0/0/1 as VLAN 2 (IP ADDRESS : 192.168.80.9/29)

FastEthernet0/0/2 as VLAN 3 (IP ADDRESS : 192.168.80.17/29)

FastEthernet0/0/3 as VLAN 4 (IP ADDRESS : 192.168.80.25/29)

Well this is working fine.

Now I have just install a new 4ESW (HWIC) card, in slot 1. ports are like that.

FastEthernet0/1/0 , FastEthernet0/1/1 , FastEthernet0/1/2 , FastEthernet0/1/3.

Those ports are also in VLAN 1.

Now I have just configured those new ports as separate VLANS. Like

FastEthernet0/1/0 as VLAN 5 (IP ADDRESS : 192.168.80.33/29)

FastEthernet0/1/1 as VLAN 6 (IP ADDRESS : 192.168.80.41/29)

FastEthernet0/1/2 as VLAN 7 (IP ADDRESS : 192.168.80.49/29)

FastEthernet0/1/3 as VLAN 8 (IP ADDRESS : 192.168.80.57/29)

Well this VLANS are not working. Even the ports are UP. So how could I resolve this problem? Is their any logical problem.

6 REPLIES
VIP Purple

Re: VLAN problem in CISCO 2811 Router

Hello,

make sure you have both switch modules configured in stacked mode. Check this link for configuration details:

Configuring Stacking

http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_feature_guide09186a00802c6bb6.html#wp1049119

HTH,

GP

Purple

Re: VLAN problem in CISCO 2811 Router

Did you create the new vlans in the vlan database ? You would have to post the configs along with a show vlan commmand . There is not too much to it , create the layer 2 vlans in the vlan database then create the layer 3 SVI's for the layer 3 end of it .

Bronze

Re: VLAN problem in CISCO 2811 Router

Hi

Please send configuration and show vlan breif.

-Minu

New Member

Re: VLAN problem in CISCO 2811 Router

Rashed#SHow vlan-switch

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0/0/0

2 VLAN0002 active Fa0/0/1

3 VLAN0003 active Fa0/0/2

4 VLAN0004 active Fa0/0/3

5 VLAN0005 active Fa0/1/0

6 VLAN0006 active Fa0/1/1

7 VLAN0007 active Fa0/1/2

8 VLAN0008 active Fa0/1/3

1002 fddi-default active

1003 token-ring-default active

1004 fddinet-default active

1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1 enet 100001 1500 - - - - - 1002 1003

2 enet 100002 1500 - - - - - 0 0

3 enet 100003 1500 - - - - - 0 0

4 enet 100004 1500 - - - - - 0 0

5 enet 100005 1500 - - - - - 0 0

6 enet 100006 1500 - - - - - 0 0

7 enet 100007 1500 - - - - - 0 0

8 enet 100008 1500 - - - - - 0 0

1002 fddi 101002 1500 - - - - - 1 1003

1003 tr 101003 1500 1005 0 - - srb 1 1002

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1004 fdnet 101004 1500 - - 1 ibm - 0 0

1005 trnet 101005 1500 - - 1 ibm - 0 0

Rashed#

Rashed#show ip interface brief

Interface IP-Address OK? Method Status Prot

ocol

FastEthernet0/0 10.11.12.1 YES NVRAM up down

FastEthernet0/1 unassigned YES NVRAM up down

FastEthernet0/0/0 unassigned YES unset down down

FastEthernet0/0/1 unassigned YES unset down down

FastEthernet0/0/2 unassigned YES unset down down

FastEthernet0/0/3 unassigned YES unset down down

FastEthernet0/1/0 unassigned YES unset up up

FastEthernet0/1/1 unassigned YES unset down down

FastEthernet0/1/2 unassigned YES unset up down

FastEthernet0/1/3 unassigned YES unset up down

Vlan1 192.168.80.1 YES manual up down

Vlan2 192.168.80.9 YES manual up down

Vlan3 192.168.80.17 YES manual up down

Vlan4 192.168.80.25 YES manual up down

Vlan5 192.168.80.33 YES manual up up

Vlan6 192.168.80.41 YES manual up down

Vlan7 192.168.80.49 YES manual up down

Vlan8 192.168.80.57 YES manual up down

New Member

Re: VLAN problem in CISCO 2811 Router

Rashed# sh run

Building configuration...

Current configuration : 2170 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime localtime

service password-encryption

!

interface FastEthernet0/0

ip address 10.11.12.1 255.255.255.252

duplex full

speed auto

no mop enabled

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0/0

!

interface FastEthernet0/0/1

switchport access vlan 2

!

interface FastEthernet0/0/2

switchport access vlan 3

!

interface FastEthernet0/0/3

switchport access vlan 4

!

interface FastEthernet0/1/0

switchport access vlan 5

!

interface FastEthernet0/1/1

switchport access vlan 6

!

interface FastEthernet0/1/2

switchport access vlan 7

!

interface FastEthernet0/1/3

switchport access vlan 8

!

interface Vlan1

ip address 192.168.80.1 255.255.255.248

!

interface Vlan2

ip address 192.168.80.9 255.255.255.248

!

interface Vlan3

ip address 192.168.80.17 255.255.255.248

!

interface Vlan4

ip address 192.168.80.25 255.255.255.248

!

interface Vlan5

ip address 192.168.80.33 255.255.255.248

!

interface Vlan6

ip address 192.168.80.41 255.255.255.248

!

interface Vlan7

ip address 192.168.80.49 255.255.255.248

!

interface Vlan8

ip address 192.168.80.57 255.255.255.248

!

New Member

Re: VLAN problem in CISCO 2811 Router

Hi

Just to let you know I am in the same boat.

Cisco is looking at my config right know and when I get answers I will post for you.

3415
Views
0
Helpful
6
Replies
CreatePlease login to create content