Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

VLAN Problem with some apps

We are in the stages of implementing VLANS and notice some problems.

1. Unable to access ASA through ASDM and unable to access SonicWall device once moved workstation to a different VLAN

2. Some application take 20 to 30 seconds longer to open and once open there is a 2 to 3 second delay when moving around in the apps.

3. Unable to access a database through an application

4. I am able to ping servers, router, switches and the each of the VLAN interfaces.

4. Workstation is getting DHCP and correct default gateway for the VLAN that it is in.

If anyone could give some assistance it would be very helpful.

13 REPLIES

Re: VLAN Problem with some apps

What kind of a switch are you using?

HTH,

John

HTH, John *** Please rate all useful posts ***
Community Member

Re: VLAN Problem with some apps

3750E stack for core switch

3560 edge switch

Re: VLAN Problem with some apps

I'm with Victor on this one, we're going to need a few things to help:

Can you post:

Vlan SVI configurations

Quick diagram of your topology

Copy of the routing table

With so many problems, we're going to need to see the configs to be able to help. We don't know where to begin.

John

HTH, John *** Please rate all useful posts ***
Blue

Re: VLAN Problem with some apps

Hi:

It sounds like something has gone very wrong with your vlan rollout.

Im wondering how, with all these problems, your business is able to sustain itself.

I think the first thing that needs to be done is for you to give a detailed explanation of what has changed on yoru network. Go network module by network module, device by device, etc, so that we can create a picture.

The information you have given us doesn't really allow us to help you. What I can say is that you seem to have inter-vlan routing issues and probably some other sub-optimal routing, which may account for all your delays.

HTH

Victor

Community Member

Re: VLAN Problem with some apps

The 3750E stack has the servers connected and Layer3 VLAN, ip routing and static route to router. The uplink port to the edge switches are trunk and VLAN are allowed on trunk port. The below is a sample from core switch.

sample server

Native VLAN that server are on

interface Vlan16

ip address 192.x.x.92 255.55.240.0

sample client

Client VLAN with IP helper

interface Vlan10

ip address 192.168.10.1 255.255.255.0

ip helper-address 192.x.x.5

ip helper-address 192.x.x.6

!

interface Vlan11

ip address 192.168.11.1 255.255.255.0

ip helper-address 192.x.x.5

ip helper-address 192.x.x.6

!

int gi5/0/27

description Uplink to Mezz2

switchport trunk encapsulation dot1q

switchport trunk native vlan 16

switchport trunk allowed vlan 10,11,16

switchport mode trunk

macro description cisco-switch

auto qos voip trust

spanning-tree link-type point-to-point

spanning-tree guard root

Blue

Re: VLAN Problem with some apps

Why have you changed your native vlan to 16?

Why are you placing your servers in the native vlan?

Why dont we start with one problem at a time.

Give us a problem we can troubleshoot on here.

For example, host 192.168.10.100 is experiencing latency when communication with a server on the server vlan.

Youre not giving us anything to help you.

Community Member

Re: VLAN Problem with some apps

VLAN 16 was setup for server and switches is there a problem with this setup. Does the trunk link need to be setup as native to the edge switches.

When client with IP address 192.168.10.100 open Outlook there is a delay 2 to 3 and when Outlook open there is another 3 to 5 second before e-mail is shown. When try to access some database it will timeout other apps will take longer to open

Community Member

Re: VLAN Problem with some apps

i would seperate the servers and switches so they are on seperate vlans, make the switch vlan the native vlan. post the show run on the edge switch.

Community Member

Re: VLAN Problem with some apps

Here is a copy of the edge switch and core switch.

Blue

Re: VLAN Problem with some apps

Ok, thank you...I do see some thing I would change right off the bat...

Can you please send a nice diagram? Im trying to figure out what role each of these switches is playing and how they fit into the overall architecture...

Thanks

Community Member

Re: VLAN Problem with some apps

I will have to send a diagram tomorrow. The edge switches are where the client workstation are connected to.

Community Member

Re: VLAN Problem with some apps

Here is a network diagram

Community Member

Re: VLAN Problem with some apps

Here is a network diagram

150
Views
0
Helpful
13
Replies
CreatePlease to create content