Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VLAN question?

Hi,

I am trying to immplement VLAN on a FLAT network and need soem information please.

I can create the VLANS on my Cisco 4510 R swicth and varuios other CAT switches. I can also configure the router for that purpose bytr what I don't know and am confused of is this:

I have 5 departments

1,2,3,4,5

each have x many users associated wit them. if i assign one 48-port blade onmy 4510 swicth to each VLAN, how would I address the need for these vlans to talk to each other?

how would users from one VLAn can talk to otherusers on another VLAN?

Also, how all different VLANS can access the servers for authentications and network resources?

These are the questions that I really don't know as I have not done this and with this scale in the past.

any information that can help me understand thi swhole concept is really appreciated. i have seen am,ny Cisco white papers but they done't tell me these things but showing how to create the VLANs and work out the trunking only.

I know the commands and know how to configure switchesa and routers but not the stuff I discusssed above.

I may be lost, I don't know, but all i know is that I don't have some of the information I need.

Regards,

Masood

11 REPLIES
Silver

Re: VLAN question?

Hi, once you've created the VLANs you can use inter-vlan routing to communicate users with servers (separate with vlans) or users with users.

Take a look to the next url, it speaks clearly about your issue:

http://www.cisco.com/en/US/products/hw/switches/ps4324/products_configuration_guide_chapter09186a0080233fa9.html#wp1029634

Regards.

Pls, rate if helpful.

New Member

Re: VLAN question?

I had seen that document. this talks about the commands which I don't have any problem with, I guess I am lacking some conceptual informationon what after vlans are being created o the switches and th esubinterfaces are created on the router.

which link will be the very good candidate for trunking?

Or, whithin a single switch, how different vlans i.e. different blades on same swicth will talk to each other?

and Finally, how to create trunk for various swicth on various VLANs to talk to each other?

As I said i may lack some concept here!!

I have not seen any example that is close to real time scenarios, say fo rsmall enterprize, yet.

Thx,

Masood

Re: VLAN question?

Hi Masood,

i was understood by ur post that, you know how to create vlans on ur switches, but you wanted to know how each vlans will communicate each other with the help of the router isn't?ok fine, here letz start.

lemme start from the begining

switch#vlan database

switch(vlan)#vtp server

switch(vlan)#vrp domain CISCO

switch(vlan)#vlan 1 name ONE

switch(vlan)#vlan 2 name TWO

switch(vlan)#vlan 3 name THREE

switch(vlan)#vlan 4 name FOUR

switch(vlan)#vlan 5 name FIVE

switch(vlan)#exit

switch#conf t

switch(config)#interface vlan 1

switch(config-if)#ip address 192.168.1.1 255.255.255.0

switch(config-if)#interface vlan 2

switch(config-if)#ip address 192.168.2.1 255.255.255.0

switch(config-if)#interface vlan 3

switch(config-if)#ip address 192.168.3.1 255.255.255.0

switch(config-if)#interface vlan 4

switch(config-if)#ip address 192.168.4.1 255.255.255.0

switch(config-if)#interface vlan 5

switch(config-if)#ip address 192.168.5.1 255.255.255.0

switch(config-if)#interface gigabitethernet 1/1

switch(config-if)#switchport access vlan 1

switch(config-if)#switchport mode access

switch(config-if)#interface gigabitether 1/2

switch(config-if)#switchport access vlan 2

switch(config-if)#switchport mode access

switch(config-if)#interface gigabitether 1/3

switch(config-if)#switchport access vlan 3

switch(config-if)#switchport mode access

switch(config-if)#interface gigabitether 1/4

switch(config-if)#switchport access vlan 4

switch(config-if)#switchport mode access

switch(config-if)#interface gigabitether 1/5

switch(config-if)#switchport access vlan 5

switch(config-if)#switchport mode access

switch(config-if)#interface gigabitethernet 1/6

switch(config-if)#description ***Connected to 2950***

switch(config-if)#switchport trunk encapsulation dot1q

switch(config-if)#switchport mode trunk

switch(config-if)#exit

switch(config)#ip routing

switch(config)#exit

switch#

on client switch

2950#vlan database

2950(vlan)#vtp client

2950(vlan)#vtp domain CISCO

2950(vlan)exit

2950#config t

2950(config)#interface vlan 5

2950(config-if)#ip address 192.168.5.2 255.255.255.0

2950(config-if)#exit

2950(config)#interface gigabitethernet 0/1

2950(config-if)#dewcription ***Connected to 4510***

2950(config-if)#switchport mode trunk

2950(config-if)#Z

2950#

if u wanted any vlan pc to be connected on this 2950 switch, make that port as the respective vlan number

eg. a pc having ip address 192.168.1.1 which is connected on fastherethernet 0/1, configure that port as switchport access vlan 1

now connect the appropriate vlan PC's on the respected gigabit or fastherethernet ports & specific the respective vlan IP address as a gateway.

hope this make you clear

rate this post if satisfied, if not please lemme know.

New Member

Re: VLAN question?

In fact this help and helps alot.

if possible, would you please point to the role of the router that I will be having to separate my two floors and how should that be addressed as far as the sub-interfaces are concern. each sub-int for each corresponding VLAN, correct?

should I decide to give one swicth, say, a 3512 or 3550 swicth and two 4510 R CAT L2/L3 swich to each VLAN and have users connect to that swicth, then the ocnnections from one swicth to another must become a trunk? and from one of the swicthes wto the router become a trunk?

I am trying to understand this and start a LAb scenario before I do it on a production network.

Regards,

Masood

Re: VLAN question?

Hi Masood,

yeah in the router you create the vlans by the following in the router

interface fasthether 0/0

no ip address

interface fastethernet 0/0.1

description ***First Floor***

encapsulation dot1q 1

ip address 192.168.1.1 255.255.255.0

interface fastethernet 0/0.2

description ***Second Floor***

encapsulation dot1q 2

ip address 192.168.2.1 255.255.255.0

Note: while configuring the vlan in the router, make sure that you have not given any ip address to the fasthernet 0/0 as mentioned above. only the sub-interface should have the ip addresses.

then in the 2950 switch

interface gigabitethernet 0/1

description ***Connected to Router***

switchport mode trunk

interface fastethernet 0/1

switchport access vlan 1

switchport mode access

interface fasthernet 0/2

switchport access vlan 2

switchport mode access

now connect the pc on fastethernet 0/1,which has the 192.168.1.0/24 ip address & 192.168.2.0/24 in fastethernet 0/2 interface.

in your case 3550 itself a layer 3 switch, so you can configure as i mentioned in my earlier post. if you have a layer 2 switch & a router, you can configure with the configuration mentioned above in this post.

hope this helps.

rate this post if satisfied.

New Member

Re: VLAN question?

Thanks very much for your detailed and to the point response. I will rate it sure.

one question though? you said that i can connect PC to fastethernet 0/1,which has the 192.168.1.0/24 ip address & 192.168.2.0/24 in fastethernet 0/2 interface.

I notice that you have mentioned /24 block, how does this work? one whole block will be connected to one fastether0/0 or 0/1 or 0/2 interface?

I know that I need to assign ports to each VLAN and those are the ports that my uers/servers will be connecting to.

correct?

Thx,

Masood

Re: VLAN question?

Hi Masood,

192.168.1.0/24 in the sense that you can connect a pc which has got the ip address in this subnet. eg. 192.168.1.1 till 192.168.1.254. like that 192.168.2.0/24 between 192.168.2.1 & 192.168.2.254.

YES u need to assign each ports to a different vlan & the PC should be on the respective subnet.

eg. interface fastethernet 0/1

switchport access vlan 1

switchport mode access

it means any pc connected on this particular interface should have the ip address assigned between 192.168.1.1 & 192.168.1.254. if you try assign 192.168.2.5 on this interface it doesn't work, in that case you need to make this interface as "switchport access vlan 2"

i hope now your clear

New Member

Re: VLAN question?

Hi again and really thank you for your indepth responses. I have lyed down my initial thoughts on how we want to proceede with our VLAN project but I have few questions and i hop ethat after this I will be on my way.

here what i think:

say: Switch A at floor 1, 5 blades each 48 gigi ports. I create, VLAN 2, VLAN 3, VLAN 4 AND VLAN 5 ON THIS SWITCH AND do the following:

vlan 2 gi2/1-48 (port one being uplink for vlan 2 with ip address and mode being trunk)

vlan 3 gi3/1-48 == all mode being switch port access vlan 2 and for below lines vlan 3, vlan 4 and vlan 5.

vlan 4 gi 3/1-48

vlan 5 gi 4/1-48

say I give the following IP addresses out of my only two private subnets (i use one of them for assigning IPs to the uplink ports i.e. gi2/1)

vlan 2 gi 2/1 10.1.1.2

vlan 3 gi 3/1 10.1.1.3

vlan 4 gi4/1 10.1.1.4

vlan 5 gi 5/1 10.1.1.5

now, I havethese questions if what was explained above were correct:

what would be th erelation of say, switch B at floor 2 with the swicth A at floor 1 above?

do I need to have the same numbers of vlans with the same name or numbers and Ip adresees on this switch as well? I don't understand this part?

Also, if I have 20 users on VLAN 2 on blade 2 on swicth A but they sit at different locations, how this works? soem may need to be connected to a diffferent switch and not switch A where most of the users from this same vlan are connected to?

these are the points that I do not see or understand partly because I have not reallt doen this VLAN scenario in real time yet. I am sure once I do one I get the feeling for it.

Also, I don't know where our servers must sit? on a different VLAn altogether? how the diffferent vlans will access these servers resources?

Please forgive me for all of these questions but having inherited a big flat network causes me to panic when I devide to immplement vlans on it.

Regards,

Masood

New Member

Re: VLAN question?

Hi,

why you have adressed vlan 5 onthe client switch i.e. swicth 2950?

2950(config)#interface vlan 5

2950(config-if)#ip address 192.168.5.2 255.255.255.0

2950(config-if)#exit

shouldn't this be done for all of the VLANs ? or the VTP is taking care of that?

so with L3 siwtch I don't need routers between my various floor? correct?

Thx,

Masood

New Member

Re: VLAN question?

Masood

You need to route between the Vlans. Does you switch have L3 software?

If it does not you need a router, search for "router on a stick"

If it does have L3 then you need SVI's for each vlan and "ip routing" in the configs. If all your vlans are on the one switch that is all you need.

New Member

Re: VLAN question?

Thanks man. I have both L3 and L2 switch all over my network. i just don't unbderstand the relation between various vlans created on a switch a with other valns on say switch B?

do all vlans need to be repeated on a single switch or same thing being repeated on all other switches on the network?

Anand, has really responded to my question very meticliously and has resolved many question that I had in my mind.

I have posted another question that can help resolve my concern and questions to make me ready start my project.

Regards,

Masood

347
Views
12
Helpful
11
Replies
CreatePlease login to create content