Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

VLAN question

Hi all,

I am really puzzled by this problem. I have 2 switches, the first one is a C3500/24 and the second one is a C3560/48. I trunked ports 24 of the C3500 switch with port 48 of the C3560 switch. I created 4 VLANs on the C3560 switch, domain name, and gave it a server role. I created the same domain name on the C3500 switch and gave it a client role. Here is additional info:

- SW1 VLAN1: 10.10.3.2

VLAN2: Eng, VLAN3: IT, VLAN4: HR, VLAN5: Finance

VTP Domain: ABC

VTP Role: Server

Default gateway: 10.10.3.1

- SW2 VLAN1: 10.10.3.3

VTP Domain: ABC

VTP Role: Server

Default gateway: 10.10.3.1

The problem is that the second switch (the client) isn't updating the VTP database with the VLAN information.

Can someone please help?

Thanks in advance,

sK

5 REPLIES
Hall of Fame Super Bronze

Re: VLAN question

Post the output from these commands

show vtp status

and

show int trunk

New Member

Re: VLAN question

SW1#show vtp status

VTP Version : 2

Configuration Revision : 2

Maximum VLANs supported locally : 1005

Number of existing VLANs : 9

VTP Operating Mode : Server

VTP Domain Name : ABC

VTP Pruning Mode : Disabled

VTP V2 Mode : Disabled

VTP Traps Generation : Disabled

MD5 digest : 0x8A 0x65 0xC9 0x0F 0xF7 0x27 0xC3 0xDA

Configuration last modified by 10.10.3.2 at 3-1-93 00:31:10

Local updater ID is 10.10.3.2 on interface Vl1 (lowest numbered VLAN interface found)

SW1#show int trunk

Port Mode Encapsulation Status Native vlan

Fa0/48 on 802.1q trunking 1

Port Vlans allowed on trunk

Fa0/48 1-4094

Port Vlans allowed and active in management domain

Fa0/48 1,20,30,40,50

Port Vlans in spanning tree forwarding state and not pruned

Fa0/48 1,20,30,40,50

---------------------------------------------------------------------------

SW2#sho vtp status

VTP Version : 2

Configuration Revision : 0

Maximum VLANs supported locally : 254

Number of existing VLANs : 5

VTP Operating Mode : Client

VTP Domain Name : ABC

VTP Pruning Mode : Disabled

VTP V2 Mode : Disabled

VTP Traps Generation : Disabled

MD5 digest : 0xF4 0xBA 0xAB 0x48 0x66 0xDA 0xDA 0xB2

Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

SW2#show interfaces fastEthernet 0/24 switchport

Name: Fa0/24

Switchport: Enabled

Administrative mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: Disabled

Access Mode VLAN: 0 ((Inactive))

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: ALL

Trunking VLANs Active: 1

Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0

Override vlan tag priority: FALSE

Voice VLAN: none

Appliance trust: none

Hall of Fame Super Bronze

Re: VLAN question

I've seen that happening before when you create all Vlans in the VTP server switch and then change to the server/client model.

Create another Vlan in the VTP server (a Vlan that you will delete later) to kickstart the process.

Your configuration looks fine, BTW.

Edit: Verify there isn't a password set. show vtp password on both switches will indicate if there is any.

New Member

Re: VLAN question

Another question .... on the C3560, I am unable to disable the trunking on a port. I tried all relevent commands such as: no switchport mode trunk, no switchport trunk encap, and no switchport dynamic but the port is set to Auto mode and trunking...

How do you disable trunking on a port?

Hall of Fame Super Bronze

Re: VLAN question

switchport mode access

151
Views
0
Helpful
5
Replies
CreatePlease to create content