Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

vlan question

Hi,

I config two CAT 3750 switches, one is on 32/F; other is on 8/F. there are two in-house fibers to be connected to each other. router is on 32/F.

I would like 192.168.16.0, 192.168.17.0 traffic via fiber A

172.16.16.0, 172.16.17.0 traffic via fiber B

It seems that my config is not working.

1. How to config the trunks to run different traffic?

2. any problem if I do not config VLAN1 on switch?

rgds

32/F segment

192.168.16.0/24

192.168.17.0/24

192.168.18.0/24

192.168.19.0/24

172.16.16.0/24

172.16.17.0/24

172.16.18.0/24

10/F segment

192.168.16.0/24

192.168.17.0/24

192.168.24.0/24

192.168.25.0/24

172.16.16.0/24

172.16.17.0/24

! R1

!

interface GigabitEthernet0/0

no ip address

!

interface GigabitEthernet0/0.1

encapsulation dot1Q 1 native

ip address 172.16.1.1 255.255.255.252

ip nat inside

!

interface GigabitEthernet0/0.2

encapsulation dot1Q 2

ip address 192.168.16.1 255.255.255.0

ip nat inside

interface GigabitEthernet0/0.3

encapsulation dot1Q 3

ip address 192.168.17.1 255.255.255.0

ip nat inside

interface GigabitEthernet0/0.12

encapsulation dot1Q 12

ip address 172.16.16.1 255.255.255.0

ip nat inside

interface GigabitEthernet0/0.13

encapsulation dot1Q 13

ip address 172.16.17.1 255.255.255.0

ip nat inside

!

Interface FastEthernet1

ip address 209.x.x.x 255.255.255.252

ip nat outside

!

ip nat pool office 209.x.x.x 209.x.x.x netmask 255.255.255.252

!

ip nat inside source 10 interface FastEthernet1 overload

!

access-list 10 permit 172.16.0.0 0.0.0.255

access-list 10 permit 192.168.16.0 0.0.0.255

access-list 10 permit 192.168.17.0 0.0.0.255

access-list 10 permit 172.16.16.0 0.0.0.255

access-list 10 permit 172.16.17.0 0.0.0.255

!

! switch

interface gigabitethernet2/0/1

description Trunk to router A GE 0/0, fiber A

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface gigabitethernet2/0/2

description Trunk to router A GE 0/1, fiber B

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/1

switchport access vlan 2

!

interface FastEthernet0/2

switchport access vlan 3

!

interface FastEthernet0/8

switchport access vlan 12

!

interface FastEthernet0/9

switchport access vlan 13

!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: vlan question

Hi Anita,

You should move the 172.16.x.x subnets (vlans 12 and 13) from GE0/0 to GE0/1.

This way the traffic of 172.16.x.x subnets will go on fiber B.

interface GigabitEthernet0/1

no ip address

!

interface GigabitEthernet0/1.12

encapsulation dot1Q 12

ip address 172.16.16.1 255.255.255.0

ip nat inside

!

interface GigabitEthernet0/1.13

encapsulation dot1Q 13

ip address 172.16.17.1 255.255.255.0

ip nat inside

Try this configuration.

If it doesn't work, please send me more info about your present configuration: full running-configs, drawing about physical connections, etc.

Cheers:

Istvan

3 REPLIES

Re: vlan question

Hi Anita,

It seems to me that GE 2/0/2 of your switch is connected to GE 0/1, fiber B, on router R1 but I don't see any layer 3 config on GE 0/1.

Cheers:

Istvan

New Member

Re: vlan question

Hi,

how to config it? I do not have any idea? please advise

rdgs

Re: vlan question

Hi Anita,

You should move the 172.16.x.x subnets (vlans 12 and 13) from GE0/0 to GE0/1.

This way the traffic of 172.16.x.x subnets will go on fiber B.

interface GigabitEthernet0/1

no ip address

!

interface GigabitEthernet0/1.12

encapsulation dot1Q 12

ip address 172.16.16.1 255.255.255.0

ip nat inside

!

interface GigabitEthernet0/1.13

encapsulation dot1Q 13

ip address 172.16.17.1 255.255.255.0

ip nat inside

Try this configuration.

If it doesn't work, please send me more info about your present configuration: full running-configs, drawing about physical connections, etc.

Cheers:

Istvan

126
Views
0
Helpful
3
Replies
CreatePlease to create content