Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

VLAN question

Hi,

I setup two ethernet switches (CAT 3750) on 8/F and 32/F. detail please check the attached file.

there are two fibers to be connected to each other. It has two VLANs on 8/F and 32/F. 192.168.12.0/24 and 192.168.24.0/24. how do I config the CAT to force the 192.168.12.0/24 traffic to fiber A and 192.168.24.0/24 go fiber B?

any suggestion?

rdgs

8 REPLIES
New Member

Re: VLAN question

int fa 1/0/8

switchport trunk allowed vlan

int fa 1/0/32

switchport trunk allowed vlan

New Member

Re: VLAN question

Hi,

do I need to enable the spanning tree? if so, how to config it?

rdgs

Super Bronze

Re: VLAN question

I'm unfamilar with specifics for the 3750, but generally all you should need to do is drop one fiber into a port based VLAN for the one VLAN and the other fiber port into a port based VLAN for the other VLAN. I.e. don't trunk VLAN on either.

If you had more than two VLANs but still wanted to have one VLAN on one fiber and the other on the other fiber, you might trunk with VLAN filters. Need to be careful with what your implementation of spanning tree does.

[edit]

PS:

You might also consider channeling the two ports and passing both VLANs across them in a trunk. Doing so gives you redundancy, loss of one link won't cause loss of VLAN. Also, depending on traffic, both VLANs can share 2x bandwidth.

Hall of Fame Super Bronze

Re: VLAN question

Replied on your first post

________________

If you are only going to deal with 2 Vlans, let's call 192.168.12.0/24 Vlan12 and 192.168.24.0/24 Vlan24.

Then on the switches, where you want traffic for Vlan12 to go just issue the following on the switchports

interface fx/x

switchport mode access

switchport access vlan 12

On the switchport where you want Vlan24 just issue:

interface fx/x

switchport mode access

switchport access vlan 24

If you wanted to trunk the ports, issue the following:

interface fx/x

switch port trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan 12

For Vlan12 and for Vlan24

interface fx/x

switch port trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan 24

One thing to keep in mind, I recommend going with the trunk if you plan on carrying more than one Vlan over that link. If you aren't then go with the access-vlan method.

HTH,

__

Edison.

New Member

Re: VLAN question

Hi edison,

the config is

interface f1/0/1

description VLAN 12

switchport mode access

switchport access vlan 12

interface f1/0/2

description VLAN 24

switchport mode access

switchport access vlan 24

interface f1/0/22

description 75xx router

switch port trunk encapsulation dot1q

switchport mode trunk

interface f1/0/23

descrip fiber A, VLAN 12 traffic only

switch port trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan 12

interface f1/0/24

descrip fiber B, VLAN 24 traffic only

switch port trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan 24

any missing? how to enable the spanning tree?

rdgs

Super Bronze

Re: VLAN question

Believe you're going to want both ends of the link configured alike, i.e. both access port mode or both trunk mode.

New Member

Re: VLAN question

Hi,

yes. I sure that the spanning must be config otherwise it may has major issue. I do not have any idea to enable it from CAT 3750. any idea or suggestion?

rdgs

Super Bronze

Re: VLAN question

Config guide for your software should provide all the details, e.g.

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_25_see/configuration/guide/swstp.html#wp1096308

You might also consider using smartport macros, e.g.

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_25_see/configuration/guide/swmacro.html

There's also the configuration assistants, but unsure what all they support.

PS:

I would recommend you start out with the IEEE 802.1w variant.

159
Views
10
Helpful
8
Replies
CreatePlease to create content