Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

VLAN routing and non-ip packet

Dear Expert,

Attached please find the proposal network design and config file for the server migration to new catalyst switch 4506. It would achieve following goal. Grateful if you see any issue on it.

1. the ip and ipx routing are enabled on router 2811 for the novell server. it is sitting on the user segment.

2. all inter-vlan routing is on 4506 catalyst switch except user segment.

3. the default gateway of user segment is pointed to 2811

4. the traffic flow will be routed between 2811 and 4506 for user segment and other VLAN (except novell server)

Question:

1. do I need to create vlan 10 on 4506? why do I need to create vlan 10?

2. do I need to create "native vlan 10"?

! hkdc2811-01

!

interface FastEthernet0/0

description connected to 8/F hkdc4506-01 core switch 01, port 3/1

ip address 192.168.10.1 255.255.255.0

ipx network 56024001 encapsulation SAP

ipx network 56025001 encapsulation NOVELL-ETHER secondary

!

router ospf 10

network 192.168.10.0 0.0.0.255 area 0

network 192.168.100.0 0.0.0.255 area 0

network 192.168.101.0 0.0.0.255 area 0

network 192.168.10.20 0.0.0.255 area 0

!

! hk4506-01

interface GigabitEthernet3/1

description connected to 2811-01 FE 0/0

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet3/2

description connected to 3COM-01 user switch

switchport access vlan 10

switchport mode access

!

interface GigabitEthernet3/3

description connected to 3COM-02 user switch

switchport access vlan 10

switchport mode access

!

interface vlan 10

description connected to vlan 10

ip address 192.168.10.5 255.255.255.0

!

interface vlan 100

description connected to vlan 100

ip address 192.168.100.1 255.255.255.0

!

interface vlan 101

description connected to vlan 101

ip address 192.168.101.1 255.255.255.0

!

interface vlan 102

description connected to vlan 102

ip address 192.168.102.1 255.255.255.0

!

router ospf 10

network 192.168.10.0 0.0.0.255 area 0

network 192.168.100.0 0.0.0.255 area 0

network 192.168.101.0 0.0.0.255 area 0

network 192.168.10.20 0.0.0.255 area 0

!

rdgs

Anita

2 ACCEPTED SOLUTIONS

Accepted Solutions
VIP Super Bronze

VLAN routing and non-ip packet

Hi,

All new version of Novel run IP, therefore you do not need IPX anymore.  Yes, you need to creat vlan 10 (not native) on the 4500 for the Novel workstation if you are planning to connect it to the 4500. If you are connecting it directly to the router, then it is just a routed port.  The port that is connecting to the router could be a routed port, but vlan works too.

HTH

Re: VLAN routing and non-ip packet

hi anita,

The  2811 will be on the 192.168.10.0/24 subnet. So you dont need any static routes for reachability.  For all other networks, ospf will do the job if you are advertising the networks on the 2811 via ospf.

HTH

Kishore

3 REPLIES
VIP Super Bronze

VLAN routing and non-ip packet

Hi,

All new version of Novel run IP, therefore you do not need IPX anymore.  Yes, you need to creat vlan 10 (not native) on the 4500 for the Novel workstation if you are planning to connect it to the 4500. If you are connecting it directly to the router, then it is just a routed port.  The port that is connecting to the router could be a routed port, but vlan works too.

HTH

New Member

VLAN routing and non-ip packet

Dear Reza,

Thanks for your posting. I am going to to amend the config as below on 4506-01 only:

! 4506-01

interface vlan 10

description connected to vlan 10

ip address 192.168.10.5 255.255.255.0

!

there is no routed port on 4506 for user segment (192.168.10.0/24). The user can access other server segments (vlan 100 - 102) via layer 3 inter-vlan routing in 4506 catalyst switch. the OSPF routes (server segments) would be learned from OSPF nei (4506). It does not need to add static route on 2811. Is it correct?

rdgs

Anita

Re: VLAN routing and non-ip packet

hi anita,

The  2811 will be on the 192.168.10.0/24 subnet. So you dont need any static routes for reachability.  For all other networks, ospf will do the job if you are advertising the networks on the 2811 via ospf.

HTH

Kishore

610
Views
0
Helpful
3
Replies