Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Vlan routing beetwen 3 routers in two locations

Hello,

I have 3 routers Cisco 2901 in two locations. Router R_1 is in location A, and R_2 and R_3 are in location B. Routers R_1 and R_2 are connected by VPN site to site and use routing protocol EIGRP. Router R_3 is the router my network priovider. On the router R_1 is configured two VLANs (100 - 10.22.15.0/24, 101 - 10.22.16.0/24) as rotuer on the stick to my network. On the router R_2 i have two interfaces L3 and 4 interfaces L2. One interface gig 0/1 use VPN to R_1, and second interface gig0/0 is connected to R_3 - network provider. On the R_2 i have only one VLAN 102 - 10.22.20.0/24. My netwrok provider connect my networks to my global VPN. On the R_3 is configured default gateways for my 3 vlans. How can i set my router R_1 (VLAN: 100,101) to default gateway on R_3? How can configure 2 vlans on R_1 to route by R_3? I woluld like configure R_1 to connection to my global VPN from two Vlans by R_3. Can you help me? Please

R_3:

interface GigabitEthernet0/1

description To customer LAN

ip address XXXXX

duplex auto

speed auto

no cdp enable

!

interface GigabitEthernet0/1.100

encapsulation dot1Q 100

ip address 10.22.15.253 255.255.255.0 --- default gateway

no cdp enable

!

interface GigabitEthernet0/1.102

encapsulation dot1Q 102

ip address 10.22.20.253 255.255.255.0  --- default gateway

no cdp enable

!

R_2:

interface GigabitEthernet0/0

description CONNECTION_TO_NETWORK PROVIDER

no ip address

duplex auto

speed 1000

!

interface GigabitEthernet0/0.102

encapsulation dot1Q 102

!

interface Vlan102

ip address 10.22.20.252 255.255.255.0

!

router eigrp 200

network 10.10.2.0 0.0.0.255

network 10.22.20.0 0.0.0.255

!

R_3:

interface GigabitEthernet0/0

description My switch

ip address 192.168.11.1 255.255.255.0

logging event subif-link-status

duplex auto

speed auto

!

interface GigabitEthernet0/0.100

encapsulation dot1Q 100

interface Vlan100

ip address 10.22.15.252 255.255.255.0

!

router eigrp 200

network 10.10.2.0 0.0.0.255

network 10.22.15.0 0.0.0.255

!

The configuration is correct?

Thank you

Everyone's tags (2)
175
Views
0
Helpful
0
Replies
CreatePlease to create content