Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Vlan Routing on a Switch

Hi

I have a problem and i don't know how i can solve that. Hope someone of you can give me some input.

In a Network with 300 clients, i want to make different subnets with one dhcp server. in theory just activate IP Helper-Address an it works. But the problem is, i have only a switch and not a router. I would set for every subnet a different vlan, so i can map the vlan on the interface (can't set a ip for ip helper on the physical interface because its a switch..) and activate ip helper address on the vlan interface.

But now i have a problem with the routing. The coreswitch have now 2 vlans, vlan 1 (10.12.100.1) and vlan 2 (10.12.40.1). the default route is set to 10.12.100.10 (Cable-switch from the provider). The client (10.12.40.2) can ping every ip in the 100 subnet.. i can ping the server 10.12.100.101, but i can not ping the cablerouter 10.12.100.10.. i can ping every device, just not the cablerouter...

here the config from the core-switch:

****************************************

Current configuration : 4328 bytes

!

! Last configuration change at 10:55:56 CET Wed Oct 14 2009

! NVRAM config last updated at 16:01:19 CET Tue Oct 13 2009

!

version 12.2

no service pad

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

service sequence-numbers

!

hostname sw_s125

!

enable secret

!

no aaa new-model

clock timezone CET 1

clock summer-time CET recurring last Sun Mar 2:00 last Sun Oct 3:00

switch 1 provision ws-c3750g-12s

switch 2 provision ws-c3750g-12s

system mtu routing 1500

ip subnet-zero

ip routing

no ip domain-lookup

ip domain-name dnata.intra

!

cluster enable dnata 0

cluster member 1 mac-address 001e.7a91.d980

cluster member 2 mac-address 001e.f659.1e80

cluster member 3 mac-address 001e.f629.3180

cluster member 4 mac-address 001e.79c3.cb00

cluster member 5 mac-address 001d.e676.5b80

cluster member 6 mac-address 001d.e675.fe00

cluster member 7 mac-address 001d.e698.f780

cluster member 8 mac-address 001d.e699.0d80

cluster member 9 mac-address 001d.e698.c380

cluster member 10 mac-address 001d.e699.6700

cluster member 11 mac-address 001d.e698.ee00

cluster member 12 mac-address 001d.e699.0180

cluster member 13 mac-address 001d.e675.ee00

cluster member 14 mac-address 001e.49eb.0a80

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface GigabitEthernet1/0/1

!

interface GigabitEthernet1/0/2

!

interface GigabitEthernet1/0/3

!

interface GigabitEthernet1/0/4

!

interface GigabitEthernet1/0/5

!

interface GigabitEthernet1/0/11

description to sw_s33

!

interface GigabitEthernet1/0/12

description to sw_gh

!

interface GigabitEthernet2/0/1

description to sw_lost

!

interface GigabitEthernet2/0/2

description to sw_transit

!

interface GigabitEthernet2/0/3

description to sw_assist

!

interface GigabitEthernet2/0/4

description to sw_4thfloor

!

interface GigabitEthernet2/0/5

!

interface GigabitEthernet2/0/6

!

interface GigabitEthernet2/0/7

!

interface GigabitEthernet2/0/8

!

interface GigabitEthernet2/0/9

!

interface GigabitEthernet2/0/10

!

interface GigabitEthernet2/0/11

!

interface GigabitEthernet2/0/12

switchport access vlan 2

!

interface Vlan1

ip address 10.12.100.1 255.255.255.0

!

interface Vlan2

ip address 10.12.40.1 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.12.100.10

ip http server

!

!

**some snmp settings**

!

control-plane

!

!

line con 0

line vty 0 4

password

login

length 0

line vty 5 15

password

login

!

end

*****************************************

The switch was first configurated from a external company who has delivered us the switches..

have someone an idea what the problem is? Thx for your help.

regards Michael

8 REPLIES
Cisco Employee

Re: Vlan Routing on a Switch

Check your route on your cable router to make sure it has a return route to the 10.12.40.0/255.255.255.0 network.

If it is IOS, you can use

ip route 10.12.40.0 255.255.255.0 10.12.100.1

HTH,

jerry

New Member

Re: Vlan Routing on a Switch

the problem is, i haven't access to the cablerouter, because its the router from the internetprovider. :(

But i have testet the subnet 40, if i set the ip address in the default vlan 1 (the port and the client) i can ping the router from the client with the ip address 10.12.40.2. so it must be a problem on the core switch with routing from vlan 1 and 2, right? but then its strange that the ping to all other clients works...

or is it wrong?

Cisco Employee

Re: Vlan Routing on a Switch

Please explain a little further. I don't understand what you have tested, do you mean you've put the switchport into VLAN1 but the client/PC's IP is still 10.12.40.x, and ping works fine?

ICMP echo is coming from the client to the cable router, and the cable router will send echo reply (return route). If the route on the cable router is missing, I don't see how the traffic will return.

Regards,

jerrry

New Member

Re: Vlan Routing on a Switch

thanks for your answers jerry

I have put the port on the switch and the computer in the vlan 1, but with the ip from the 40 subnet.

on the vlan 1 interface on the switch with the ip 10.12.100.1 i have added the ip 10.12.40.1 as secondary. then the ping works from the computer with the ip 10.12.40.2... but its on vlan 1, not in 2...

Cisco Employee

Re: Vlan Routing on a Switch

Okay, I don't see any issue on the switch.

Purple

Re: Vlan Routing on a Switch

The ISP probably hAs ICMP and echo reply blocked that's why it won't answer to a ping . Most smart ISP's do that as a precaution.

New Member

Re: Vlan Routing on a Switch

thanks for the answers

but when the client is in the vlan 1 with the same ip, it can ping the router..

my problem is not that the ping not works, the connection to the other location over the isp don't works too, but only from the clients in the vlan2.

New Member

Re: Vlan Routing on a Switch

A bit confused. But are you saying that you cannot ping the cable router (.10) from any device on vlan1 or vlan2? What does your interface look like that is connected to the cable router?

i.e. show interface gig1/0

replace gig1/0 with the physical interface connected to your cable router. Just to make sure you don't have any layer 2 issues.

160
Views
0
Helpful
8
Replies