Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Vlan sub-interface puzzler

Having an issue getting a vlan to work. I have a Cisco 2801 router configured with sub interfaces and have some questions. I have a 10.1.1.0 network which is Vlan 1 and a 10.1.2.0 network (both /24)Vlan 2 The switch is configured as a trunk on the uplink and on one port with Vlan 1 as native and Vlan 2 are on both ports. Vlan 1 works fine from the trunked port but Vlan 2 doesn't. Meening I can use a 10.1.1.0 address and ping but when I use a 10.1.2.0 address I cant ping the gateway on that network. Here is my router config:

interface FastEthernet0/1

description INSIDE INTERFACE - VLAN 1

ip address 10.1.1.1 255.255.255.0

ip access-group 110 in

ip nbar protocol-discovery

ip flow ingress

ip flow egress

ip nat inside

ip virtual-reassembly

ip policy route-map NO-NAT-STATIC-IP-FOR-VPN-CLIENTS

load-interval 30

speed 100

full-duplex

no cdp enable

!

interface FastEthernet0/1.2

description INSIDE INTERFACE Voice - VLAN 2

encapsulation dot1Q 2

ip address 10.1.2.1 255.255.255.0

ip helper-address 10.1.1.14

no cdp enable

Here is a sho ip int brie

Vlan1 unassigned YES NVRAM up down

Vlan2 unassigned YES unset up down

Vlan3 192.168.1.1 YES NVRAM up up

3 REPLIES

Re: Vlan sub-interface puzzler

Hi

As a side not, the use of VLAN 1 is not recommended for data, see post below

hxxp://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=LAN%2C%20Switching%20and%20Routing&topicID=.ee71a04&fromOutline=&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.2cd256f3

Try adding vlan 1 to a sub interface as well, just add native to the end of the encapsulation command.

interface FastEthernet0/1

speed 100

full-duplex

no cdp enable

FastEthernet0/1.1

description INSIDE INTERFACE - VLAN 1

encapsulation dot1Q 1 native

ip address 10.1.1.1 255.255.255.0

ip access-group 110 in

ip nbar protocol-discovery

ip flow ingress

ip flow egress

ip nat inside

ip virtual-reassembly

ip policy route-map NO-NAT-STATIC-IP-FOR-VPN-CLIENTS

load-interval 30

interface FastEthernet0/1.2

description INSIDE INTERFACE Voice - VLAN 2

encapsulation dot1Q 2

ip address 10.1.2.1 255.255.255.0

ip helper-address 10.1.1.14

no cdp enable

New Member

Re: Vlan sub-interface puzzler

I'll give this a try.

Silver

Re: Vlan sub-interface puzzler

In my opinion ur setup is not working because you have given IP to etherent port 0/1 and then you are assigning on more to its subinterface.

When you use subinterface you dont give ip to that port. You just define subinterface.

583
Views
4
Helpful
3
Replies