Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Vlan Tagging and Config cant work!

I have a CISCO Router 1921 and i couldnt connect to the internet

The ISP have a tagged Vlan 10 on the internet before i could connect to it.

I have the below running config is there anything wrong with it?

         

additonal Info with a simeple routerr

Internet Connection:
IPv6 6rd:Disabled
IP Address:116.15.152.177
Subnet Mask:
Default Gateway:116.15.153.254
Primary DNS Server:165.21.83.88
Secondary DNS Server:165.21.100.88
Address:
   Subnet Mask:
   Host Name:
   Domain Name:

        Enable LAN side firewall
        Disable DHCP Server
        Enable DHCP Server
                 Start IP Address:
                 End IP Address:
                 Subnet Mask:
                 Leased Time (hour):
Running Config

no ip dhcp conflict logging

ip dhcp excluded-address 10.168.1.40 10.168.1.70

!

ip dhcp pool iptpool

network 10.168.1.0 255.255.255.0

default-router 10.168.1.254

dns-server 165.21.83.88 165.21.100.88

interface GigabitEthernet0/1
description LAN

ip address 10.168.2.1 255.255.255.0
ip address vlan 10
duplex auto

speed auto

no mop enabled


exit
!

interface GigabitEthernet0/0


description WAN

ip address dhcp

duplex auto

speed auto

interface vlan 10
name "SingtelFibre"
routing
ip address 10.168.1.1 255.255.254.0

ip route 0.0.0.0 0.0.0.0 202.166.71.254

!

ip access-list standard USC

permit 0.0.0.0

!

3 REPLIES
Bronze

Re: Vlan Tagging and Config cant work!

Your wan and lan adresses may need to be reversed?
I Guess the lan is where you want the router to distribute the dhcp scope.
So the lan interface adress should match the dhcp subiet.

Sent from Cisco Technical Support iPad App

Re: Vlan Tagging and Config cant work!

I'm not sure, but you are assigned a default gateway from the ISP, yet you have a default route to a different next hop in your config. Remove the default route "ip route 0.0.0.0 0.0.0.0 202.166.71.254" and see if that resolves the issue.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
Bronze

Re: Vlan Tagging and Config cant work!

at first change 

     interface GigabitEthernet0/0

     description WAN

     ip address dhcp

     interface vlan 10
     name "SingtelFibre"
     ip address 10.168.1.1 255.255.254.0

to:

     interface GigabitEthernet0/0

     description physycal port

     no ip address

     interface GigabitEthernet0/0.10

     description WAN

     encapsulation dot1Q 10

     ip address dhcp

          ! or ip-address given by provider

This way tyou create, for the physical interface Gi0/0, a subinterface Gi0/0.10  that is vlan10 tagged

The interfacename Gi0/0.10 has only by name a relation with vlan10, You could use any number like Gi0/0.1 if you prefer.

then try to ping provider gatweway.

If that works, then we'll go to the next step

173
Views
4
Helpful
3
Replies
CreatePlease to create content