Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

VLAN Translation with MPLS xconnect

Hello,

Are vlan translations supported using 3750ME and 7606?

I'm trying to turn up an SVI xconnect between two PE boxes (3750ME and 7606) over our MPLS network, but when I use different interface VLANs with matching VCIDs, the VLAN on the client switch that's attached to the 7606 PE will go into *PVID_Inc. I've built this before between a pair of 7606 PEs but this is the first attempt using a 3750 as a PE.

Below are some of the configs for the devices:

3750ME-pe1#show run int vlan10
Building configuration...

Current configuration : 121 bytes
!
interface Vlan10
description *****

no ip address
mpls ip
  xconnect 172.24.100.1 1714 encapsulation mpls
end
3750ME-pe1#

7606-pe1#show run int vlan 1714
Building configuration...

Current configuration : 107 bytes
!
interface Vlan1714
description *****
mtu 1546
no ip address
mpls ip
xconnect vfi *****
end

7606-pe1#

7606-pe1#show run int g2/31
Building configuration...

Current configuration : 270 bytes
!
interface GigabitEthernet2/31
description Client-3550-001_Fa0/24
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 556,610,997,1700-1705,1707-1709,1713,1714,1716
switchport trunk allowed vlan add 1725-1727
switchport mode trunk
end

7606-pe1#

This is the ouput from the client switch attached to a trunk port on the 7606

client-3550-001#show run int fa0/24
Building configuration...

Current configuration : 240 bytes
!
interface FastEthernet0/24
description 7606-pe1_4/31
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 556,610,997,1700-1705,1707-1709,1713,1714,1716
switchport trunk allowed vlan add 1725-1727
switchport mode trunk
end

client-3550-001#

client-3550-001#show spanning-tree vlan 1714

VLAN1714
  Spanning tree enabled protocol rstp
  Root ID    Priority    34482
             Address     000e.d766.6880
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    34482  (priority 32768 sys-id-ext 1714)
             Address     000e.d766.6880
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Fa0/24              Desg BKN*19        128.24   P2p *PVID_Inc


client-3550-001#


Dec 11 07:32:05.256 EST: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 10 on FastEthernet0/24 VLAN1714.
Dec 11 07:32:05.256 EST: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet0/24 on VLAN1714. Inconsistent local vlan.

Thanks.

--- Dominique

5 REPLIES
VIP Super Bronze

Re: VLAN Translation with MPLS xconnect

Hi Dominique,

3750s only support VRF lite but not MPLS.

Please refer to this documet for more info

http://www.cisco.com/en/US/docs/solutions/Enterprise/Network_Virtualization/PathIsol.html

HTH

Reza

Community Member

Re: VLAN Translation with MPLS xconnect

Hi Reza,

Thanks for the reply.

I guess I should have stated that this is a 3750 Metro switch (ME-C3750-24TE-M). This switch connect to one of our P boxes via the ES ports. What I'm trying to build is an EoMPLS xconnect over SVI. I do agree that on "regular" 3750s MPLS isn't supported.

Hope that helps

Thanks.

-- Dominique

VIP Super Bronze

Re: VLAN Translation with MPLS xconnect

Hi Dominique,

Thanks for clarification.

On the 3750-ME, are you using the SFP ES ports?

I believe those are the only 2 ports that support layer-2 layer-3 MPLS/VPN

Reza

Community Member

Re: VLAN Translation with MPLS xconnect

Yup.

The "uplink" port is on g1/1/1 for this 3750 which connect to a port on an ES20 in a 7606

Thanks.

-- Dominique

Hall of Fame Super Silver

Re: VLAN Translation with MPLS xconnect

Hello Dominique,

I remember a feature called vlan rewrite in EoMPLS on GSR routers.

looking at feature navigator

Subinterface to EoMPLS VC Mapping

I think that if this is similar to vlan rewrite you may be able to setup the VC.

This feature is supported on C7600 side with sup720

Sub-interface Xconnect, also called VLAN-edge Xconnect

Sub-interface Xconnect differs from Interface Xconnect because the ingress port is a trunk (such as dot1Q). The switch removes the 1Q header, extracts the VLAN number, determines the associated sub-interface, and performs the cross-connect with the associated VLAN at the other side of the network. This simulates VLAN-to-VLAN switching (at long distance through the MPLS network). VLAN renumbering is possible, but it adds complexity to the design.

http://www.cisco.com/en/US/docs/solutions/Enterprise/Data_Center/HA_Clusters/HA_IAF_5.html

For your hardware there are specific commands for ES linecard

see

http://www.cisco.com/en/US/docs/routers/7600/install_config/ES40_config_guide/es40_chap6.html#wp1385107

the rewrite ingress tag command has many options and the 1-to-1 option should be the right one.

Hope to help

Giuseppe

4189
Views
0
Helpful
5
Replies
CreatePlease to create content