Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

VLAN Trunking on LAN

Hello Cisco Gurus

I am having an interesting, albeit, frustrating issue with interoperability between a 3560 48 Port Poe and an HP 5412zl backbone switch. I have 2 VLANS defined 1 is Data and 2 is voice. If I plug a PC and or phone into the HP directly I get a DHCP address for the phone and the PC.

I have a Gigabit uplink port set up

Untagged on the HP for VLAN 1 on the HP side. When I connect a computer to the Cisco switch I can get a computer to get an address but not a phone.

From the switch console I can ping both the computer and phone DHCP servers.

The uplink port is GB 0/1 and the port settings are as follows.

The IP subnet for the phones is 10.55.4.x/24

and data is 10.56.x.x /16

spanning-tree mode mst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

vlan 2

name Voice-vlan

!

!

!

!

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2

switchport mode trunk

switchport voice vlan 2

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust cos

auto qos voip trust

spanning-tree portfast

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-2056

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust cos

auto qos voip trust

I tried hard coding a PC using a 10.55.4.x address and I couldn't ping a thing. If I get a DHCP address on a PC I can ping both 10.55.4 and 10.56.x.x addresses. Its like the Cisco device is totally unaware of the existance of VLAN 2. Any ideas and or suggestions would be extremely helpful. This limitation is holding up a project already behind schedule. Thank you in advance for your feedback.

2 REPLIES
Purple

Re: VLAN Trunking on LAN

Don't know much about hp but on cisco user ports you do not need "switchport mode trunk" when you are using the switchport voice vlan option I believe. Try pulling that and see if it makes any difference. Don't think there should be any trunk parameters on the user port , someone correct me if I am wrong .

http://cisco.com/en/US/docs/switches/lan/catalyst3560/software/release/12.1_19_ea1/configuration/guide/swvoip.html

New Member

Re: VLAN Trunking on LAN

Try with this conf:

int fast 0/1

switchport access vlan 2

Plug a PC in port 1 and look if it can contact the voice DHCP server.

http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_25_see/command/reference/cli3.html#wpmkr2561799

221
Views
0
Helpful
2
Replies
CreatePlease to create content