Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

vlan trunking setup on cisco switch

Hi Guys,

I'm trying to diagnose a trunk port issue on a switch.

There is a vlan 60 and vlan 100 setup however devices in vlan 60 doesn't seem to be able to ping the router interface in the same subnet.

the switch configs are below, the uplink to the router only mentions vlan100 and nothing about vlan60, does the putting the switchport in trunk mode normally allows all vlans?

Thanks for your help.

 

interface FastEthernet0/6
 description Video Conferencing Ports
 switchport access vlan 60
 switchport mode access
 switchport voice vlan 100
 srr-queue bandwidth share 10 10 60 20
 priority-queue out
 mls qos trust cos
 auto qos voip trust
 spanning-tree portfast
 spanning-tree bpduguard enable
!
interface FastEthernet0/7
 description Video Conferencing Ports
 switchport access vlan 60
 switchport mode access
 switchport voice vlan 100
 srr-queue bandwidth share 10 10 60 20
 priority-queue out
 mls qos trust cos
 auto qos voip trust
 spanning-tree portfast
 spanning-tree bpduguard enable

!
interface GigabitEthernet0/1
 description connection to wan router
 switchport mode trunk
 switchport voice vlan 100
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 auto qos voip trust
!
interface GigabitEthernet0/2
 description connection to wan router
 switchport mode trunk
 switchport voice vlan 100
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 auto qos voip trust
 spanning-tree portfast

 

 

4 REPLIES
Community Member

Hi,Yes, by default all VLAN's

Hi,

Yes, by default all VLAN's are permitted across a trunk.

Is the routers interface configured as a trunk?

Martin

Hall of Fame Super Gold

I agree with Martin that

I agree with Martin that normally a trunk is allow all VLANs to be carried. You can verify this on the switch using the command show interface trunk.

 

Martin asks a good question about whether the router interface is configured as a trunk. The switch trunk will have VLAN 1 as the native VLAN and send untagged frames for VLAN 1 while all frames for VLANs 60 and 100 will be tagged frames. Without dot1Q processing specified on the router interface it will not be able to process these VLANs.

 

HTH

 

Rick

Community Member

Hi Martin and Rickthanks for

Hi Martin and Rick

thanks for your reply, the trunking has been configured on the router, included a snapshot of the router config. Initially there was already trunk port working as VLAN100 was existing and thats working, it was only vlan 60 thats recently been added and its not working.

Was there any issues with the switch configurations that I posted before?

interface FastEthernet0/1.1
description LAN
encapsulation dot1Q 1 native
ip address 172.25.87.133 255.255.255.252 secondary
ip address 10.10.120.254 255.255.255.0
ip helper-address 10.10.20.40
ip helper-address 10.30.10.21
ip helper-address 10.10.120.2
service-policy input PM-CLASSIFY-IN
!
interface FastEthernet0/1.60
encapsulation dot1Q 60
ip address 10.60.120.254 255.255.255.0
service-policy input PM-CLASSIFY-IN
!
interface FastEthernet0/1.100
encapsulation dot1Q 100
ip address 10.20.120.1 255.255.255.0
service-policy input PM-CLASSIFY-IN
!
 

 

Hall of Fame Super Gold

Thanks for providing the

Thanks for providing the router configuration of the interfaces that are trunking. I do not see any obvious problems with the router config or with the switch config. Would you post the output of show ip interface brief from the router and the output of show interface trunk from the switch?

 

I am curious about your comment that vlan 100 already existed and worked. In the switch config it is the voice vlan. Was it always the voice vlan? If vlan 60 is recently created what was the data vlan on the switch interfaces before?

 

HTH

 

Rick

143
Views
0
Helpful
4
Replies
CreatePlease to create content